Crashes when I try to run or open chm file

Bug #34610 reported by ZhengPeng Hou on 2006-03-12
14
Affects Status Importance Assigned to Milestone
kchmviewer (Ubuntu)
Medium
Kubuntu Bugs

Bug Description

Dapper on ppc , upgrade daily , zh_CN locales kubuntu
backstrace message as below:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 805450256 (LWP 9430)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5 0x0da86728 in raise () from /lib/libc.so.6
#6 0x0da88124 in abort () from /lib/libc.so.6
#7 0x0ea8ac18 in qFatal () from /usr/lib/libqt-mt.so.3
#8 0x1002ca40 in QMemArray<char>::detach ()
#9 0x1002e3e4 in QMemArray<char>::detach ()
#10 0x1001ddf0 in QValueList<QString>::detachInternal ()
#11 0x1001f468 in QValueList<QString>::detachInternal ()
#12 0x1001f82c in QValueList<QString>::detachInternal ()
#13 0x0e6e2f84 in QWidget::event () from /usr/lib/libqt-mt.so.3
#14 0x0e7f5cec in QMainWindow::event () from /usr/lib/libqt-mt.so.3
#15 0x0e5ffdc0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#16 0x0e600d58 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#17 0x0f02a190 in KApplication::notify () from /usr/lib/libkdecore.so.4
#18 0x0e5672bc in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#19 0x0e6dea80 in QWidget::show () from /usr/lib/libqt-mt.so.3
#20 0x0e7f81d8 in QMainWindow::show () from /usr/lib/libqt-mt.so.3
#21 0x0f36f538 in KMainWindow::show () from /usr/lib/libkdeui.so.4
#22 0x1002c6a4 in QMemArray<char>::detach ()
#23 0x0da7090c in __libc_init_first () from /lib/libc.so.6
#24 0x0da7090c in __libc_init_first () from /lib/libc.so.6
#25 0x0da7090c in __libc_init_first () from /lib/libc.so.6

Kenny Duffus (kduffus) on 2006-03-17
Changed in kchmviewer:
assignee: nobody → kubuntu-team
ZhengPeng Hou (zhengpeng-hou) wrote :

this crash still exist on dapper beta(fresh install).

Changed in kchmviewer:
status: Unconfirmed → Confirmed

Running on Kubuntu Dapper powerpc

1. What do you mean by "running a CHM file" ?
2. Did you try it on several CHM files or just one file ?

Changed in kchmviewer:
status: Confirmed → Needs Info
ZhengPeng Hou (zhengpeng-hou) wrote :

1 run mean start kchmviewer
2 this bug was confirmed by others, and this bug can be reprodeuced on
ppc,but not i386.

2006/9/1, Ahmed El-Mahmoudy <email address hidden>:
> 1. What do you mean by "running a CHM file" ?
> 2. Did you try it on several CHM files or just one file ?
>
> ** Changed in: kchmviewer (Ubuntu)
> Status: Confirmed => Needs Info
>
> --
> Crashes when I try to run or open chm file
> https://launchpad.net/bugs/34610
>

ZhengPeng Hou (zhengpeng-hou) wrote :

still can be reproduced under feisty

William Grant (wgrant) on 2007-04-05
Changed in kchmviewer:
status: Needs Info → Confirmed
Richard Johnson (nixternal) wrote :

Can anyone reproduce this on Gutsy using the 3.1.2 release of kchmviewer?

Richard Johnson (nixternal) wrote :

Closing this report due to not being able to reproduce it, as well as the lack of responses. If you feel this is still an issue, I urge you to reopen this report.

I am looking at uploading a beta release from a couple of months ago that seems as stable as the current, maybe this will fix some of the inconsistencies that people have come across. Thank you.

Changed in kchmviewer:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers