loadkeys segfaults with certain arguments in 16.10

Bug #1631504 reported by Jason Conti on 2016-10-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kbd (Ubuntu)
High
Michael Hudson-Doyle

Bug Description

This can be reproduced as follows:

1) Switch to VT 1 (ctrl+alt+f1)
2) run: loadkeys garbage
3) loadkeys will segfault

The problem appears to be with the implicit declaration of xmalloc in loadkeys.c. It is resolved if
#include "xmalloc.h" is added to the top of that file (and in fact all the other source files in kbd that reference xmalloc include that file).

Interestingly xmalloc is resolved without include but the returned pointer seems to get truncated. It doesn't do this if the source is built with gcc 5.4 in 16.04 so maybe it has something to do with gcc 6.2 in 16.10.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: kbd 2.0.3-2ubuntu2
ProcVersionSignature: Ubuntu 4.8.0-19.21-generic 4.8.0-rc8
Uname: Linux 4.8.0-19-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Oct 7 15:27:58 2016
InstallationDate: Installed on 2016-10-06 (1 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20161006)
SourcePackage: kbd
UpgradeStatus: No upgrade log present (probably fresh install)

Jason Conti (jconti) wrote :
Jason Conti (jconti) wrote :

Noticed that the code causing the crash is only in the Ubuntu package, specifically debian/patches/loadkeys_ckbcomp.diff, so I refreshed the patch with the include and made a debdiff.

The attachment "loadkeys_fix_implicit_xmalloc.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in kbd (Ubuntu):
importance: Undecided → High
Michael Hudson-Doyle (mwhudson) wrote :

Hi, thanks for the patch! I've uploaded it to zesty. I don't know if it counts as severe enough to be SRUed to yakkety, can start that process if you think it is :)

Changed in kbd (Ubuntu):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
status: New → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kbd - 2.0.3-2ubuntu3

---------------
kbd (2.0.3-2ubuntu3) zesty; urgency=medium

  * debian/patches/loadkeys_ckbcomp.diff: Include xmalloc.h to avoid implicit
    declaration causing crashes with newer gcc. LP: #1631504.

 -- Jason Conti <email address hidden> Thu, 13 Oct 2016 13:51:28 -0400

Changed in kbd (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers