FTBFS in maverick. Error: 'mkdir' was not declared in this scope

Bug #611867 reported by Gursimran singh
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kball (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: kball

Error: 'mkdir' was not declared in this scope

Use man 2 mkdir

Tags: patch

Related branches

Revision history for this message
Gursimran singh (simar) wrote :
Revision history for this message
Bhavani Shankar (bhavi) wrote :

Hello mohar!

here is a review of your patch!

1. why are you reverting the debian patch level change in the patch?

2. There is no mention of maintainer with @ubuntu.com mail address (Hint: use update-maintainer from the ubuntu dev tools package to set Maintainer field)

3. AFAIK there is no need of including <sys/types.h> as <sys/stat.h> includes definition for mkdir function so the patch will reduce further

keeping the above points in mind I have reworked and I have pasted my own patch for your reference

regards

Changed in kball (Ubuntu):
status: New → Confirmed
Revision history for this message
Gursimran singh (simar) wrote :

Thanks Bhavani for your review. I'm new to patching, hope to learn how things setup soon.

I would be glad if you could have a look at one more FTBFS that I have fixed today at #602134

Revision history for this message
Gursimran singh (simar) wrote :

Bhavani, I have one doubt. In both the packages uses quilt patch system. In this regard, should we pop all patches before making a debdiff, as while extracting the source the all quilt patches are applied automatically.. or we have to push all patches before making a debdiff..

If we pop all patches we can have small debdiff..

Revision history for this message
Bhavani Shankar (bhavi) wrote :

hello mohar!

already reviewed that bug :) and yes you need to push the patch to test weather it applies cleanly or not and then pop out all the patches since they are applied during build on the buildd via debian/rules magic :)

See:

https://wiki.ubuntu.com/PackagingGuide/Howtos/Quilt

regards

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kball - 0.0.20041216-6ubuntu1

---------------
kball (0.0.20041216-6ubuntu1) maverick; urgency=low

  * debian/patches/10_add_missing_headers.patch:
    + Add missing headers to fix "mkdir" not found error and hence
      FTBFS with gcc 4.5 (LP: #611867)
 -- Bhavani Shankar <email address hidden> Sat, 31 Jul 2010 11:29:39 +0530

Changed in kball (Ubuntu):
status: Confirmed → Fix Released
tags: added: patch
Revision history for this message
Gursimran singh (simar) wrote :

@Bhavi

Seems everything is fine now with the bug.. but for my more proper understanding ..

"why are you reverting the debian patch level change in the patch?"

Regarding your words above..

I have studied the debdiffs. What does you mean really, I did not get. I would be happy if you could be generous to explain these a bit more.

Thanks

Revision history for this message
Bhavani Shankar (bhavi) wrote : Re: [Bug 611867] Re: FTBFS in maverick. Error: 'mkdir' was not declared in this scope

Hello again!

if you take a close look at the patch all the patches are with a
directory level change

i.e *.patch -p1

but you reverted that change in your patch :)

regards

On Mon, Aug 2, 2010 at 6:44 PM, Gursimran singh Mohar
<email address hidden> wrote:
> @Bhavi
>
> Seems everything is fine now with the bug.. but for my more proper
> understanding ..
>
> "why are you reverting the debian patch level change in the patch?"
>
> Regarding your words above..
>
> I have studied the debdiffs. What does you mean really, I did not get. I
> would be happy if you could be generous to explain these a bit more.
>
> Thanks
>
> --
> FTBFS in maverick. Error: 'mkdir' was not declared in this scope
> https://bugs.launchpad.net/bugs/611867
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “kball” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: kball
>
> Error: 'mkdir' was not declared in this scope
>
> Use man 2 mkdir
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/kball/+bug/611867/+subscribe
>

--

Bhavani Shankar.R
https://launchpad.net/~bhavi, a proud ubuntu community  member.
What matters in life is application of mind!,
It makes great sense to have some common sense..!

Revision history for this message
Gursimran singh (simar) wrote :

Now I got it!!!
Thanks Bhavi

Revision history for this message
Gursimran singh (simar) wrote :

@ bhavi

Pease have a look at the following bug also LP: #602134. I think you are not subscribed to it.

Revision history for this message
Gursimran singh (simar) wrote :

@bhavani
Sorry for so many repeating comments but I think you did not comment. See bug LP: #602134 again ..

Revision history for this message
Bhavani Shankar (bhavi) wrote :

done :)

regards

On Mon, Aug 2, 2010 at 8:29 PM, Gursimran singh Mohar
<email address hidden> wrote:
> @bhavani
> Sorry for so many repeating comments but I think you did not comment. See bug LP: #602134 again ..
>
> --
> FTBFS in maverick. Error: 'mkdir' was not declared in this scope
> https://bugs.launchpad.net/bugs/611867
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “kball” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: kball
>
> Error: 'mkdir' was not declared in this scope
>
> Use man 2 mkdir
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/kball/+bug/611867/+subscribe
>

--

Bhavani Shankar.R
https://launchpad.net/~bhavi, a proud ubuntu community  member.
What matters in life is application of mind!,
It makes great sense to have some common sense..!

Revision history for this message
Artur Rona (ari-tczew) wrote :

Bhavani, I'm sad that you again didn't credit patch's author in debian/changelog...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers