kdeinit4 crashed with SIGSEGV in QListData::remove()

Bug #1023231 reported by Scott Kitterman
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kamera (Ubuntu)
Medium
Unassigned

Bug Description

It looks like kdeinit4 failed to open something when I tried to connect to a media device using mtp.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: kdelibs-bin 4:4.8.4a-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic-pae 3.2.19
Uname: Linux 3.2.0-26-generic-pae i686
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
CrashCounter: 1
Date: Tue Jul 10 21:58:03 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/kdeinit4
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
ProcCmdline: kdeinit4:\ kio_kamera\ [kdeinit]\ camera\ local:/tmp/ksocket-username/klauncherMT1767.slave-socket\ local:/tmp/ksocket-username/dolphinZb3728.slave-socket
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb5ee3f14 <__run_exit_handlers+68>: mov 0x8(%edx),%edx
 PC (0xb5ee3f14) ok
 source "0x8(%edx)" (0x9009bbd8) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: kde4libs
StacktraceTop:
 QListData::remove (this=0xbfb47f60, i=0) at /usr/include/i386-linux-gnu/bits/string3.h:58
 QListData::erase (this=0xbfb47f60, xi=0x87e44dc) at tools/qlist.cpp:412
 ?? () from /usr/lib/kde4/kio_kamera.so
 ?? () from /usr/lib/kde4/kio_kamera.so
 ?? () from /usr/lib/kde4/kio_kamera.so
Title: kdeinit4 crashed with SIGSEGV in QListData::remove()
UpgradeStatus: Upgraded to precise on 2012-04-09 (92 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare syslog wireshark
XsessionErrors:
 (process:1909): GLib-GIO-WARNING **: Received property menu with type s does not match expected type o in the expected interface
 (process:1909): GLib-GIO-WARNING **: Received property menu with type s does not match expected type o in the expected interface

Revision history for this message
Scott Kitterman (kitterman) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde4libs (Ubuntu):
status: New → Confirmed
affects: kde4libs (Ubuntu) → kamera (Ubuntu)
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 QListData::remove (this=0xbfb47f60, i=0) at /usr/include/i386-linux-gnu/bits/string3.h:58
 QListData::erase (this=0xbfb47f60, xi=0x87e44dc) at tools/qlist.cpp:412
 erase (it=..., this=0xbfb47f60) at /usr/include/qt4/QtCore/qlist.h:466
 removeLast (this=0xbfb47f60) at /usr/include/qt4/QtCore/qlist.h:287
 takeLast (this=0xbfb47f60) at /usr/include/qt4/QtCore/qlist.h:493

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in kamera (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Revision history for this message
Scott Kitterman (kitterman) wrote : Please test proposed package

Hello Scott, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in kamera (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Scott Kitterman (kitterman) wrote :

Kamera (which is not surprising since it's only slightly maintained) still does not handle a Samsung Galaxy S III very well, but at least it doesn't crash now, so this particular bug seems fixed.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kamera - 4:4.8.5-0ubuntu0.1

---------------
kamera (4:4.8.5-0ubuntu0.1) precise-proposed; urgency=low

  [ Scott Kitterman ]
  * New upstream bugfix release (LP: #1047417)

  [ Felix Geyer ]
  * Add quote_unquote_path_components.patch (cherry-picked from upstream)
    to avoid crashes in kameras which contain '/' in their names.
    (LP: #1023231)
 -- Felix Geyer <email address hidden> Fri, 07 Sep 2012 21:17:21 +0200

Changed in kamera (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers