Kaffeine crashes konqueror when trying to play embedded movies

Bug #5346 reported by Bart Verwilst on 2005-12-03
24
Affects Status Importance Assigned to Milestone
kaffeine (Ubuntu)
Medium
Kubuntu Bugs

Bug Description

Whenever i try to play an embedded movie, kaffeine gives these messageboxes: "Can't init Audio Driver 'alsasink' - trying another one...", "Can't init Video Driver 'xvimagesink' - trying another one...", "No useable video-driver found! (xvimagesink)" After this third message box, konqueror disappears... I can play files when kaffeine is started standalone just fine...

Thanks!

Changed in kaffeine:
assignee: nobody → kubuntu-team
Jonathan Jesse (jjesse) wrote :

I am getting the same issue w/ Konqueror in both Breezy and Dapper Flight2.

Florian Jensen (florian.jensen) wrote :

Same problem here!! Please fix it asap!

Michel Favreau (michel-favreau) wrote :

Same problem. Crash whenever rightclicking on a video file (any type) in Konqueror and selecting "preview with GstreamerPart".

Kubuntu breezy fresh install.

Also on Dapper Flight CD 3 Live.

Seems to me the same bug as # 24568.

Michel Favreau (michel-favreau) wrote :

Another addition : same problem also with Breezy live CD. Just boot the CD, and do the test: Take any video file (there are two in usr/share/apps/k3b/extras/), right-click and select "preview in kaffeine Gstreamer.

This bug can really not be called unconfirmed.

Bart Verwilst (verwilst) on 2006-02-15
Changed in kaffeine:
status: Unconfirmed → Confirmed
Craig Duquette (cduquette) wrote :

This bug occurs when the Kaffeine-mozilla backend doesn't have kaffeine-xine available to it. It attempts to use gstreamer for the backend, and gives this error to my knowledge.

Michel Favreau (michel-favreau) wrote :

I can't agree with you because, as said before, this happens with the regular kubuntu breezy live-cd which doesn't implement neither mozilla nor kaffeine-mozilla.

Alex Perry (perry-alex) wrote :

Same thing here, it crashes if any format video is played embedded in konqueror. Doesn't actually crash until the browser is closed.

KDE 3.5.1
Kaffeine 0.7.1

Rocco Stanzione (trappist) wrote :

The problem persists in kde3.5.2

Jonathan Jesse (jjesse) wrote :

Flight6 with the latest updates has the same problem. I usually download the movies instead of watching them from the webpage.

Anthony Mercatante (tonio) wrote :

The problem should be resolved with latest version of kubuntu-default-settings.
Let's hope upload is approved !

Changed in kaffeine:
status: Confirmed → Fix Committed
Jonathan Riddell (jr) on 2006-06-27
Changed in kaffeine:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers