DVB-T play fail with error

Bug #404970 reported by Giovanni Bortolozzo on 2009-07-26
88
This bug affects 16 people
Affects Status Importance Assigned to Milestone
kaffeine (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kaffeine

Kaffeine detect my DVB-T card, it can scan and find the channels, but when I try to see one I get this messagebox

   "Cannot find demultiplexer plugin for the given media data"

In console (when I launch kaffeine from command line) I get

    demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.
    demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.

ProblemType: Bug
Architecture: i386
Date: Sun Jul 26 20:19:37 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: kaffeine 1.0~pre1+svn976487-0ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
SourcePackage: kaffeine
Uname: Linux 2.6.31-4-generic i686

Haglund (mathias-haglund) wrote :

You need to install libxine1-ffmpeg if you want to watch DVB on any xine-based player

Thanks.

Then I suppose that kaffeine should (at least) suggest libxine1-ffmpeg, since anyway one of its mayor function it's broken.

Uhm, at first seem to works, that is a can see a channel, but after some zapping (two or three channels) it fail again with the same error... this evening I will try investigate

Spang (hetkot) wrote :

I have the same problem now in Karmic alpha 64 bit.
Had to install phonon-xine-backend manually to fix first problem. ("Cannot open stream")

And now I'm getting this error and same console output. No playback at all, even the first time (no zapping yet).
When I access the dvb tuner with xine-gui it does work. And libxine1-ffmpeg was already present.

Spang (hetkot) wrote :

Update:

A reboot allowed me to open one channel.

Spang (hetkot) wrote :

Another update (sorry, don't mean to spam):

Updating to beta state has put me in the same situation of being to zap a few times, while it works perfectly. Afterwords it returns the same error.

Spang (hetkot) wrote :

I'm happy to participate in the beta improvement. In my opinion, the way you find the most bugs is by using the beta as primary system. I don't mind the beta hick-ups and I don't mind reporting them. But when I want to sit back and watch some tv, or record a show, I would like it to somewhat work. Having to reboot every time I change the channel is a bit much for me, even with the very quick boot times of Karmic ;) .

I don't want to disrespect all the hard work that is put in to the rewrite of Kaffeine and the packaging effort, but maybe the time for the new Kaffeine in the Ubuntu repository hasn't just come yet.

For now, for me I solved the problem by downgrading to the jaunty version of Kaffeine, until the new version is fixed. To do this I:

 * Uninstalled Kaffeine
 * I fetched the debian-package from http://packages.ubuntu.com/jaunty/kde/kaffeine
 * Installed it (simple double click does the trick these days)
 * Locked the version with synaptic, so the update manager ignores it

Maybe this is helpful for others in the same situation.

toams (toams) wrote :

searching google for this bug, and found this debian bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=547938.

It seems the solution is not double clicking on the channels! I tested it and it works for me.

this bug should also be solved in SVN.

Regards,

Tomas

Changed in kaffeine (Ubuntu):
status: New → Confirmed

The problem seems to be kdebase-runtime, it depends on
phonon-backend-xine | phonon-backend
and phonon-backend-gstreamer (universe) provides phonon-backend so if its installed before installing kdebase-runtime, a dependancy of kaffeine, then the xine backend isnt installed and kaffeine fails on dvb without it being clear why. Its a problem, is the best solution,
- Make kaffeine give a better explanation of the failure so user can fix
- Remove the phonon-backend option from kdebase-runtime and therefore force xine
- Remove the 'provides phonon-xine' from the gstreamer backend

This will cause tears if we dont do one or the other before release, its a bit cryptic as it is

oh, or we could add phonon-backend-xine as a direct dependency of kaffeine too i suppose

i guess that still leaves you with the libxine1-ffmpeg problem. Maybe just a more informative error message from kaffeine (or the phonon backend) is whats needed

I can confirm this bug... and i can zap between channels if i just click once. If i click double like in the previous version, i get the error ;)

I think it's a kaffeine regression

Spang (hetkot) wrote :

I have tested it a few times, mainly because some (partial distribution) upgrades tend to ignore the locked version. The non double clicking of the channels does not prove to be a reliable solution here.
Also the Kaffeine rewrite is missing some features I'm very keen on, like minimal mode and minimize to tray on close.

wonder75 (wonder75) wrote :

yes, where is the minimal mode?
kaffeine is useless without it. can't watch tv...

wonder75 (wonder75) wrote :

basicly the whole "View"-menu is missing.
Minimal mode used to have the hotkey "M".
Thats Mute now. Minimal mode didn't make it in the shortcut list as well.
Thats really not good, because you can't hide the channel pane anymore when watching tv.

Spang (hetkot) wrote :

That's not entirely true. If you can live with the tab bar on the left the buttons in the bottom an the menu on the top. You can just click on the "kaffeine tab" in the tab bar. Then you just get a playing window with the three mentioned features.

If you, like me, can't live with the missing features, in an earlier post I mentioned how you can install Kaffeine 0.8.7.

Leandro (leandro-pangea) wrote :

It affects to me too. I reinstalled Kaffeine 0.8.7 but same problem, different error message. Same error in demux_wavpack

John Vale (vale691) wrote :

On updating from 9.10 beta to final release Karmic Koala, Kaffeine (version 1.0-pre2) failed with "Cannot find demultiplexer plugin for the given media data" so as you advised I installed " libxine1-ffmpeg" now working ok Thanks.

Spang (hetkot) wrote :

I'm guessing 0.8.7 needs the same "libxine1-ffmpeg" package for demultiplexing.

Spang wrote:
> I'm guessing 0.8.7 needs the same "libxine1-ffmpeg" package for
> demultiplexing.
>
I guess so.

Even though libxine1-ffmpeg was already installed, a reinstall fixed the
problem for me:

sudo apt-get --reinstall install libxine1-ffmpeg

Leandro.

Bruce R (bm007a0030) wrote :

Kaffeine 1.0-pre2 as added to the 29oct2009 release by Software Center scanned very well, quickly and correctly detecting recent channel changes not detected by previous versions of Kaffeine but would not play, displaying the 'Cannot find demultiplexer plugin' Error message.

Synaptic search for "libxine1-ffmpeg" revealed non-installation by the Software Center.

First-Time installation then solved the problem, with FreeView reception working very well, so I guess that it's all down to a Software Center, Kaffeine dependency handling problem ?

Peter B. (puk007-gmail) wrote :

I'm affected as well by this one reported in original bug report text (having karmic final),
I just wonder, why codec autoinstall is not started that would process this problem nice way
another solution would be to simply add dependency to libxine1-ffmpeg for kaffeine package

I believe ubuntu is on a great way to non-tech people using it, this would be another easy solution for blocking point for some people

VSN (vsn-inbox) wrote :

Hi!

Ubuntu 9.10 final, DVB-T USB, Kaffeine 1.0-per 2.

The same problem: "Cannot find demultiplexer plugin for the given media data". I have also a DVB-S (PCI) card and it works perfectly.

I have just tested the way toams posted: It seems the solution is not double clicking on the channels! It works for me too!!!!

PS I had to install the libxine1-ffmpeg manually too, it would be great if this would work somehow automaticly.

Regards,
VSN

VSN (vsn-inbox) wrote :

[UPDATE]
on Ubuntu 10.04 RC the bug regarding double click is fixed. I supposed because kaffeine doesn't use phonon any more.
But you still have to install libxine1-ffmpeg manually in order to be able to watch DVB.

PS Kaffeine Version 1.0-svn3

VPablo (villumar) wrote :

I think this bug is fixed and can be closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.