[libdvdcss missing] Error message unclear

Bug #37264 reported by Didier Raboud on 2006-03-30
30
Affects Status Importance Assigned to Milestone
kaffeine (Ubuntu)
Medium
Unassigned

Bug Description

Kubuntu Dapper Flight 5 Up2Date

Well. I'm trying to read a DVD. So got it in reader: Window plops proposing to read it with Kaffeine. OK.

I got two errors (exactly the same errors with menu entry : "Read DVD")
------------------------
The source can't be read.
Maybe you don't have enough rights for this, or source doesn't contain data (e.g: no disc in drive). (system:/media/hdc)
------------------------

Then
-----------------------
No plugin found to handle this resource (dvd:/)
-----------------------

[Details] give me that (not translated in french indeed):
-----------------------
xine: cannot find input plugin for MRL [dvd:/]
xine: input plugin cannot open MRL [dvd:/]
xine: found input plugin : DVD Navigator
demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "demux_avi: invalid avi chunk "video_decoder: no plugin available to handle 'XviD'
xine: found demuxer plugin: AVI/RIFF demux plugin
xine: found input plugin : file input plugin
-----------------------

So I see nowhere the fact that I have to install something.

I personnally know I should get the libdvdcss2 (or any of DeCSS implementations) from some obscure website, but I think that the information the program gives to user is insufficient.

I am very clear about illegality of the libdvdcss2, but is it illegal for Ubuntu to just "mention" it ? Or at least "make allusion to" like in "you should install the appropriate program" or redirect the user to an explaining website (somewhere on Ubuntu.com ?)...

I think that issue should be intensively discussed, because the user is limited without knowing (or understanding) why. If Ubuntu intends to be "all public", it has to be a little less obscure, isn't it ?

P.S. Maybe the answer is in the first error : "Maybe you don't have enough rights for this (...)2

Kenny Duffus (kduffus) on 2006-03-30
Changed in kaffeine:
assignee: nobody → kubuntu-team
Matthew East (mdke) wrote :

libdvdcss is discussed in /usr/share/doc/libdvdread3/README.Debian so to answer your question, no, it is not illegal for Ubuntu to talk about it. You'll find it clearly explained in the Desktop Guide for Ubuntu and Kubuntu 6.06. In fact, libdvdcss2 is not clearly illegal either.

That just clarifies a couple of your questions. However, the uninformative error message sounds like a bug to me, so leaving this bug open.

Ted Treadwell (ttread) wrote :

Confirm, this error message is exactly the same in Kubuntu 6.06 Flight 7.

also confirmed.

Changed in kaffeine:
status: Unconfirmed → Confirmed
Andrew Ash (ash211) wrote :

This bug still appears in Edgy Beta.

Here are some specs that may relate to creating an easy to use way to install these codecs:

--Apparently Mandriva has something just like this: https://wiki.ubuntu.com/LinuxForReal#head-f397f3da0e2dc8d159874f3d5dffa025a7a587b3
--Something similar for Ubuntu: https://wiki.ubuntu.com/UbuntuCommonHooker

The first link seems to be what we're looking for:

"One of the most convenient features of Mandriva Linux is the way it handles commercial DVD movies. Put an encrypted DVD into your DVD-ROM and the Kaffeine video player pops up a window that checks for the required libraries and codecs. If some are not found -- Win32 and libdvdcss are not installed with the distribution because of legal issues in some countries -- you're told where to go to get them. Click the provided links, download the RPMs, install them using Mandriva's software installer, and within five minutes you have DVD and Windows media file playback capabilities."

I think this would clear up the confusing dialog Kaffeine gives to unsuspecting users trying to play a DVD.

Andrew Ash (ash211) wrote :

I think there was a push to get this worked on in Ubuntu with the libgimme codec installer. Can any of this code be used here for Kaffeine?

I'm getting the same error in Kaffeine.

Installation:
- Fujitsu S6410P
- Intel Core 2 Duo,
- RAM: 2Gig
- Linux peter-laptop 2.6.22-10-generic x86_64
- kubuntu Gutsy Gibbon 7.10 Tribe-5
- All updates applied
- Kaffeine v0.8.5
- KDE v3.5.7
- xine codecs installed

The DVD begins to play when first entered or play is pressed. After playing the introduction I get the following error text:

xine Message - kaffeine player
The source can't be read

Maybe you don't have enough rights for this, or source doesn't contain data. (e.g. no disc in drive) (Error reading NAV packet)

Anything else you need, then please let me know.

brendan (talikarng) wrote :

I got the same error in kubuntu 7.04, but this was fixed as soon as I installed libdvdcss2 from medibuntu.

Peter (sunspots) wrote :

Thanks for the feedback.

I tried "apt-get install libdvdcss2" and it told me that it was referenced in another package but did not provide the package details. I also tried with medibuntu and it just gave an error.

I had a look in the Add/Remove Programs and could not find any reference to libdvdcss2.

Any idea where or how I locate it in Gutsy?

brendan (talikarng) wrote :

I don't use gutsy yet but you should be able to install it through aptitude if you add medibuntu to your sources list.

Peter (sunspots) wrote :

Thanks for the info. I did a search around and found this link
https://answers.launchpad.net/medibuntu/+question/7984

Up until Jun 2007 there was no repository for medibuntu.

Will update when I know more.

Changed in kaffeine (Ubuntu):
assignee: Kubuntu Bugs (kubuntu-bugs) → nobody

Peter, has there been an update?

Changed in kaffeine (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for kaffeine (Ubuntu) because there has been no activity for 60 days.]

Changed in kaffeine (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers