Please sync Kadu 0.6.5.1 (universe) from Debian unstable (main)

Bug #306361 reported by Artur Rona on 2008-12-08
12
Affects Status Importance Assigned to Milestone
kadu (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: kadu

Kadu is porting to Qt 4.4.
Old version 0.6.0.2 is based on Qt3, but new version 0.6.5 supports Qt 4.4, so this is good up reason to upgrade for KDE 4.2.

   * New upstream release
   * kadu-kde-modules and kadu-gtk-modules have been removed, since we no longer have any kdelibs/GTK+ dependent modules

Packages are in Debian unstable main

Changelog:
kadu (0.6.5.1-5) unstable; urgency=low

  * Removed debian/patches/05-default_sms-fix.patch and
    debian/patches/06-saveWindowsGeometry-fix.patch -- they've alreadt been
    applied upstream
  * qt4_docking is now linked dynamically (Closes: #515045)
  * Removed "libvlc0-dev | libvlc-dev, and xmms2-dev" from Build-Depends --
    *_mediaplayer modules in their current versions use D-Bus to communicate
    players

 -- Patryk Cisek <email address hidden> Fri, 13 Feb 2009 15:34:33 +0100

kadu (0.6.5.1-4) unstable; urgency=low

  * Added debian/patches/04-config_wizard_no_data_content.patch -- content of
    /usr/share/kadu/modules/data/config_wizard/ should not be empty. It should
    contain some .png files needed by config_wizard module. This patch fixes
    the bug.

 -- Patryk Cisek <email address hidden> Tue, 10 Feb 2009 09:53:19 +0100

kadu (0.6.5.1-3) unstable; urgency=low

  * Changed the order of libvlc-dev and libvlc0-dev in Build-Depends -- sbuild
    failed to build the package when $check_depends_algorithm = "first-only";
    in sbuild.conf was set

 -- Patryk Cisek <email address hidden> Sun, 08 Feb 2009 15:14:36 +0100

kadu (0.6.5.1-2) unstable; urgency=low

  * Moving 0.6.5.1 from experimental to unstable

 -- Patryk Cisek <email address hidden> Mon, 02 Feb 2009 21:30:29 +0100

kadu (0.6.5.1-1) experimental; urgency=low

  * New upstream release
  * Added some external modules: mx610_notify, qt4_docking_notify,
    water_notify, weather
  * Added libvlc-dev (vlc_mediaplayer module), libxmms2-dev
    (xmms2_mediaplayer module) and libdbus-1-dev to Build-Depends
  * Removed debian/patches/04-sound-themes-fix.patch (already applied
    upstream)
 -- Patryk Cisek <email address hidden> Mon, 26 Jan 2009 16:09:31 +0100

kadu (0.6.5-1) experimental; urgency=low

  * New upstream release
  * kadu-kde-modules and kadu-gtk-modules have been removed, since we no
    longer have any kdelibs/GTK+ dependent modules
  * Removed kadu-mozilla man page, moved sounds to kadu-themes, updated
    Kadu Team members list in debian/copyright -- Thanks to Piotr Galiszewski
    (Kadu Team member) for submitting a patch
  * Updated Kadu Team members list in debian/copyright
  * Updated debian/README.source -- Kadu is now cmake based, not autotools
  * Removed Tango icon theme -- its license (CC-SA 2.5) is not DFSG-compliant
  * Channged (C) to © in debian/copyright

 -- Patryk Cisek <email address hidden> Mon, 19 Jan 2009 13:18:49 +0100

Piotr Ożarowski (piotr) wrote :

kadu 0.6.5-1 is available in Debian experimental (and will be moved to unstable soon, i.e. sync shouldn't break anything)

description: updated
description: updated
description: updated
Mario Limonciello (superm1) wrote :

unmarking duplicate if we want an archive admin to see this..

Mario Limonciello (superm1) wrote :

I did a test build, and it doesn't appear to sync well. You sure this shouldn't be a merge?

Strange. This package builds cleanly in Patryk's PPA (https://launchpad.net/~patryk-prezu/+archive/ppa) : http://launchpadlibrarian.net/22447594/buildlog_ubuntu-jaunty-i386.kadu_0.6.5.1-4~ppa2_FULLYBUILT.txt.gz

I pinged Patryk. Maybe he can say something more

Iain Lane (laney) wrote :

Unsubscribing u-u-s. Please resubscribe when there is something to sponsor. Thanks.

Resubscribing u-u-s.

New package kadu-0.6.5.1-5 is available in Debian sid. Build logs for jaunty are available in Patryk's ppa : https://launchpad.net/~patryk-prezu/+archive/ppa/+build/867091

Debian changelog since 0.6.5.1-4:
 kadu (0.6.5.1-5) unstable; urgency=low

   * Removed debian/patches/05-default_sms-fix.patch and
     debian/patches/06-saveWindowsGeometry-fix.patch -- they've alreadt been
     applied upstream
   * qt4_docking is now linked dynamically (Closes: #515045)
   * Removed "libvlc0-dev | libvlc-dev, and xmms2-dev" from Build-Depends --
     *_mediaplayer modules in their current versions use D-Bus to communicate
     players

 -- Patryk Cisek <email address hidden> Fri, 13 Feb 2009 15:34:33 +0100

Please sync. At this time. there shouldn't be any problems :)

Sync request ACKed

(Builds fine here too.)

description: updated
Changed in kadu:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in kadu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments