kactivities must depend on libqt5sql5-sqlite

Bug #1455765 reported by Gard Spreemann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kactivities-kf5 (Ubuntu)
New
Undecided
Unassigned

Bug Description

Without the Qt SQLite database driver (libqt5sql5-sqlite) installed, kactivitymanagerd will core dump. The bug has probably gone undiscovered because kactivities depends on libqt5sql5, which recommends libqt5sql5-sqlite, thereby installing the latter for most people. Those of us not installing recommended packages may in some cases not have the latter installed.

KDE/Plasma does not function as intended without kactivitymanagerd. Installing libqt5sql5-sqlite fixes the problem.

Ubuntu version: 15.04
kactivities version: 5.9.0-0ubuntu1
Suggested fix: Have kactivities depend on libqt5sql5-sqlite

Tags: kubuntu vivid
tags: added: kubuntu vivid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.