k3b 1.0: ripping dvd doesn´t work

Bug #99448 reported by Emanuel Goscinski on 2007-03-31
18
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Undecided
Kubuntu Bugs
Declined for Feisty by Daniel Holbach

Bug Description

Binary package hint: k3b

In Feisty Fawn Beta up-to-date, k3b package: 1.0-0ubuntu1,

This k3b version has an option "rip video dvd" in the extras menu.
When you click on this option with an dvd in your drive only the files on the dvd are shown by k3b. But there should appear an dvd-rip dialog, which guides you through the ripping process.

On the german kubuntu forum was an discussion about this: http://forum.kubuntu-de.org/index.php?topic=8052.0
where a nice man tried to build k3b 1.0 packages for dapper and edgy and had the same problem.

The Solution was to build the packages again with support for libdvdread.

Maybe this could be fixed...

Thank you for your good work. Greetings
emu

Matt Hubert (matt-cfxnetworks) wrote :

I can reproduce the problem.

Changed in k3b:
status: Unconfirmed → Confirmed

assigning to you because you are the maintainer of this package. And non of the developers has noticed this bug.

Changed in k3b:
assignee: nobody → ubuntu-core-dev

Hi,
there is now a Package which you can eventually use in the repository of Marcus Czeslinski
aka Czessi "deb http://archive.czessi.org/ubuntu feisty main", where the issue is already solved.

Maybe you can just check this and upload it to the official repositories.

Greetings emu

Changed in k3b:
assignee: ubuntu-core-dev → kubuntu-team
Martin Daser (m4rt1n-d453r) wrote :

Hello all,
is this correction included in the Kubuntu Feisty repository?
I checked for updates of the k3b package a few times but did not find any.

Thanks in advance!

Greetings,
    Martin

Matt Sicker (jvz) wrote :

It's not in Feisty, I can assure you. K3b requires transcode installed I believe as well, and since that isn't installed by default (although K3b is), wouldn't it be nice if the program prompted you if you wished to install the applications required to rip DVDs?

New question: is this fixed in Gutsy?

The bug is still here in Gutsy

scido (domi-mailing-list) wrote :

I can confirm this problem with k3b 1.0.4 (backported in gutsy). The program isn't compiled against libdvdread
To resolve this problem install libdvdread-dev and then recompile k3b using:

$ sudo apt-get source --compile k3b

please fix this simple problem with new packages.

regards,
scido

lcampagn (luke-campagnola) wrote :

I've got this problem too. The suggested fix worked, thanks.

Pat Double (patdouble) wrote :

This is still present in Hardy Beta. This is a simple fix, can it please be made into Hardy so we don't have to compile our own package and mark it 'hold' in dpkg?

Hi @all,

I just talked with one of the MOTUs. I asked him if he could fix this for hardy.
But there is a simple rule, which prohibit this:
A package in main (like k3b), is not allowed to depend on a package in universe (like libdvdread). So it is unlikely that, this bug is "easy" to fix because of the packaging policies of kubuntu.
So I set this to "won`t fix", so nobody still wonders why this simple bug, still remains.

uups, I just saw I can`t set this to "won`t fix" it seems this is only allowed for bugcontrol-team.
So please set this to "won`t fix"

Ralph Janke (txwikinger) on 2008-04-01
Changed in k3b:
status: Confirmed → Won't Fix
Rudd-O (rudd-o) wrote :

Could someone with the knowhow add some sort of dlopen() indirection to K3B so we can dlopen() the required functionality and not depend on a universe package?

James (jet57) wrote :

Would an acceptable fix be to provide a second k3b package compiled against libdvdread in the universe repository?

Yes absolutely!

Just make it clear in the details for the packages why there is another k3b in the universe.

How about adding a dialogue that tells the users what is going on when they try using the feature and nothing happens...at all. Something like "this functionality depends on libraries we can't ship in the United State: see ___". Then they could be directed to a page explaining things and, if the opportunity becomes available, be directed to trade the system-installed k3b with the Universe k3b. Something like that would be great since this is something that has people scratchin' their heads. : )

nulll (nu111) wrote :

it's nearly 2009
nearly 2 years are passed since the bug notification and the bug is still there

:( :( :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers