Ubuntu

Add image conversion option to k3b

Reported by Uqbar on 2011-10-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
k3b
New
Wishlist
k3b (Ubuntu)
Wishlist
Unassigned

Bug Description

I need to create just an ISO image with K3b. So I select "simulation" and "create image".
I am only allowed to go on if I insert a usable medium.
I would expect to be able to go on without.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: k3b 2.0.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Mon Oct 31 10:34:53 2011
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 LANGUAGE=
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: k3b
UpgradeStatus: No upgrade log present (probably fresh install)

Uqbar (uqbar) wrote :
tags: added: k3b
description: updated
Alessandro Menti (elgaton) wrote :

The "Create image" option is used to tell K3b that the ISO image should be created entirely on the hard disk before burning instead of being created "on the fly", not to "just create the ISO image". For that there is a checkbox named "Only create image" - select it and you'll notice that K3b will just create the image without burning it.

As this is not a real bug, I'm closing this report as Invalid. Feel free to report any other bugs you find.

Changed in k3b (Ubuntu):
status: New → Invalid
Uqbar (uqbar) wrote :

In some cases, like when burning from an APE image, there's no "Create only image" checkbutton.

Alessandro Menti (elgaton) wrote :

Sorry for my hastiness - I thought you wanted to create an image starting from a data/audio project (in those cases, the "Only create image" checkbox is correctly present). From what you have said, it seems you want to convert CD image formats instead (e.g., convert an APE image to an ISO one). Regarding that issue, you are right; currently, K3b does not offer an option to convert CD/DVD image formats yet (a bug report has already been filed: <https://bugs.kde.org/show_bug.cgi?id=154292>).

If you are referring to that missing feature, please say so, so that I'll be able to confirm the report on the KDE bugtracker (so that the K3b developers will be made aware of that) and to link it to this one. That way, if a new version of K3b that adds the feature is made available, we will include it in Ubuntu.

Again, sorry and thanks for the report.

Changed in k3b (Ubuntu):
status: Invalid → Incomplete
Uqbar (uqbar) wrote :

I said:
> I need to create just an ISO image with K3b. So I select "simulation" and "create image".
I'm not saying anything about the starting point.
So it can be anything. In the specific case it was an APE+CUE image.
This kind of action transforms the APE into a bunch of CDDA/WAW files to be later written to the medium.

Alessandro Menti (elgaton) wrote :

I said you wanted to convert CD image formats because, if you start a new data/audio project *from scratch* and try to burn it (choosing, for example, "File->New Project->New Data Project", dragging and dropping files from the file manager window at the top to the project window at the bottom and then clicking on "Burn"), there is already the checkbox "Only create image" that creates an ISO image for you, without requiring any medium.
What you were trying to do was to create an ISO file from a CD/DVD image file (let it be APE+CUE, BIN or another format) to an ISO file. In the field, these concepts are quite different: while burning a CD/DVD from normal data files requires that an ISO image file is created first (either on the hard drive or on the fly) to encode the data appropriately, APE+CUE/BIN/ISO files are *directly* written to the disk, as they are an exact "dump" of the CD/DVD.

For this reason, these two uses of K3b are implemented as *separate* operations, with separate dialogs. There are two different "starting points" as you call them; one to create a CD from data files, and one to create a CD from an image file.

Also, the words "Simulation" and "Create image" carry a precise meaning in burning programs. "Create image" means that the ISO image file is not created on the fly, and "Simulation" means that the burner tries to simulate a writing on the inserted medium: the disk is rotated at the same speed that would be used for a real writing and data is transferred from the computer to the drive just like it would be if the medium was burned. The simulation is in fact identical to burning, except for the fact that the laser of the drive is turned off: most importantly, it's a "physical" operation. For this reason, those options can not be used to "burn" an APE+CUE image to an ISO file; that's more like converting an image file format to another.

Some programs offer the option to create another image file as a "virtual recorder" that is treated just like a burner, but K3b has decided to use checkboxes in the Burn dialog to implement it. Maybe you were deceived by this fact.

Anyway, I have updated the bug report that I linked before to ask the K3b developers to add conversion support between formats.

Alessandro Menti (elgaton) wrote :

Confirmed change.

Changed in k3b (Ubuntu):
status: Incomplete → Confirmed
Changed in k3b:
importance: Unknown → Wishlist
status: Unknown → New
summary: - k3b requires empty media even for simulation+create image only
+ Add image conversion option to k3b
Changed in k3b (Ubuntu):
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.