K3b temporarily ejects disk before verification

Bug #72609 reported by Boris
76
This bug affects 1 person
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Wishlist
Kenny Duffus

Bug Description

Binary package hint: k3b

When burning with option of checking the written data after burning turned on, after having burned the disk K3b opens the disk tray (ejects disk) then immediatedly closes the tray, and proceed with the task of verification. This is unneeded action which has undesirable side effect (on Kubuntu 6.0.6) that a standard KDE dialog "What you want to do with the unmounted DVD disc?" appears (this dialog normally appears each time a user inserts a disc).

Boris

Revision history for this message
kko (kko) wrote :

If I understand correctly, this is designed as a safety measure to ensure that no caches (operating system cache, CD/DVD drive cache) can possibly interfere with the verification process, and that the data to be verified is really read from the physical disk that was burned. If this is correct, then - for this part - this would seem to be a non-bug. Please correct me if I am wrong.

The side effect of the standard KDE dialog is another issue - and yes, I agree that it would be nice if this dialog didn't appear, in this case.

Kenny Duffus (kduffus)
Changed in k3b:
assignee: nobody → kduffus
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Revision history for this message
Sridhar Dhanapalan (sridhar) wrote :

This eject/reload mechanism doesn't work with non-motorised feed mechanisms, like the CD/DVD trays on most laptops. In those scenarios, the disc is ejected but the user needs to manually re-insert it.

Revision history for this message
mehturt (mehturt) wrote :

I observe the same on my laptop - the tray is open but, of course, not closed automatically. Even if closed by hand, the verification does not continue so I suspect that is a bug in k3b, isn't it?

Revision history for this message
Yakov Markovitch (ymarkovitch) wrote :

Not only verification does not continue after the tray is closed by hand, but in that case k3b completely hangs and should be killed (HP Pavilion zv5340us, AMD64). AFAIK, a sequence of unmount-mount should be enough to ensure all caches are reset, shouldn't it? Unmounting doesn't suppose ejecting. Besides, all decent Windows burners manage to do this w/o ejecting, so I think the problem is not unsurmountable. This bug is extremely annoying for every laptop owner.

Revision history for this message
hasi (whynot-nurfuerspam) wrote :

I can confirm this problem for Kubuntu 7.04 on a Dell Latitude D620 Notebook.
I find something I haven't seen reported in the previous postings: after the disk is finished, I get a window that asks me whether I want to re-load the disk. If I close in the CD tray manually and hit the load button, the verification kicks in normally. The problem is that this has to happen within a few seconds, otherwise K3b reports an error ("No files to verify found on disk", or similar).
I would be perfectly happy if that there was no time out, but K3b would wait for a manual decision from the user: whether to load the CD for verification or whether to cancel and skip verification. This should be fairly simple to implement.
Just my 2 cents.
--hasi.

Revision history for this message
kko (kko) wrote :

I agree with hasi.

There are apparently two issues here:
1) It is, if I understand correctly, acceptable that the CD is ejected, to make sure no cache interferes with the verification process. In this case, the KDE new disk found dialog is unnecessary - but how to disactivate it for this case only?

2) Laptops and other trayless optical drives - the disk is not automatically re-inserted. The suggestion by hasi would be a good way to handle this.

Revision history for this message
flebber (ubuntu-netspace) wrote :

I have two drives LG DVD/Burner and Iomega CD/Burner. After disk remounts after ejecting the verification always fails to complete, only recently has this error started and is for burning cd-image with K3b.

Revision history for this message
flebber (ubuntu-netspace) wrote :

Forgot to add attachment of error in previous post.

Revision history for this message
brucehd (n1hnj) wrote :

I have encountered this same issue using k3b in Hardy Heron x86_64. After the write is complete, k3b commands the drive to eject the tray. I'm only guessing it sends another command to load the tray so it can begin verification. Unfortunately the tray fails to close. Loading the tray manually has no effect. k3b at this time is frozen, driving the CPU% between 50% and 100%, and will not respond to any mouse clicks. I then have to kill k3b from within System Monitor.

This problem has happened with both an LG GSA-4163B (PATA interface) and a Samsung SH-203B (SATA interface).

It should also be noted that the written disc loads and tests fine (using an md5 checksum file I wrote to the disc).

Revision history for this message
KeenEars (fl-blade) wrote :

I have the same on Hardy with my NEC ND3500 - tray ejects before verification, but it is not continued. Tried to launch k3b from terminal - no errors was displayed. It Just stops... Discs are reading fine.

Revision history for this message
KeenEars (fl-blade) wrote :

...Forgot to say that k3b don`t hangs in my case, I still can cancel it from verification.

Revision history for this message
Mario Di Nicola (warp99) wrote :

"I have encountered this same issue using k3b in Hardy Heron x86_64. After the write is complete, k3b commands the drive to eject the tray. I'm only guessing it sends another command to load the tray so it can begin verification. Unfortunately the tray fails to close. Loading the tray manually has no effect. k3b at this time is frozen, driving the CPU% between 50% and 100%, and will not respond to any mouse clicks. I then have to kill k3b from within System Monitor."

I have the exact same problem using x86_64 Kubuntu Hardy.

Revision history for this message
Portable-Jim (christian-chess-geek) wrote :

"I have encountered this same issue using k3b in Hardy Heron x86_64. After the write is complete, k3b commands the drive to eject the tray. I'm only guessing it sends another command to load the tray so it can begin verification. Unfortunately the tray fails to close. Loading the tray manually has no effect. k3b at this time is frozen, driving the CPU% between 50% and 100%, and will not respond to any mouse clicks. I then have to kill k3b from within System Monitor."

Same problem, with one exception:
- Loading the disc quickly back in once it has finished lets K3B continue.

If I do not get the CD back in time, Gnome recognizes the burnt CD and brings up the CD contents. THis leaves K3b hanging as described above.

I don't really care whether or not the drive ejects, as I am on a desktop.

Info:
- Hardy Heron x86_64
- iomega drive
- K3b 1.0.4 (using KDE 3.5.9)

Revision history for this message
Selmi (selmi) wrote :

i have same problem, only in my case k3b doesn't freeze, i can cancel 'verification' and go on. i use hardy, 32bit version.

its extremely annoying and it happens on every pc i have access to. some have atapi dvd-writers, some sata....all are desktops, i never tried it with notebook. and its not only in hardy, the same happened with gutsy and i am ~75% sure that also in feisty. before i don't know

Revision history for this message
hbbk (hbbk) wrote :

hi

Just have to say mee too :)

But more informations here :

K3B open the tray then fail to close it automaticaly, if I close it by hand the DVD icon appear on the desktop and I can open it but K3B seems to be still waiting for the DVD to be loaded. It do not freeze nor get too many cpu, I still can cancel the verification but this is very annoying if I have to burn many copies... Cancelling verification make the tray open (and error message: verification failed of course)

Kubuntu 8.04
K3B 1.0.4

           *-cdrom
                description: DVD writer
                product: DVD_RW ND-3540A
                vendor: _NEC
                ...
                version: 1.01
                serial: [_NEC DVD_RW ND-3540A 1.0105031600
                capabilities: removable audio cd-r cd-rw dvd dvd-r
                configuration: ansiversion=5 status=ready

Revision history for this message
Rémi (pazelty) wrote :

I have an other bug who is not very different :

https://bugs.launchpad.net/ubuntu/+source/k3b/+bug/260440

Revision history for this message
trevor t (launch-etjt) wrote :

Solution:
Try these settings in burn dialog, it worked for me.
    -Writing tab, do not check 'Verify written data'.
    -Misc tab, Multisession Mode, change 'Auto' to 'No Multisession'

Problem:
When set to Verify, and 'Auto', the disc was ejected during verify. Also, the disc was left in a state of 'Appendable Data' instead of 'Complete Data', and only K3b could read it. I tried to add another file and finish the session, but that didn't work either.

K3b 1.0.5
Ubuntu 8.10

Revision history for this message
Martin Zuther (mzuther) wrote :

Hi!

Same problem for me. There's a temporary workaround, though. In "K3b" options, open the "Advanced" tab and mark this:

  [x] Do not eject medium after write process

Damn, this thing has annoyed me for so long, and I had actually forgotten about this setting... Works fine here, even though there might of course be caching issues like kko already mentioned.

Have fun,

Martin

Revision history for this message
HammerHead66 (hollycowbatman23) wrote :

if you are using K3b software if you go into /setting/ go to bottom left click it. then look at bottom left side for advanced left click it. under miscellaneous check " Do not eject medium after write process" it will stop this problem.

Revision history for this message
HammerHead66 (hollycowbatman23) wrote :

update: Altho the first cd burns it is not able to burn more. Please look at this link to find out more thank you. http://paste.ubuntu.com/136191/

Revision history for this message
brucehd (n1hnj) wrote :

The setting, "Do not eject medium after write process," process does exactly what it says. Once the write is complete k3b will hang, not verify the written disk, and the only way to shut it down is to kill the task.

Revision history for this message
MaxFox (m-fox2k) wrote :

same problem after upgrading ubuntu 8.10->9.04.
this feature worked before, and availability of this feature was the reason why i have installed k3b.
cd is mounting if tray closed by hand, but k3b does not begin to check cd, timer is counting up. pressing cancel and no errors in debug info.

checking "Do not eject medium after write process" option solved the problem, after burning media k3b is checking cd.

Revision history for this message
mlg7 (mlg7) wrote :

me too. On a laptop, it ejects the disk and cannot get it back.
Well, I want k3b to have a "VERIFY DISK AGAINST ISO IMAGE" command
because, well... I do not want to create another ISO image just to compare
the result... A better approach would probably be calculation of the MD5
sum of the burned disk, but I think it will sooner do it the hard way than
I find out the clever guy's path.

Revision history for this message
Andy Brook (javahollic) wrote : Re: [Bug 72609] Re: K3b temporarily ejects disk before verification

The following will give you fingerprint info, chalkup under workarounds:

md5sum /dev/cdrom0
md5sum /someplace/myfile.iso

2009/5/26 mlg7 <email address hidden>

> me too. On a laptop, it ejects the disk and cannot get it back.
> Well, I want k3b to have a "VERIFY DISK AGAINST ISO IMAGE" command
> because, well... I do not want to create another ISO image just to compare
> the result... A better approach would probably be calculation of the MD5
> sum of the burned disk, but I think it will sooner do it the hard way than
> I find out the clever guy's path.
>
> --
> K3b temporarily ejects disk before verification
> https://bugs.launchpad.net/bugs/72609
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
Wolfgang Kufner (wolfgangkufner) wrote :

iirc it does not eject anymore before verification. Can anyone confirm that this is now fixed?

Revision history for this message
Timothy Miller (theosib) wrote :

Yes. It appears to lock the door or something so that the disc is not ejected after write so that verify can proceed immediately.

Revision history for this message
Wolfgang Kufner (wolfgangkufner) wrote :

Two people seeing that it is now fixed, none saying it is not. Thank you all. Closing...

Changed in k3b (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments