k3b doesn't find drive because no hal service started

Bug #696286 reported by ZeroBeat on 2011-01-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: k3b

Directly after starting of k3b the program reports that there is no optical drive, because hal service not started.
Take a look at attached picture.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: k3b 2.0.1-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Jan 1 18:27:38 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110101)
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 LC_MESSAGES=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: k3b

ZeroBeat (zerobeat) wrote :
Kaulbach (mystic-scientist) wrote :

Same issue here, not running unity desktop but Kubuntu with KDE 4.5 however. Refreshing the k3b setup page for devices makes my drive visible and then it works, but not during k3b startup. Hal is not running
Linux acer64 2.6.37-11-generic #25-Ubuntu SMP Tue Dec 21 23:42:56 UTC 2010 x86_64 GNU/Linux
K3b Installed: 2.0.1-2ubuntu1
printenv output:
KDE_MULTIHEAD=false
DM_CONTROL=/var/run/xdmctl
MALLOC_CHECK_=3
TERM=xterm
SHELL=/bin/bash
XDM_MANAGED=method=classic
XDG_SESSION_COOKIE=2d5b316597e4d2834d0c76674ab29752-1294066775.926984-1958523718
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/mike/.gtkrc-2.0:/home/mike/.gtkrc-2.0-kde4:/home/mike/.kde/share/config/gtkrc-2.0
KONSOLE_DBUS_SERVICE=:1.49
GS_LIB=/home/mike/.fonts
GTK_RC_FILES=/etc/gtk/gtkrc:/home/mike/.gtkrc::/home/mike/.kde/share/config/gtkrc
WINDOWID=48234553
SHELL_SESSION_ID=a56478d4f30a4000973f29691d8eea42
KDE_FULL_SESSION=true
USER=mike
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
SESSION_MANAGER=local/acer64:@/tmp/.ICE-unix/1597,unix/acer64:/tmp/.ICE-unix/1597
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
DESKTOP_SESSION=kde-plasma
PWD=/home/mike
LANG=en_CA.UTF-8
KDE_SESSION_UID=1000
KONSOLE_DBUS_SESSION=/Sessions/2
HISTCONTROL=ignoreboth
SHLVL=1
COLORFGBG=15;0
HOME=/home/mike
KDE_SESSION_VERSION=4
LANGUAGE=
XCURSOR_THEME=oxy-white
LOGNAME=mike
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-wnii1G0p7B,guid=93d572dc04bf32d547510b9500000058
XDG_DATA_DIRS=/usr/share:/usr/share:/usr/local/share
LESSOPEN=| /usr/bin/lesspipe %s
WINDOWPATH=7
DISPLAY=:0
PROFILEHOME=
QT_PLUGIN_PATH=/home/mike/.kde/lib/kde4/plugins/:/usr/lib/kde4/plugins/
LESSCLOSE=/usr/bin/lesspipe %s %s
_=/usr/bin/printenv

ZeroBeat (zerobeat) wrote :

Problem is solved since update from today.
Best regards
Mike

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers