Ubuntu

k3b uses wrong normalize binary name

Reported by Pär Lindfors on 2006-05-13
28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Medium
Kenny Duffus

Bug Description

Binary package hint: k3b

This is in latest Dapper.

The package normalize-audio (0.7.6-7) in Universe provides the binary /usr/bin/normalize-audio but k3b (0.12.14-0ubuntu5) only accepts a binary named "normalize". k3b should be changed to look for the correctly named binary.

With a symlink named normalize (for example /usr/local/bin/normalize -> /usr/bin/normalize-audio) k3b detects the program and normalization works fine.

Kenny Duffus (kduffus) on 2006-08-12
Changed in k3b:
assignee: nobody → kduffus
jcfp (jcfp) wrote :

confirming, same bug here... very easy to fix so please do.

Kenny Duffus (kduffus) wrote :

when does this occur?

Changed in k3b:
status: Unconfirmed → Needs Info

Kenny Duffus <email address hidden>:

> when does this occur?
>
> ** Changed in: k3b (Ubuntu)
> Status: Unconfirmed => Needs Info
>

Always. Just install k3b (0.12.14-0ubuntu7) and normalize-audio (0.7.6-7)
packages in (k)ubuntu (6.06).

Then check in the k3b options -> Programs:

"normalize" is listed as 'not found' even though it is installed, because
the binaries in the normalize-audio package are named "normalize-audio"
and "normalize-mp3" respectively, while k3b searches the PATH for the
exact name "normalize" only.

Now fixing is trivial, either via k3b settings or creating a symlink, but
it should obviously work out-of-the-box.

Kenny Duffus (kduffus) wrote :

thanks for that extra information, the binary name is supposed to be sorted but this looks like it is missed for this

Changed in k3b:
status: Needs Info → Confirmed
jcfp (jcfp) wrote :

Problem appears to have been fixed in edgy; k3b now looks for 'normalize-audio'.

chemist109 (chemist109) wrote :

In Feisty, K3B looks for 'normalize-audio' but doesn't find it even though it's installed. This seems to be the bug that won't die.

dilmah (dillonloos) wrote :

I can confirm this problem in Feisty as well. I have apt-get install normalize-audio and placed symlinks as follows:
ln -s /usr/bin/normalize-audio /usr/bin/normalize
ln -s /usr/bin/normalize-audio /usr/local/bin/normalize

I have also tried specifing the full path to the binaries in the programs section of the settings.
I have also tried doing a hard link not a symlink.

Nothing seems to work.

Vangelis Tasoulas (cyberang3l) wrote :

dilmah said on 2007-04-13:

I can confirm this problem in Feisty as well. I have apt-get install normalize-audio and placed symlinks as follows:
ln -s /usr/bin/normalize-audio /usr/bin/normalize
ln -s /usr/bin/normalize-audio /usr/local/bin/normalize

I have also tried specifing the full path to the binaries in the programs section of the settings.
I have also tried doing a hard link not a symlink.

Nothing seems to work.

Same problem for me :(
What`s going on??

jcfp (jcfp) wrote :

When debugging k3b, it actually does seem to find normalize-audio if it's in the path, and even execute it with argument "--version"? But after that, it still lists it as 'not found' in the preferences. As for creating a symlink: that was a fix for a previous incarnation of this bug and is not going to work in feisty.

jcfp (jcfp) wrote :

Problem is that when k3b find normalize-audio and executes it with --version, it tries to find the string "normalize-audio" in the output, while the normalize program outputs just "normalize 0.7.7" instead. It seems this problem is caused by a change the "kubuntu_101_rename_normalize.diff" patch makes in k3b-1.0/libk3b/core/k3bdefaultexternalprograms.cpp (around line 734).

After adding a small patch to revert this change and rebuilding the package, k3b had no trouble finding and using normalize.

kimus (kimus) wrote :

I did this hack just for testing:

# vim /usr/bin/normalize-audio

#/bin/bash
case "$1" in
        --version)
                normalize --version | sed -e 's/normalize /normalize-audio /g'
                ;;
        *)
                normalize $*
                ;;
esac

chmod +x /usr/bin/normalize-audio

and now k3b detects normalize :-D

Breuil Cyril (cyrilb856) wrote :

i've done a fix for this. i attach debdiff here

Changed in k3b:
status: Confirmed → Fix Committed
Breuil Cyril (cyrilb856) on 2007-05-31
Changed in k3b:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers