says i do not have permission to use cdrecord

Bug #37423 reported by don hardaway
16
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Medium
Unassigned

Bug Description

I am using a Dell Inspiron 6000. When I try to burn a cd it says I do not have permission to use cdrecord. Strangely, when I attach a usb disk drive, it will let me read it but will not let me write to it saying i do not have permission. When i try to set the permission to write it will not let me and the root is the owner. Using Dapper on my Dell Latitude 800 it works fine with k3b and usb drives. I wonder if it has to do with the io controller on the Inspiron 6000--sata drive is on it.

Revision history for this message
don hardaway (don-hardaway) wrote :

Dapper flight 5

Kenny Duffus (kduffus)
Changed in k3b:
assignee: nobody → kubuntu-team
Revision history for this message
mhanski (ma-han2000) wrote :

see also bug #23544

Revision history for this message
Luka Renko (lure) wrote :

Are you logged under user that was created during installation?
Can you provide output of "id" command?

Your username should be in group "cdrom" to get access to CD/DVD devices.

Changed in k3b:
status: Unconfirmed → Needs Info
Revision history for this message
don hardaway (don-hardaway) wrote : Re: [Bug 37423] Re: says i do not have permission to use cdrecord

here you go:

uid=1000(matt) gid=1000(matt)
groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),106(lpadmin),110(scanner),112(admin),1000(matt)

On 4/11/06, Luka Renko <email address hidden> wrote:
>
> Are you logged under user that was created during installation?
> Can you provide output of "id" command?
>
> Your username should be in group "cdrom" to get access to CD/DVD devices.
>
> ** Changed in: k3b (Ubuntu)
> Status: Unconfirmed => Needs Info
> --
> says i do not have permission to use cdrecord
> https://launchpad.net/malone/bugs/37423
>

--
"Great spirits have often encountered violent opposition from weak minds."
--Albert Einstein

Revision history for this message
don hardaway (don-hardaway) wrote :

OK, found the problem with external usb hard disk. simple fix--file format was ntfs instead of fat32.

The only problem now is still being able to use k3b to burn cds. It does not give me permission to use cdrecord on the Dell Inspiron 6000 with the latest dapper but on my Dell Latitude d800 i can burn cds fine.

Revision history for this message
Barry deFreese (bddebian) wrote :

Don. Is the id command output above from the d800 computer or the Inspiron? Thank you.

Revision history for this message
don hardaway (don-hardaway) wrote :

the inspiron 6000

Revision history for this message
don hardaway (don-hardaway) wrote :

install the latest --flight 7 and did all of the updates and k3b still says i do not have permission to burn. i did dpkg-reconfigure cdrecord and said yes. then i went into setup of k3b and put in cdrom as group and STILL it will not let me burn.

Revision history for this message
Ahmed Kamal (kim0) wrote :
Download full text (3.9 KiB)

Hi,
I cannot use k3b to burn CDs!!
This is the output of "id"
uid=9999(ahmed) gid=100(users) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),100(users),106(lpadmin),110(scanner),111(admin)

k3b asked me to use k3bsetup, I used it, but still it couldn't fix the problem!

It only succeeded, after I used 'kdesu k3b'
-----------
This is the output of k3b debugging

System
-----------------------
K3b Version: 0.12.14

KDE Version: 3.5.2
QT Version: 3.3.6
Kernel: 2.6.15-23-686
Devices
-----------------------
MATSHITA DVD-RAM UJ-841S 1.50 (/dev/scd0, /dev/sg1) at /media/cdrom0 [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-RAM; DVD-R; DVD-RW; DVD-R DL; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R Sequential; DVD-R Dual Layer Sequential; DVD-RAM; DVD-RW Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; DVD+R Double Layer; CD-ROM; CD-R; CD-RW] [SAO; TAO; Restricted Overwrite]

K3b
-----------------------
Size of filesystem calculated: 87052

Used versions
-----------------------
cdrecord: 2.1.1a01

cdrecord
-----------------------
/usr/bin/X11/cdrecord: Warning: Running on Linux-2.6.15-23-686
/usr/bin/X11/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/X11/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second.
Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Joerg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <email address hidden>.
      The original author should not be bothered with problems of this version.
TOC Type: 3 = CD-ROM XA mode 2
/usr/bin/X11/cdrecord: Permission denied. Cannot open '/dev/sg0'. Cannot open SCSI driver.
/usr/bin/X11/cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
/usr/bin/X11/cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
/usr/bin/X11/cdrecord:
/usr/bin/X11/cdrecord: For more information, install the cdrtools-doc
/usr/bin/X11/cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .

cdrecord command:
----------------------...

Read more...

Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote :

See bug #32039 for some more info and a possible workaround. This may be a duplicate.

Revision history for this message
Edu (martinez-bernal) wrote :

in my case the recorder is in /dev/sg1 with correct permisions, but there is /dev/sg0 wich belongs to root group and every time I try to record a cd, cdrecord tries to open this device. If I delete it o change the privileges, the burn goes succsesful, but at every restart it returns again with wrong permisions

Revision history for this message
John Vivirito (gnomefreak) wrote :

this is a duplicate of bug #21359.

Revision history for this message
Edu (martinez-bernal) wrote :

The bug still valid for me. A workaround is to set uid cdrecord.

eduard@LaMaquinaDelMal:~$ ls -l /dev/sg*
crw-rw---- 1 root root 21, 0 2006-10-26 22:45 /dev/sg0
crw-rw---- 1 root cdrom 21, 1 2006-10-26 22:45 /dev/sg1

 cdrecord --scanbus outputs several "Error trying to open /dev/sg0 exclusively (Permission denied)... retrying in 1 second." and finally stops with "cdrecord: Permission denied. Cannot open '/dev/sg0'. Cannot open SCSI driver.", like k3b output in Ahmed Kamal comment.

Revision history for this message
Tony Lewis (tonylewis) wrote : Me too, plus workaround and upstream fix

"Me too". I have the identical problem on a Dell Inspiron 6400.

Issue is discussed here: http://bugs.kde.org/show_bug.cgi?id=122568. Short version is that it appears to be that cdrecord wants to scan the SCSI bus again, but hasn't got read permission for /dev/sg0 (hard drive) so barfs before it can get to /dev/sg1 (DVD-RW).

Best workaround is here: https://launchpad.net/distros/ubuntu/+source/k3b/+bug/25380/comments/3. Other workarounds are to "dpkg-reconfigure cdrecord" and let it run as SUID, or to "chown root:cdrom /dev/sg0" after each reboot, in order of decreasing recommendedness

The KDE bug indicates that a fix was committed to the K3b SVN on 30 October 2006. So that'll be in feisty, and not edgy, I assume

Revision history for this message
Edu (martinez-bernal) wrote :

I can confirm previous comment and the first workaround works for me. I think that status should be changet to confirmed...

Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote :

Could someone with this problem try the newest k3b in Feisty?

Revision history for this message
Edu (martinez-bernal) wrote :

I have a fresh installed feisty and It doesn't work, but now the message is the same as in bug 83645. The workaround of https://launchpad.net/ubuntu/+source/k3b/+bug/25380/comments/3 now doesn't work. In fact, the user parameters were already in k3b.
-------------------------------------------------------------------
Running suggested commands as a regular user:
eduard@LaMaquinaDelMal:~$ wodim -scanbus
wodim: No such file or directory.
Cannot open SCSI driver!
For possible targets try 'wodim --devices' or 'wodim -scanbus'.
For possible transport specifiers try 'wodim dev=help'.
For IDE/ATAPI devices configuration, see the file README.ATAPI.setup from
the wodim documentation.
eduard@LaMaquinaDelMal:~$ wodim -devices
Beginning native device scan. This may take a while if devices are busy...
wodim: Overview of accessible drives (1 found) :
----------------------------------------------------------------------
0 dev='/dev/sr0' rwrw-- : 'TSSTcorp' 'CDRW/DVD TSL462C'
----------------------------------------------------------------------

Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote :

Do you still have this problem on Feisty final? Bug 75753 (dupe of bug 83645 mentioned above) says it's fixed.

Revision history for this message
Mario Đanić (mario-danic) wrote :

Feisty and Gutsy should have this fixed. Do you still have the problem?

Revision history for this message
Richard Birnie (rbirnie-deactivatedaccount) wrote :

I can confirm that this is fixed in Gutsy (up to date on 24-06-2007). k3b no longer complains about permissions and I am able to successfully burn CDs.

-----------------------
K3b Version: 1.0.1

KDE Version: 3.5.7
QT Version: 3.3.7
Kernel: 2.6.22-6-generic
Devices
-----------------------
TOSHIBA DVD-ROM SD-R2102 1006 (/dev/scd0, ) [CD-R, CD-RW, CD-ROM, DVD-ROM] [DVD-ROM, CD-ROM, CD-R, CD-RW] [SAO, TAO, SAO/R96P, SAO/R96R]

Changed in k3b:
assignee: kubuntu-team → nobody
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers