Ignores manually set burn speed

Bug #31768 reported by Timothy Miller on 2006-02-17
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
k3b
Unknown
Medium
brasero (Ubuntu)
Low
Unassigned
k3b (Ubuntu)
Medium
Unassigned

Bug Description

I'm having various problems with k3b. Among them is a problem with throughput, so for safety, I'd like to throttle down the burn speed. But no matter what I set the burn speed to, k3b ignores it and sets the burn speed to 8.02x.

Timothy Miller (theosib) wrote :

Sorry: 8.20x (11356 KB/s)

Kenny Duffus (kduffus) on 2006-03-17
Changed in k3b:
assignee: nobody → kubuntu-team
Tm_T (Jussi Kekkonen) (tmt) wrote :

Well, I tried to confirm this bug, set k3b to burn cd image as speed 46x, k3b dropped it to 40x because burner doesn't support any faster. Reasult: works fine

Conclusion: can't confirm it, though I'm using Dapper.

Ronny Bangsund (ronnyb) wrote :

The poster's problem isn't that it's not
going fast enough; he wants to go SLOWER
than the default max speed (which K3B
seems to detect correctly). I have the
same problem in K3B on Breezy with
KDE 3.5.2; It wants to do 8x or so, but
not the 4x I ask for.

Carthik Sharma (carthik) on 2006-05-31
Changed in k3b:
status: Unconfirmed → Confirmed
DarkMageZ (darkmagez) wrote :

i can confirm this for dapper, but it appears it might be slightly deliberate.
if you hit the little refresh button to the right of the selection, it will detect which speeds your burner can handle. i noticed this while burning afew dvd's today, i couldn't get it to burn @ 1x, it would always jump to 2.4x, so i hit that little button, and it gave me the options of 2.4 & 8x only.

maybe this little refresh button should be removed, and automatically run? might cause issues with dodgy drivers, but that's the drivers fault!

Kenny Duffus (kduffus) wrote :

The refresh button is examining the CD media when you press the refresh button as it complains if you don't have any media in the drive

Mario Đanić (mario-danic) wrote :

Do you still have the same problem>

This problem still occurs on Gutsy (fully updated 24-06-2007). If I set the burn speed to 1X or 6X then k3b sets it back to 4X in both cases. I suppose this could be hardware/driver specific so for the record my system is:

-----------------------
K3b Version: 1.0.1

KDE Version: 3.5.7
QT Version: 3.3.7
Kernel: 2.6.22-6-generic
Devices
-----------------------
TOSHIBA DVD-ROM SD-R2102 1006 (/dev/scd0, ) [CD-R, CD-RW, CD-ROM, DVD-ROM] [DVD-ROM, CD-ROM, CD-R, CD-RW] [SAO, TAO, SAO/R96P, SAO/R96R]

Daniel Hahler (blueyed) wrote :

Robert pointed out in bug 31768, that brasero has the same problem.

I've reported it upstream for k3b (http://bugs.kde.org/show_bug.cgi?id=154498), where it looks like the call to /usr/bin/growisofs is wrong (includes wrong speed param).

Changed in k3b:
status: Unknown → Confirmed
Steve Stalcup (vorian) on 2008-01-16
Changed in brasero:
status: New → Confirmed
moueza (mouezapeter) wrote :

same problem under suse 10.3 with a CD

I can confirm that the same issue happens in brasero in Hardy Heron x86-64 but the cdrecord command launched by brasero seems to have the right speed parameter:
cdrecord -v dev=/dev/scd0 gracetime=0 speed=1 driveropts=burnfree -multi fs=4m tsize=11080s -dao -data -nopad

as you see speed is set to 1 but the burning process is done at 4x

There is no way to debug brasero as bug 273183

The same issue happens also in GnomeBaker. The problem is related to wodim (cdrecord).

Changed in k3b:
assignee: kubuntu-bugs → nobody
status: Confirmed → Triaged
Changed in brasero (Ubuntu):
importance: Undecided → Low
Changed in k3b:
status: Confirmed → Invalid
Jonathan Thomas (echidnaman) wrote :

Should be fixed with K3b 2.

Changed in k3b (Ubuntu):
status: Triaged → Fix Released
Changed in k3b:
status: Invalid → Unknown
Franco.Santinelli (fascorp) wrote :

Have to say that I am experiencing the same problem under Ubuntu 10.10 32 bits. Ater selecting 4x the disc is burnt at whichever speed the app wants (usually 12x) and the dvd-r disc supports 4,8,12,16.

I tried to use simulate to avoid making coasters because with the above method when I set to verify after burning it never ends, but when it finish the simulations process it ejects the blank DVD-R with a message "media not empty".

My DVD drive is a HL-DT-ST DVDRAM GH22NS40 (formerly a LG drive) with the lastest firmware (NL02)

Changed in k3b:
importance: Unknown → Medium
beroal (beroal) wrote :

Jonathan Thomas (echidnaman) wrote on 2010-03-17: #12
"Should be fixed with K3b 2."
I have this problem with K3b 2 (see versions below). I set the writing speed to 4x, but it writes DVD-R at 12x. "k3b" uses "cdrkit" for writing.
k3b 2.0.2-4
cdrkit 1.1.11-2
kdebase-runtime 4.7.4-1
kdelibs 4.7.4-1
kdemultimedia-kioslave 4.7.4-1
Arch Linux.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.