Video DVDs created by k3b from iso file unreadable by MS Windows

Bug #235738 reported by bedege
2
Affects Status Importance Assigned to Milestone
cdrkit (Debian)
New
Unknown
cdrkit (Ubuntu)
Undecided
Unassigned
k3b (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: k3b

I've burned a DVD+R using k3b, from an iso image I created using k9copy. This DVD mounts and reads OK with Xubuntu:
- when inserted, it is mounted and has the usual VIDEO_TS and AUDIO_TS directories
- the video plays fine with Totem

However, when I insert this DVD in a windows box, the systems complains that the disk is empty, while a burning tool says the disc is 4.4 GB full. Of course Windows can not read nothing on it, but with the vlc windows port, that reads the film ok. If I burn the iso file with Nero (for instance) under windows, then Windows reconizes the created DVD+R and reads it.

I use Xubuntu 8.04, with all patches applied. This bug has also been reported on ubuntuforums (http://ubuntuforums.org/showthread.php?t=787299).

Revision history for this message
bedege (degouville) wrote :

THe k3b release I use is 1.0.4 (KDE 3.5.9) shipped with Ubuntu Hardy Heron 8.04

Revision history for this message
bedege (degouville) wrote :

Actually, it looks like it's a genisoimage/cdrkit bug (https://bugs.launchpad.net/ubuntu/+source/cdrkit/+bug/233942), that creates faulty iso files for video DVDs.

This bug has been reported in genisoimage 1.1.6 (that currently ships with Hardy), and *should* be fixed in release 1.1.7.

I have not been able to fix it yet, but still it has nothing to do with k3b.

Changed in cdrkit:
status: Unknown → New
Revision history for this message
Thomas Kluyver (takluyver) wrote :

"it has nothing to do with k3b." OK--I'm marking it as invalid in k3b.

Is it the same issue as in bug 233942? If so, can it be marked as a duplicate?

Changed in k3b:
status: New → Invalid
Revision history for this message
bedege (degouville) wrote :

Yes, it is more likely a genisoimage bug, not k3b. It can be marked as a duplicate. Thank you.

Revision history for this message
bedege (degouville) wrote :

I do confirm it's a genisoimage bug. Downgrading to genisoimage 1.1.2 solved the issue. Newlycreated iso files and video DVDs are ok under MS Windows.

However, upgrading to 1.1.7 or 1.1.8 (from Debian) did not help and gives identical results to Hardy's 1.1.6.

Revision history for this message
Epson (epson-deactivatedaccount) wrote :

I was told that installing geniso 1.1.6 would fix this problem.
I just tried this on a Dell optiplex 745 with a dvd rom / cdrw and I still can't view dvds burning using kb3 and geniso 1.1.6. I'm using a dvd-rw so maybe that's part of the problem. Anyone able to view dvds burned using a dvd-rw with windows?
I guess I'll try genisoimage 1.1.2 and see if that fixes my problem.

Revision history for this message
Epson (epson-deactivatedaccount) wrote :

On my system downgrading to 1.1.2 does something funky with k3b and k9copy. After installing 1.1.2, I can't open k3b or k9copy. I'm going to try 1.1.6 from gutsy again. I'm using Kubuntu 8.04.

Revision history for this message
Epson (epson-deactivatedaccount) wrote :

installing genisoimage_1.1.6-1ubuntu3_i386.deb removes remastersys. when I put remastersys back on using Adept Manager it puts genisoimage_1.1.6-1ubuntu6_i386.deb back on. when I install genisoimage_1.1.6-1ubuntu3_i386.deb back on and I check to see if remastersys is installed, I try to run it and it never opens

When I run remastersys from the terminal instead of the program menu I see one of the following errors:
"The following packages have unmet dependencies:
  remastersys: Depends: mkisofs"

So, remastersys is one program that's affected when downgrading genisoimage_1.1.6-1ubuntu6_i386.deb to genisoimage_1.1.6-1ubuntu3_i386.deb

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.