k3b should unmount a CD before burning

Bug #23326 reported by Markus Wigge on 2005-10-06
10
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Wishlist
Jonathan Riddell

Bug Description

If I insert a removable media (i.e. USB-Stick) and try to remove it nautilus
tries to "eject" it!?

This will only work on CD/DVD drives I think. But this is also a problem! I
tried to erase a CD/RW with k3b but gnome opened it in nautilus. So I had to
unmount it first and gnome ejected it!? So this will lead to confused users I
think...

Martin Pitt (pitti) wrote :

(In reply to comment #0)
> If I insert a removable media (i.e. USB-Stick) and try to remove it nautilus
> tries to "eject" it!?

Yes, this is done deliberately. Unmounting works poorly with devices like iPod,
which still complain that it is unsafe to remove them. Ejecting USB and Firewire
devices will actually power them off.

> This will only work on CD/DVD drives I think. But this is also a problem! I
> tried to erase a CD/RW with k3b but gnome opened it in nautilus. So I had to
> unmount it first and gnome ejected it!? So this will lead to confused users I
> think...

You cannot unmount a CD, it clearly says "Eject". Just like nautilus-cd-burner,
k3b should just unmount the CD right before writing on it.

Jonathan, is this already the case? Or is this feature just missing?

Maybe the trouble arises from mixing the different strategies of KDE and Gnome
in terms of handling removable devices.

Jonathan Riddell (jr) wrote :

Missing feature

Changed in k3b:
importance: Medium → Wishlist
Kenny Duffus (kduffus) on 2006-10-21
Changed in k3b:
status: Unconfirmed → Confirmed

This seems to be fixed in k3b 1.0 upstream (built from source on feisty)

Daniel Hahler (blueyed) wrote :

k3b 1.0 (which is said to fix this) has been uploaded for Feisty, so "Fix Released".
Please re-open if this is still an issue.

Changed in k3b:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.