k3b verification broken

Bug #207265 reported by Swistak
74
This bug affects 5 people
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: k3b

K3b verification doesn't work properly. It claims that the written data differs from original even though it is not the case. When I make an iso image and calculate the md5 sum it turns out to be identical to the original one.

It's k3b 1.0.4 (Kubuntu 8.04 beta)

Revision history for this message
Swistak (swistakers) wrote :
Revision history for this message
Swistak (swistakers) wrote :

This bug seems to be related to UTF-8. When I run k3b using:

#!/bin/sh
export LC_ALL=pl_PL.ISO-8859-2; k3b

verification works correctly.

Revision history for this message
x (xk2c-deactivatedaccount) wrote :

same problem here, k3b claims faild verification but manually created md5sum matches.

$ locale
LANG=de_DE.UTF-8
LANGUAGE=de_DE:de
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

Revision history for this message
x (xk2c-deactivatedaccount) wrote :

i did:
$ LANG=de_DE@euro
$ locale
LANG=de_DE@euro
LANGUAGE=de_DE:de
LC_CTYPE="de_DE@euro"
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES="de_DE@euro"
LC_PAPER="de_DE@euro"
LC_NAME="de_DE@euro"
LC_ADDRESS="de_DE@euro"
LC_TELEPHONE="de_DE@euro"
LC_MEASUREMENT="de_DE@euro"
LC_IDENTIFICATION="de_DE@euro"

still verification in k3b fails, but manually created md5sum matches

Revision history for this message
Gregory Margo (gmargo) wrote :

Same problem here.
Verification of a burned data cd fails, but manual read with dd produces image identical to original.
This same hardware, and same locale variables, worked just fine under gutsy.

LANG=en_US.UTF-8
LC_COLLATE=POSIX
LC_TIME=POSIX

linux-image-2.6.24-15-generic 2.6.24-15.27
k3b 1.0.4-2ubuntu4

Revision history for this message
Gregory Margo (gmargo) wrote :

To amend my earlier report, which I filed after two failures:
Following those two failures, I had four successes, so it's not consistent.
Does not seem to be data dependent (image 1 failed twice, succeeded once, image 2 succeeded three times.)
Also, I believe I only had the LANG variable set, not the LC_ ones.
(LC_ ones were set in .bashrc, but KDE session started from kdm, so I think only LANG from /etc/environment was set.)

Revision history for this message
Risto H. Kurppa (risto.kurppa) wrote :

KDE 3.5.9 w. Hardy and same error here whilst burning Ubuntu images. I really believe that they are ok (not md5 checked after burning) but I get the same 'written data in track 1 differs...' message so I'd say too that something is broke there..

Revision history for this message
Risto H. Kurppa (risto.kurppa) wrote :

More people confirm this on ubuntu-fi forums: http://forum.ubuntu-fi.org/index.php?topic=17948.0, using Hardy.

Revision history for this message
Stefan Carslöv (odur) wrote :

Confirming that verification on k3b in Kubuntu Hardy Heron is broken for images.

Revision history for this message
Angelos Vlassopoulos (avlass) wrote :

I think that more than enough people verify the bug. Just check the respective thread at ubuntu forums

http://ubuntuforums.org/showthread.php?p=5767141#post5767141

Revision history for this message
Risto H. Kurppa (risto.kurppa) wrote :

Changed to confirmed..?

Changed in k3b:
status: New → Confirmed
Revision history for this message
MohamadReza Mirdamadi (mohi) wrote :

I have this bug again in Intrepid, K3b 1.0.5

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

I am marking this triaged, importance - Medium. There should be enough information for the developers to begin working this issue.

Changed in k3b:
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
D. Brodzik (amyrose) wrote :

The bug still exists in Jaunty.

Revision history for this message
Christian Vogler (christian-vogler) wrote :

After a verification failure, if I sha1sum the CD device directly, the resulting SHA1 sum also differs from the one of the ISO image. After ejecting and reinserting the disc, the sha1sums suddenly match properly. This makes me wonder whether this is really a k3b issue, or something related to the kernel or even the device itself.

Revision history for this message
Frank Denissen (aankoopdenissen) wrote :

I have enabled the option in k3b so that the disk is ejected directly after burning. This makes that the after-burning verification is done with a re-inserted disk. The verification still fails.

I found on the web two methods to calculate the checksum. Only method 1 gives the same value for the checksum as calculated from the .iso file. I'm wondering which method k3b is using ....

method 1: dd if=$cd bs=$blocksize count=$blockcount conv=notrunc,noerror | md5sum
method 2: md5sum $cd

$cd is the device: example /dev/sr0
$blocksize and $blockcount are taken from the output of isoinfo

Revision history for this message
Wolfgang Kufner (wolfgangkufner) wrote :

Works for me. I just successfully burned and verified a DVD iso and a CD iso. Ubuntu maverick 64 bit.

Maybe it is fixed now.

Revision history for this message
Frank Denissen (aankoopdenissen) wrote :

It works for me too. Problem seems to be solved.
I'm running k3b 1.91.0~rc2-0ubuntu3 in Kubuntu Lucid Lynx

Revision history for this message
Wolfgang Kufner (wolfgangkufner) wrote :

Thanks, Frank. Given that confirmation and the old age (Jaunty or older) of all reports of failure I think it is best to close this as fixed :-).

Changed in k3b (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments