Ubuntu

k3b causes system freeze

Reported by Linker on 2007-04-27
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: k3b

I wanted to write a dvd at 16x, no multisession, verify data after write.
I managed to write one, it got verified, all went ok.
Then I wanted to write a second dvd using the same setup.
5 minutes after the write started, k3b crashed (and some other
open applications went down with it).
The system froze. I could still move the mouse, but couldn't open any
application.
But the dvd kept spinning, as if it were still written.
I left it about 10 minutes or so, with no change (disk still spinning).
I rebooted the system using Alt + SysRq + R, S, E, I, U, B.
But the dvd was still spinning ... I had to shutdown in order to make
it stop.

I have an LG dvd writer.
Os is Kubuntu Feisty on 32 bits, it's an upgrade from edgy.

I tried to write another dvd after this, changing some options, but it
kept freezing.

kokoko (bababa) wrote :

Thanks for taking the time to report this bug.
Can you also tell us the version of K3B you are having this problem with?

Linker (del-kaos) wrote :

k3b is version 1.0.
I had some other apps open while burning: amarok, firefox, maybe even adept.

oz_ollie (oz-ollie) wrote :

This is definitely still a problem. System freezes, Crtl + Alt + Bksp to kill X session but system is unstable until reboot. I have tried under Gnome and KDE desktops (Ubuntu 7.04 installed then kde-desktop packages installed) and system freezes under both desktops after displaying the colourful splash screen. Splash screen stays on top of any other apps launched.

Kernel Version - 2.6.20-15-generic
K3B Version - 1.0-0ubuntu2

toaste (toaste) wrote :

I can confirm a reproducible lockup related to K3B 1.0 on my Edgy system. I also happen to have an LG burner and am running gnome. In my case, immediately following successfully burning a DVD (with the write successful message displayed) the system locks (completely unresponsive; ctrl+alt+F1 will not bring up terminal). Any advice regarding what logs I should post (any particular section of DMESG output, etc)?

Hardware:
Intel Core 2 Duo E6400
Intel DG965WH Board
LG 18X DVD±R Super-Multi DVD Burner With 12X DVD-RAM Write IDE Model GSAH22N-BK

toaste (toaste) wrote :

***Typo in previous post:

This problem did not exist when running 6.10/Edgy on this machine and has only appeared after an upgrade to Ubuntu 7.04/Feisty.

Bhavani Shankar (bhavi) wrote :

K3b doesnt write DVD s and causes system freeze... Its on a freshly installed Fiesty from edgy..

oz_ollie (oz-ollie) wrote :

It appears to be a problem with the k3b launcher splash screen.

I installed AcetoneISO, after reading a review in Linux Format 92. One of AcetoneISO's options is "Burn CD/DVD", clicking on this launched k3b, but without displaying the splash screen and straight into the regular k3b window. I have only tried burning CD ISOs this way (successful), not DVDs yet.

Thanks mate.
Bhavani Shankar.
On 5/4/07, oz_ollie <email address hidden> wrote:
>
> It appears to be a problem with the k3b launcher splash screen.
>
> I installed AcetoneISO, after reading a review in Linux Format 92. One
> of AcetoneISO's options is "Burn CD/DVD", clicking on this launched k3b,
> but without displaying the splash screen and straight into the regular
> k3b window. I have only tried burning CD ISOs this way (successful), not
> DVDs yet.
>
> --
> k3b causes system freeze
> https://bugs.launchpad.net/bugs/110484
> You received this bug notification because you are a member of Kubuntu
> Team, which is a bug contact for k3b in ubuntu.
>
> --
> kubuntu-bugs mailing list
> <email address hidden>
> https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs
>

Mario Đanić (mario-danic) wrote :

Can you reproduce the problem in gutsy?

Changed in k3b:
status: New → Confirmed
Linker (del-kaos) wrote :

I did not try it in gutsy yet.

Peter Cordes (peter-cordes) wrote :

I also have a DG965WH motherboard (and a Pioneer DVR-111D, firmware 1.29). It uses the Intel g965 chipset, which doesn't include any IDE ports. The board has a Marvell IDE controller chip, which is driven by the pata_marvell kernel module. This is a relatively new driver in the kernel, and I think not totally bug-free yet. e.g. running AMD64 Feisty with the stock kernel, my system would lock up if k3b was running while I closed the tray with a blank dvd-r (or was it +r) in it.

 I'm currently running Gutsy's kernel (and the latest git versions of DRM and mesa for better g965 support; I made a script to download and hack linux-headers...-generic so they don't depend on gutsy's libc, because the headers themselves don't. I guess some of the shipped progs in /usr/src/.../scripts do. BTW, Gutsy's xorg isn't a big improvement for opengl performance or stability if you were using Feisty with mesa from git. They still haven't fixed the tearing (no vsync). I think Feisty's mesa still crashed sometimes on g965, though, and gutsy's mesa is newer and better.)

 Anyway, I can burn DVDs all day without any problems, and the crash while k3b recognized a freshly inserted disc doesn't happen anymore. (I used to have to quit k3b, load a disc, and run it again.)

 So some people's lockups might be the fault of their PATA driver. Try a newer kernel if you have a motherboard with an Intel 965 chipset and a funky PATA controller. BTW, SATA burners are not much more expensive these days, if you're in the market for a new one anyway.

 Usually system lockups are not directly k3b's fault. Locking up the whole system requires messing with hardware (usually), so it's more often a driver or the X server or something else that directly controls hardware that needs to be fixed. Or other software can avoid doing whatever makes the driver cause a lockup.

Just take a look of whozzat features:

   1. talk in hidden with friends
   2. unlimited file transfer, uploading
   3. social networking = social welfare
   4. here Almost all the features available that is needed on a social
   networking site
   5. get money for every thing you do

Sign up soon….

Don't waste a single minute

*http://www.whozzat.com/signup.php?rid=1108***

Whenever you have the time please visit this site.. It's cool!!

Remember this website started by some students and their plan is to give
social welfare threw Whozzat. So, pls register here and say to all your
friends

David Barreda (arkoldthos) wrote :

Same happens to me since Gutsy, now using Intrepid and got the same problem~

Álvaro M. Recio (naproxeno) wrote :

It happens to me also in Jaunty.

Maarten Bezemer (veger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 110484 and any other logs that are relevant for this particular issue.

Changed in k3b (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for k3b (Ubuntu) because there has been no activity for 60 days.]

Changed in k3b (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers