Can't burn a cd

Bug #103075 reported by paumarc
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Low
Unassigned

Bug Description

Hi

 Each time that i try to burn a cd with k3b i get the messatge (i can burn cd with nautilus)

IO Error. Most likely no space keft on harddisk

but my hard disk is just

/dev/sda6 25G 5,5G 18G 24% /
varrun 502M 240K 501M 1% /var/run
varlock 502M 4,0K 502M 1% /var/lock
procbususb 502M 144K 501M 1% /proc/bus/usb
udev 502M 144K 501M 1% /dev
devshm 502M 0 502M 0% /dev/shm
lrm 502M 28M 474M 6% /lib/modules/2.6.20-13-generic/volatile
/dev/mapper/sda7 21G 4,8G 15G 25% /home
/dev/mapper/sda3 5,4G 292K 5,4G 1% /media/sda3
/dev/disk/by-uuid/18AFC458563F4FBA
                       40G 27G 13G 69% /media/windows
/dev/sda4 1,1G 828M 201M 81% /media/win32
/dev/sdb1 75G 17G 59G 22% /media/disk

pau@esberro:~$ uname -a
Linux esberro 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

k3b output

pau@esberro:~$ k3b
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
kbuildsycoca running...
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
pau@esberro:~$ kdecore (KAction): WARNING: KActionCollection::KActionCollection( QObject *parent, const char *name, KInstance *instance )
(K3bDevice::HalConnection) initializing HAL >= 0.5
Mapping udi /org/freedesktop/Hal/devices/storage_model_DVDRAM_GSA_4082N to device /dev/scd0
/dev/scd0 resolved to /dev/scd0
/dev/scd0 is block device (0)
/dev/scd0 seems to be cdrom
bus: 4, id: 0, lun: 0
(K3bDevice::Device) /dev/scd0: init()
(K3bDevice::Device) /dev/scd0 feature: CD Mastering
(K3bDevice::Device) /dev/scd0 feature: CD Track At Once
(K3bDevice::Device) /dev/scd0 feature: CD-RW Media Write Support
(K3bDevice::Device) /dev/scd0 feature: DVD Read (MMC5)
(K3bDevice::Device) /dev/scd0 feature: DVD+R
(K3bDevice::Device) /dev/scd0 feature: DVD+RW
(K3bDevice::Device) /dev/scd0 feature: DVD+R Double Layer
(K3bDevice::Device) /dev/scd0 feature: DVD-R/-RW Write
(K3bDevice::Device) /dev/scd0 feature: Rigid Restricted Overwrite
(K3bDevice::Device) /dev/scd0 unknown profile: 2
(K3bDevice::Device) /dev/scd0: dataLen: 60
(K3bDevice::Device) /dev/scd0: checking for TAO
(K3bDevice::Device) /dev/scd0: checking for SAO
(K3bDevice::Device) /dev/scd0: checking for SAO_R96P
(K3bDevice::Device) /dev/scd0: checking for SAO_R96R
(K3bDevice::Device) /dev/scd0: checking for RAW_R16
(K3bDevice::Device) /dev/scd0: checking for RAW_R96P
(K3bDevice::Device) /dev/scd0: checking for RAW_R96R
(K3bDevice::DeviceManager) setting current write speed of device /dev/scd0 to 4234
Could not resolve /dev/hda
/dev/hda resolved to /dev/hda
(K3bDevice::Device) could not open device /dev/hda for reading
                    (No such file or directory)
could not open device /dev/hda (No such file or directory)
/dev/scd0 resolved to /dev/scd0
(K3bDevice::DeviceManager) dev /dev/scd0 already found
(K3bDevice::DeviceManager) found config entry for devicetype: HL-DT-ST DVDRAM GSA-4082N
DiskInfo:
Mediatype: CD-R
Current Profile: CD-R
Disk state: empty
Empty: 1
Rewritable: 0
Appendable: 0
Sessions: 0
Tracks: 0
Layers: 1
Capacity: 79:57:74 (LBA 359849) (736970752 Bytes)
Remaining size: 79:57:74 (LBA 359849) (736970752 Bytes)
Used Size: 00:00:00 (LBA 0) (0 Bytes)
(K3bDevice::Device) /dev/scd0: Number of supported write speeds via 2A: 3
(K3bDevice::Device) /dev/scd0 : 4234 KB/s
(K3bDevice::Device) /dev/scd0 : 2822 KB/s
(K3bDevice::Device) /dev/scd0 : 1764 KB/s
Devices:
------------------------------
Blockdevice: /dev/scd0
Generic device:
Vendor: HL-DT-ST
Description: DVDRAM GSA-4082N
Version: CQ04
Write speed: 4234
Profiles: DVD-ROM, DVD-R Sequential, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Read Cap: DVD-ROM, DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+RW Dual Layer, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Write Cap: DVD-R, DVD-R Sequential, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R, CD-RW
Writing modes: SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite
Reader aliases: /dev/scd0
------------------------------
qstring_to_xtp result code -2
qstring_to_xtp result code -2
kdecore (KAction): WARNING: KActionCollection::operator+=(): function is severely deprecated.
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
Qt: Locales not supported on X server
QInputContext: no input method context available
QInputContext: no input method context available
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
QInputContext: no input method context available
QInputContext: no input method context available
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
QInputContext: no input method context available
QInputContext: no input method context available
(K3bDevice::DeviceManager) request for empty device!
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
QInputContext: no input method context available
QInputContext: no input method context available
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
qstring_to_xtp result code -2
(K3bDevice::DeviceManager) request for empty device!
QInputContext: no input method context available
QInputContext: no input method context available
qstring_to_xtp result code -2
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!

Revision history for this message
dajero (dajero) wrote :

I had the same problem but was able to work around it by creating the directory /tmp/kde-<my_username>, where, ofcourse, you need to replace <my_username> with your own username. You'll notice that k3b says Temp: No info in the lower left corner of its window. Once you've created the aforementioned directory and restart k3b you'll notice that k3b now displays the correct amount of free disk space in /tmp.

Revision history for this message
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 beta?

Changed in k3b:
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in k3b:
status: Incomplete → Invalid
EhsanJebeli (e-jebely)
Changed in k3b (Ubuntu):
assignee: nobody → EhsanJebeli (e-jebely)
status: Invalid → Confirmed
Revision history for this message
Phillip Susi (psusi) wrote :

Please don't fiddle with buttons willy-nilly.

Changed in k3b (Ubuntu):
assignee: EhsanJebeli (e-jebely) → nobody
status: Confirmed → Invalid
Revision history for this message
markling (markling) wrote :

I have this problem. I had used k3b on this machine before without a hitch. Now this problem has arisen. It appears as though it may have arisen after upgrading from Xubuntu i686 12.10 to 13.04. I'm fairly certain I last used K3b to burn a CD without a problem before the upgrade. My hard disks have free space. The files are being copied from an external hard drive, over USB.

To confirm, when I try to write an audio disk, k3b says: "IO Error. Most likely no space left on harddisk."

dajero's suggestion looked right for me: k3b does say "no info" in the bottom right of the writing dialogue.

dajero's suggestion worked for me too. I created directory: /tmp/kde-username (where username is my username). I didn't even have to restart k3b. I just closed the last failed write window and clicked burn again. It immediately performed a successful burn.

The write window, however, still shows "no info" in the bottom left.

When the error occurs, k3b shows only the following debugging info:

Devices
-----------------------
SONY CD-RW CRX217E 1DS2 (/dev/sr0, CD-R, CD-RW, CD-ROM) [CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R] [%7]

System
-----------------------
K3b Version: 2.0.2
KDE Version: 4.10.2
QT Version: 4.8.4
Kernel: 3.8.0-22-generic

There is another directory already in tmp with a similar name, created just a short while ago - possibly about the time I started k3b. It is a temp file of the same format as the one dajero said should be created, but with 6 random characters on the end: /tmp/kde-<username><5-random-characters>

I filed a bug report.

Changed in k3b (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
markling (markling) wrote :

On restarting my computer, the unusually-named tmp directory was as you might expect no longer there.

On restarting k3b the unusually-named tmp directory returned. It had the same format, with the same apparently random characters: /tmp/kde-<username><5-random-characters>.

The contents of this directory, I forgot to mention before: a file called xauth-1000-_0

Again, problem solved by creating a tmp directory: /tmp/kde-<username>

The upshot of this problem is that k3b will never work out of the box for me. I will always have to create a tmp directory before I can get it to burn a disc.

Revision history for this message
markling (markling) wrote :

Just a note to say this error still exists.

Went back to k3b.
Could not burn CD.
Same error message: "IO Error. Most likely no space left on harddisk."
Same fix: mkdir /tmp/kde-<username>
Same repurcissions: k3b needs to be fixed afresh before each session.

Revision history for this message
markling (markling) wrote :

Here's k3b's "Show Debugging Output" shows:

Devices
-----------------------
SONY CD-RW CRX217E 1DS2 (/dev/sr0, CD-R, CD-RW, CD-ROM) [CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R] [%7]

System
-----------------------
K3b Version: 2.0.2
KDE Version: 4.10.3
QT Version: 4.8.4
Kernel: 3.8.0-25-generic

Revision history for this message
markling (markling) wrote :

For output from ubuntu-bug for this k3b report, please see:

https://bugs.launchpad.net/ubuntu/+source/k3b/+bug/1193641

Revision history for this message
markling (markling) wrote :

So k3b settings says:

Default Temporary Directory: /tmp/kde-<username>/

It would seem to make sense for the k3b to either choose a tmp directory that exists or to create it itself.

Revision history for this message
markling (markling) wrote :

This error still occurs.

Revision history for this message
drew (latortuga) wrote :

This just happened to me as well and adding the tmp dir worked as a fix.

Revision history for this message
Harald Sitter (apachelogger) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

Changed in k3b (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Harald Sitter (apachelogger) wrote :

Also, FWIW I canno reproduce this on 13.10, the directory is correctly created when starting k3b...

Revision history for this message
Phillip Susi (psusi) wrote :

Harald, you do not mark bugs as invalid because they exist upstream; you should report it upstream and link this bug to the upstream report. Is anyone else able to reproduce this on 13.10?

Changed in k3b (Ubuntu):
status: Invalid → Incomplete
Revision history for this message
Harald Sitter (apachelogger) wrote :
Changed in k3b (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers