Add libpulse and libasound as build dependencies

Bug #1118153 reported by Pete Woods on 2013-02-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
julius (Ubuntu)
Undecided
Unassigned

Bug Description

This change does two things:
* Add two new build dependencies - libpulse-dev and libasound-dev.
   - This causes all the audio backends to be built.
* Moves the library configuration tools from the main julius package to libjulius-dev.
   - This allows you to build against libjulius-dev without having julius installed.

Pete Woods (pete-woods) wrote :
Pete Woods (pete-woods) wrote :
Pete Woods (pete-woods) wrote :
description: updated
Bhavani Shankar (bhavi) wrote :

Uploaded. Closing this

julius (4.2.2-0ubuntu2) raring; urgency=low

  * Add libpulse-dev and libasound-dev as build dependencies.
     - This makes all the sound back-ends build.
  * Move libjulius-config and libsent-config into libjulius-dev.
     - It is now possible to build against libjulius-dev without
       also having the main julius package installed.
  * See bug lp:1118153
 -- Pete Woods <email address hidden> Thu, 07 Feb 2013 09:04:13 +0000

Regards,

Changed in julius (Ubuntu):
status: New → Fix Released
IRIE Shinsuke (irie) wrote :

Please don't move files (libsent-config and libjulius-dev) without setting Breaks and Replaces in debian/control!!!!

Downgrading from 4.2.2-0ubuntu2 to 4.2.2-0ubuntu1 fails as follows:

$ sudo apt-get install julius=4.2.2-0ubuntu1 libjulius-dev=4.2.2-0ubuntu1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libjcode-pm-perl
Use 'apt-get autoremove' to remove it.
Suggested packages:
  julius-voxforge
The following packages will be DOWNGRADED:
  julius libjulius-dev
0 upgraded, 0 newly installed, 2 downgraded, 0 to remove and 0 not upgraded.
Need to get 0 B/1,552 kB of archives.
After this operation, 60.4 kB disk space will be freed.
Do you want to continue [Y/n]?
dpkg: warning: downgrading julius from 4.2.2-0ubuntu2 to 4.2.2-0ubuntu1
(Reading database ... 477242 files and directories currently installed.)
Preparing to replace julius 4.2.2-0ubuntu2 (using .../julius_4.2.2-0ubuntu1_amd64.deb) ...
Unpacking replacement julius ...
dpkg: error processing /var/cache/apt/archives/julius_4.2.2-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/libsent-config', which is also in package libjulius-dev 4.2.2-0ubuntu2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
dpkg: warning: downgrading libjulius-dev from 4.2.2-0ubuntu2 to 4.2.2-0ubuntu1
Preparing to replace libjulius-dev 4.2.2-0ubuntu2 (using .../libjulius-dev_4.2.2-0ubuntu1_amd64.deb) ...
Unpacking replacement libjulius-dev ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/julius_4.2.2-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
$

IRIE Shinsuke (irie) wrote :

Typo in previous comment:

"libsent-config and libjulius-dev" -> "libjulius-config and libsent-config"

Siegfried Gevatter (rainct) wrote :

Re-opening because of the missing Breaks.

Changed in julius (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers