RM FTBFS with new scons, new g++, new C++ standards

Bug #1730706 reported by Dimitri John Ledkov on 2017-11-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-mongo-tools3.2 (Ubuntu)
Critical
Nicholas Skaggs
Bionic
Critical
Nicholas Skaggs
juju-mongodb3.2 (Ubuntu)
Critical
Nicholas Skaggs
Bionic
Critical
Nicholas Skaggs

Bug Description

FTBFS with new scons, new g++, new C++ standards, new boost.

These could be fixed up, but I'm not sure if Foundations should continue to invest into this port of mongodb.

I wonder, if it should be RMed instead.

xnox@sochi:~$ reverse-depends src:juju-mongodb3.2
No reverse dependencies found

xnox@sochi:~$ reverse-depends -b src:juju-mongodb3.2
No reverse dependencies found

Dimitri John Ledkov (xnox) wrote :

If there is an owner for this package, please speak up if it should be kept in the archive.

description: updated
Dimitri John Ledkov (xnox) wrote :

Apperantly it is used by juju, but not by anything in the archive. This package urgently needs maintaince, or removal from the archive and moved $elsewhere.

Changed in juju-mongodb3.2 (Ubuntu Bionic):
status: New → Confirmed
importance: Undecided → Critical
milestone: none → ubuntu-17.12
assignee: nobody → Nicholas Skaggs (nskaggs)

This one always end up on my plate for better or worse. Distributing it via
the archive doesn't really make any sense but there are problems with all
the alternatives we've thought of (mostly around needing to work in
disconnected environments).

On 8/11/2017 08:01, "Dimitri John Ledkov" <email address hidden> wrote:

> Apperantly it is used by juju, but not by anything in the archive. This
> package urgently needs maintaince, or removal from the archive and moved
> $elsewhere.
>
> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
> Status: New => Confirmed
>
> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
> Importance: Undecided => Critical
>
> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
> Milestone: None => ubuntu-17.12
>
> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
> Assignee: (unassigned) => Nicholas Skaggs (nskaggs)
>
> --
> You received this bug notification because you are subscribed to juju-
> mongodb3.2 in Ubuntu.
> https://bugs.launchpad.net/bugs/1730706
>
> Title:
> RM FTBFS with new scons, new g++, new C++ standards
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/juju-mongodb3.
> 2/+bug/1730706/+subscriptions
>

Dimitri John Ledkov (xnox) wrote :

On 7 November 2017 at 19:56, Michael Hudson-Doyle
<email address hidden> wrote:
> This one always end up on my plate for better or worse. Distributing it via
> the archive doesn't really make any sense but there are problems with all
> the alternatives we've thought of (mostly around needing to work in
> disconnected environments).
>

But that's no longer part of your duties at all.... Thus juju team
should be maintaining this, if they need/want it shipped in 18.04
archive.

> On 8/11/2017 08:01, "Dimitri John Ledkov" <email address hidden>
> wrote:
>
>> Apperantly it is used by juju, but not by anything in the archive. This
>> package urgently needs maintaince, or removal from the archive and moved
>> $elsewhere.
>>
>> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
>> Status: New => Confirmed
>>
>> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
>> Importance: Undecided => Critical
>>
>> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
>> Milestone: None => ubuntu-17.12
>>
>> ** Changed in: juju-mongodb3.2 (Ubuntu Bionic)
>> Assignee: (unassigned) => Nicholas Skaggs (nskaggs)
>>
>> --
>> You received this bug notification because you are subscribed to juju-
>> mongodb3.2 in Ubuntu.
>> https://bugs.launchpad.net/bugs/1730706
>>
>> Title:
>> RM FTBFS with new scons, new g++, new C++ standards
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/ubuntu/+source/juju-mongodb3.
>> 2/+bug/1730706/+subscriptions
>>
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1730706
>
> Title:
> RM FTBFS with new scons, new g++, new C++ standards
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/juju-mongodb3.2/+bug/1730706/+subscriptions

--
Regards,

Dimitri.

Nicholas Skaggs (nskaggs) wrote :

We will seek to ship juju-mongo3.6 in leiu of this package. We need mongo3.6 for juju 2.4, which will ship with bionic.

Steve Langasek (vorlon) wrote :

This should still be done for 18.04. Since juju itself is out of archive, we will need to be told once juju is no longer using the juju-mongodb3.2 package for 18.04 and it's safe to remove.

Changed in juju-mongodb3.2 (Ubuntu Bionic):
milestone: ubuntu-17.12 → ubuntu-18.03
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2018-04-09
Changed in juju-mongo-tools3.2 (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Nicholas Skaggs (nskaggs)
Steve Langasek (vorlon) wrote :

Removing packages from bionic:
 juju-mongodb3.2 3.2.15-0ubuntu1 in bionic
  juju-mongodb3.2 3.2.15-0ubuntu1 in bionic amd64
  juju-mongodb3.2 3.2.15-0ubuntu1 in bionic arm64
  juju-mongodb3.2 3.2.15-0ubuntu1 in bionic ppc64el
  juju-mongodb3.2 3.2.15-0ubuntu1 in bionic s390x
Comment: FTBFS, unused; LP: #1730706
1 package successfully removed.
Removing packages from bionic-proposed:
 juju-mongodb3.2 3.2.15-0ubuntu3 in bionic
Comment: FTBFS, unused; LP: #1730706
1 package successfully removed.

Changed in juju-mongodb3.2 (Ubuntu Bionic):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages from bionic:
 juju-mongo-tools3.2 3.2.4+ds-0ubuntu1 in bionic
  juju-mongo-tools3.2 3.2.4+ds-0ubuntu1 in bionic amd64
  juju-mongo-tools3.2 3.2.4+ds-0ubuntu1 in bionic arm64
  juju-mongo-tools3.2 3.2.4+ds-0ubuntu1 in bionic armhf
  juju-mongo-tools3.2 3.2.4+ds-0ubuntu1 in bionic i386
  juju-mongo-tools3.2 3.2.4+ds-0ubuntu1 in bionic ppc64el
  juju-mongo-tools3.2 3.2.4+ds-0ubuntu1 in bionic s390x
Comment: FTBFS, unused; LP: #1730706
1 package successfully removed.
Removing packages from bionic-proposed:
 juju-mongo-tools3.2 3.2.4+ds-0ubuntu2 in bionic
Comment: FTBFS, unused; LP: #1730706
1 package successfully removed.

Changed in juju-mongo-tools3.2 (Ubuntu Bionic):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers