upgrade juju-mongodb3.2 to 3.2.15

Bug #1699354 reported by Michael Hudson-Doyle on 2017-06-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-mongodb3.2 (Ubuntu)
Undecided
Michael Hudson-Doyle
Xenial
Undecided
Michael Hudson-Doyle
Yakkety
Undecided
Michael Hudson-Doyle
Zesty
Undecided
Michael Hudson-Doyle

Bug Description

[Impact]
The previous juju-mongodb3.2 version was 3.2.12. 3.2.13, 3.2.14 and 3.2.15 contain numerous bug fixes, some of which are important to Juju. Of particular interest are:

https://jira.mongodb.org/browse/SERVER-25318
https://jira.mongodb.org/browse/SERVER-26076
https://jira.mongodb.org/browse/SERVER-26381
https://jira.mongodb.org/browse/SERVER-28548
https://jira.mongodb.org/browse/SERVER-24963
https://jira.mongodb.org/browse/SERVER-28026
https://jira.mongodb.org/browse/SERVER-26452
https://jira.mongodb.org/browse/SERVER-22053
https://jira.mongodb.org/browse/SERVER-26136
https://jira.mongodb.org/browse/SERVER-25789
https://jira.mongodb.org/browse/SERVER-27347
https://jira.mongodb.org/browse/SERVER-28877
https://jira.mongodb.org/browse/SERVER-28578

There are also numerous performance related improvements, especially for the WiredTiger storage engine.

[Test Case]
Nothing specific as the above bugs only appear in large systems.

[Regression potential]
Slight, as the only consumer of this package is juju. Juju's CI will be run on the proposed packages before this bug is marked verification-done.

Changed in juju-mongodb3.2 (Ubuntu):
status: New → Fix Released

The previous juju-mongodb3.2 version was 3.2.12. 3.2.13 and 3.2.14 contains numerous bug fixes, some of which are important to Juju. Of particular interest are:

https://jira.mongodb.org/browse/SERVER-25318
https://jira.mongodb.org/browse/SERVER-26076
https://jira.mongodb.org/browse/SERVER-26381
https://jira.mongodb.org/browse/SERVER-28548
https://jira.mongodb.org/browse/SERVER-24963
https://jira.mongodb.org/browse/SERVER-28026
https://jira.mongodb.org/browse/SERVER-26452
https://jira.mongodb.org/browse/SERVER-22053

There are also numerous performance related improvements, especially for the WiredTiger storage engine.

description: updated
summary: - upgrade juju-mongodb3.2 to 3.2.14
+ upgrade juju-mongodb3.2 to 3.2.15
description: updated
Changed in juju-mongodb3.2 (Ubuntu):
status: Fix Released → In Progress
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in juju-mongodb3.2 (Ubuntu Yakkety):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in juju-mongodb3.2 (Ubuntu Zesty):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in juju-mongodb3.2 (Ubuntu Xenial):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in juju-mongodb3.2 (Ubuntu Zesty):
status: New → In Progress
status: In Progress → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-mongodb3.2 - 3.2.15-0ubuntu1

---------------
juju-mongodb3.2 (3.2.15-0ubuntu1) artful; urgency=medium

  * New upstream release. (LP: #1699354)

 -- Michael Hudson-Doyle <email address hidden> Mon, 10 Jul 2017 11:48:35 +1200

Changed in juju-mongodb3.2 (Ubuntu):
status: In Progress → Fix Released
Changed in juju-mongodb3.2 (Ubuntu Xenial):
status: New → In Progress
Changed in juju-mongodb3.2 (Ubuntu Yakkety):
status: New → In Progress
Changed in juju-mongodb3.2 (Ubuntu Zesty):
status: New → In Progress
Steve Langasek (vorlon) on 2017-08-04
Changed in juju-mongodb3.2 (Ubuntu Yakkety):
status: In Progress → Won't Fix
Steve Langasek (vorlon) wrote :

Regarding this as covered by the JujuUpdates exception.

Changed in juju-mongodb3.2 (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty

Hello Michael, or anyone else affected,

Accepted juju-mongodb3.2 into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-mongodb3.2/3.2.15-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steve Langasek (vorlon) wrote :

Hello Michael, or anyone else affected,

Accepted juju-mongodb3.2 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-mongodb3.2/3.2.15-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in juju-mongodb3.2 (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Nicholas Skaggs (nskaggs) wrote :

Michael, these failed to build on some arches; so looks like they didn't move into proposed (we are always running proposed). Nevertheless, I've installed them now onto our xenial and zesty CI slaves so they will run through the slew of testing now. We'll monitor for regressions.

On 11 August 2017 at 03:22, Nicholas Skaggs <email address hidden>
wrote:

> Michael, these failed to build on some arches; so looks like they didn't
> move into proposed

No... they are in proposed, I promise. They are not in updates yet. that's
what all this is about :)

> (we are always running proposed)

Why would you do that? Do you possibly have proposed and updates mixed up?
Running with updates enabled is always good, running with proposed enabled
is pretty risky.

> . Nevertheless, I've
> installed them now onto our xenial and zesty CI slaves so they will run
> through the slew of testing now. We'll monitor for regressions.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers