[SRU] Juju 2.3.2

Bug #1744968 reported by Nicholas Skaggs on 2018-01-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core (Ubuntu)
Undecided
Nicholas Skaggs
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
nplan (Ubuntu)
High
Mathieu Trudel-Lapierre
Xenial
High
Mathieu Trudel-Lapierre
Artful
High
Mathieu Trudel-Lapierre

Bug Description

This syncs juju with the upstream release bringing the latest bugfixes and enhancements.

[SRU Information]
juju-core has a stable release exception, including for major version updates, https://wiki.ubuntu.com/JujuUpdates.

[Impact]
A full list of targeted bugs can be seen against the milestone, and the intervening milestones:

https://launchpad.net/juju/+milestone/2.3.2

[QA/Testing]
Juju practices continuous integration and testing of the juju source tree. The results for this release can be seen here:

http://qa.jujucharms.com/releases/6159

In addition, juju has adt test coverage for all supported archs, http://autopkgtest.ubuntu.com/packages/j/juju-core/.

Finally, manual verification and testing of the package has been done per https://wiki.ubuntu.com/JujuUpdates

Changed in juju-core (Ubuntu):
assignee: nobody → Nicholas Skaggs (nskaggs)
status: New → In Progress

This affects netplan too in xenial (and by the same token, I'll land this SRU fix to artful as well).

Code is ready in git, just needs a proper "backport" of netplan to the affected releases.

Changed in nplan (Ubuntu):
status: New → Fix Released
Changed in nplan (Ubuntu Xenial):
status: New → In Progress
Changed in nplan (Ubuntu Artful):
status: New → In Progress
Changed in nplan (Ubuntu Xenial):
importance: Undecided → High
Changed in nplan (Ubuntu Artful):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in nplan (Ubuntu Xenial):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in nplan (Ubuntu):
status: Fix Released → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in juju-core (Ubuntu Xenial):
status: New → In Progress
Changed in juju-core (Ubuntu Artful):
status: New → Invalid

To clarify: we need this SRU to land before we can make further updates to nplan, since nplan will start installing an /etc/network/interfaces file containing just a comment pointing to the new location of configurations in a netplan world, but that file might confuse juju.

This SRU includes the fixes to avoid having juju confused by /etc/network/interfaces.

See https://bugs.launchpad.net/ubuntu/+source/nplan/+bug/1744993.

Hello Nicholas, or anyone else affected,

Accepted juju-core into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-core/2.3.2-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in juju-core (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Nicholas Skaggs (nskaggs) wrote :

I tested juju 2.3.2 and found it working, able to bootstrap, deploy, bash completion all work. I deployed a bionic controller and workload as well without any apparent issues.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 2.3.2-0ubuntu0.16.04.1

---------------
juju-core (2.3.2-0ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream release. (LP: #1744968)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 07 Feb 2018 15:35:21 -0500

Changed in juju-core (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for juju-core has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.33

---------------
nplan (0.33) bionic; urgency=medium

  * replug: Do not unbind ath9kl_sdio. Thanks Oliver! (LP: #1741910)
  * doc: fix syntax for IPv6 example addresses. IPv6 needs to be escaped in
    YAML. (LP: #1735317)
  * debian/postinst: Write breadcrumbs on disk in /etc/network/interfaces to
    denote the migration to using netplan. (LP: #1744968)
  * bridge: implement port-priority support for the NM and networkd backends.
    (LP: #1735821)
  * doc: routes are not top-level but per-interface. (LP: #1726695)
  * Rework CLI parsing / code layout to better handle subcommands.

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 23 Jan 2018 11:32:47 -0500

Changed in nplan (Ubuntu):
status: In Progress → Fix Released
Changed in juju-core (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers