[SRU] Juju 2 GA

Bug #1617440 reported by Nicholas Skaggs
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned
Zesty
High
Unassigned

Bug Description

Juju 2.0 is now final! This upgrades juju to the GA release.

[SRU Information]

juju-core has a stable release exception, including for major version updates, https://wiki.ubuntu.com/JujuUpdates.

[Impact]
This update fixes the LXD regression affecting juju in xenial: bug 1614559.
It also removes 32-bit packages and provides a debconf notice upon installation or upgrade. See https://lists.ubuntu.com/archives/ubuntu-release/2016-September/003882.html. Finally it adds a sysctl config to help the lxd provider: bug 1631038.

In addition, numerous bug fixes have occurred bringing juju up to production readiness.

A full list of targeted bugs can be seen against the milestone, and the intervening milestones:

https://launchpad.net/juju/2.0/2.0-beta16
https://launchpad.net/juju/2.0/2.0-beta17
https://launchpad.net/juju/2.0/2.0-beta18
https://launchpad.net/juju/2.0/2.0-rc1
https://launchpad.net/juju/2.0/2.0-rc2
https://launchpad.net/juju/2.0/2.0-rc3
https://launchpad.net/juju/2.0/2.0.0

[QA/Testing]
Juju practices continuous integration and testing of the juju source tree. The results for this release can be seen here.

http://reports.vapour.ws/releases/4486

In addition, juju has adt test coverage for all supported archs, http://autopkgtest.ubuntu.com/packages/j/juju-core/.

Finally, manual verification and testing of the package has been done per https://wiki.ubuntu.com/JujuUpdates

summary: - [SRU] Juju 2 beta 16 for Xenial
+ [SRU] Juju 2 beta 17 for Xenial
description: updated
summary: - [SRU] Juju 2 beta 17 for Xenial
+ [SRU] Juju 2-rc3 for Xenial
description: updated
summary: - [SRU] Juju 2-rc3 for Xenial
+ [SRU] Juju 2 GA
description: updated
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :
Changed in juju-core (Ubuntu Zesty):
status: New → Fix Released
Changed in juju-core (Ubuntu Xenial):
status: New → In Progress
Changed in juju-core (Ubuntu Yakkety):
status: New → In Progress
Changed in juju-core (Ubuntu Xenial):
importance: Undecided → High
Changed in juju-core (Ubuntu Yakkety):
importance: Undecided → High
Changed in juju-core (Ubuntu Zesty):
importance: Undecided → High
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Nicholas, or anyone else affected,

Accepted juju-core into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-core/2.0.0-0ubuntu0.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in juju-core (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Nicholas, or anyone else affected,

Accepted juju-core into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-core/2.0.0-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in juju-core (Ubuntu Xenial):
status: In Progress → Fix Committed
Revision history for this message
Nicholas Skaggs (nskaggs) wrote :

Xenial package installed and working as expected.

tags: added: verification-done
removed: verification-needed
tags: added: v-done-xenial
removed: verification-done
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello Nicholas, or anyone else affected,

Accepted juju-core into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-core/2.0.0-0ubuntu0.16.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: v-done-yakkety
removed: verification-needed
tags: added: verification-done-xenial verification-done-yakkety
removed: v-done-xenial v-done-yakkety
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 2.0.0-0ubuntu0.16.10.3

---------------
juju-core (2.0.0-0ubuntu0.16.10.3) yakkety; urgency=medium

  * debian/control: Fix the build failure due to dependency issues.
    (LP: #1617440)
    - Nope, we really don't want a Build-Depends on golang-github-coreos-go-
      systemd-dev.
    - Drop golang-go.crypto from Build-Depends.

juju-core (2.0.0-0ubuntu0.16.10.2) yakkety; urgency=medium

  * Restore golang-github-coreos-go-systemd-dev
  * Fix missing dh_install for sysctl file (LP: #1631038)

juju-core (2.0.0-0ubuntu0.16.10.1) yakkety; urgency=medium

  * New upstream release 2.0.0 (LP: #1617440)
  * d/copyright updated for 2.0.0 vendored packages.
  * Add sysctl files for lxd provider (LP: #1631038)
  * Update d/watch file
  * Add upstream signing key
  * Restore golang-golang-x-[crypto,net]-dev dependencies
  * Update bootstrap order for autpopkgtests for juju cli changes

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 03 Nov 2016 11:51:54 -0600

Changed in juju-core (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for juju-core has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 2.0.0-0ubuntu0.16.04.2

---------------
juju-core (2.0.0-0ubuntu0.16.04.2) xenial; urgency=medium

  * DPKG_MAINTSCRIPT_ARCH doesn't work in .config, use dpkg check (LP: #1614969)

 -- Nicholas Skaggs <email address hidden> Mon, 31 Oct 2016 15:55:49 -0400

Changed in juju-core (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers