[needs-packaging] Juju 1.24.7 is not in Ubuntu

Bug #1506652 reported by Curtis Hovey on 2015-10-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core (Ubuntu)
Low
Unassigned
Trusty
Low
Unassigned
Vivid
Low
Unassigned

Bug Description

Juju 1.24.7 addresses changes happening in AWS and MAAS. AWS deprecated the m1* instance types and users of older Jujus are seeing cases where EC2 does not have enough instances. Juju 1.24.7 will ask for newer instance types. Juju 1.24.7 has a dhcp related fix to work with MAAS 1.9.

[SRU Information]

juju-core has a stable release exception in https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions, including for major version updates.

[Devel Fix]

[sinzui] Prepare source package and diffs: DONE
[rbasak] Review package and upload of new upstream release with packaging review: DONE

[Stable Fix]

[sinzui] backport wily source package and prepare diffs for vivid: DONE
[rbasak] Review package for vivid-proposed: DONE
[sinzui] backport source package and prepare diffs for trusty: DONE
[rbasak] Review package for trusty-proposed: DONE

[Pre-QA tasks]

[rbasak] Upload to the current supported release (vivid-proposed): DONE
[rbasak] Upload to the current LTS release (trusty-proposed): DONE

[QA Status]

Since there are multiple verifications required, they are listed here as a work item whiteboard status type thing rather than try and track them in a single tag. Please do not mark verification-TODO or remove block-proposed until all following items have passed. If any of these items fail, this bug should be marked verification-failed immediately.

[sinzui] Upstream QA test against Vivid: DONE
[sinzui] Upstream QA test against Trusty: DONE
[sinzui] Upstream release process complete: DONE

Manual tests required:

[sinzui] Test juju-quickstart against vivid-proposed: DONE
[sinzui] Test juju-deployer against vivid-proposed: DONE
[sinzui] Test client and cloud server upgrade against vivid-proposed: DONE
[sinzui] Test client manual bootstrap and add-machine against vivid-proposed: DONE

[sinzui] Test juju-quickstart against trusty-proposed: DONE
[sinzui] Test juju-deployer against trusty-proposed: DONE
[sinzui] Test client and cloud server upgrade against trusty-proposed: DONE
[sinzui] Test client manual bootstrap and add-machine against trusty-proposed: DONE

Curtis Hovey (sinzui) on 2015-10-15
Changed in juju-core (Ubuntu):
status: New → Confirmed
Curtis Hovey (sinzui) wrote :

My branch lp:~sinzui/ubuntu/wily/juju-core/wily-1.24.7 is a simple import of 1.24.7 from 1.24.6. Per previous suggestions, I removed the rules to switch init systems in adt tests. Juju supports both upstart and systemd and adt should test that juju "just works" with the Ubuntu release.

Curtis Hovey (sinzui) wrote :

Attached is the diff from Juju 1.24.6 to 1.24.7. This is a painless diff compared to most Juju releases.
No dependencies changed
Not files were added,
No copyrights or licences changed.

tags: added: upgrade-software-version verification-needed
Curtis Hovey (sinzui) on 2015-10-16
description: updated
Curtis Hovey (sinzui) wrote :

lp:~sinzui/ubuntu/vivid/juju-core/vivid-1.24.7 is a backport of the wily 1.24.7 package I prepared. Attached is a diff of the two packages made using
    diff -r -u -x *.bzr wily-1.24.7/ wily-1.24.7/ > ./1.24.7-vivid-backport.diff
only the changelogs differ.

Curtis Hovey (sinzui) wrote :

Correction:

lp:~sinzui/ubuntu/vivid/juju-core/vivid-1.24.7 is a backport of the wily 1.24.7 package I prepared. Attached is a diff of the two packages made using
    diff -r -u -x *.bzr wily-1.24.7/ vivid-1.24.7/ > ./1.24.7-vivid-backport.diff
only the changelogs differ.

Robie Basak (racb) on 2015-10-19
Changed in juju-core (Ubuntu):
status: Confirmed → Triaged
Changed in juju-core (Ubuntu Vivid):
status: New → Triaged
Curtis Hovey (sinzui) wrote :

This a revised debian diff for wily. I revised the future tests because they were no compatible with trusty. We want a simple backport to trusty and vivid where only the changelog is different from wily. trusty is a sensible to perform future series upgrade tests with because it does not support systemd as modern and future series do.

Curtis Hovey (sinzui) wrote :

lp:~sinzui/ubuntu/trusty/juju-core/trusty-1.24.7 is a backport of the wily 1.24.7 package I prepared. Attached is a diff of the two packages made using
    diff -r -u -x *.bzr wily-1.24.7/ trusty-1.24.7/ > ./1.24.7-trusty-backport.diff
only the changelogs differ.

Curtis Hovey (sinzui) wrote :

To summarise:
    There are 3 branches, one for wily, vivid, and trusty each.
    juju-core's source has no dep changes, or new files. no copyrights or licences changed.
    The wily debian/tests dir was updated to remove the switch to upstart.
    The wily debian/tests dir was updated to skip future-* tests when the release doesn't support systemd (trusty).
    The wily .pc dir was removed.
    The vivid branch is just a backport of the wily branch
    The trusty branch is just a backport of the wily branch

Robie Basak (racb) wrote :

Please could you rebase on 1.24.6-0ubuntu2? I'm not sure whether the MIR changes have any implications for our process either - eg. for Vivid..

Curtis Hovey (sinzui) wrote :

lp:~sinzui/ubuntu/wily/juju-core/wily-1.24.7 is now rebased on 1.24.6-0ubuntu2. After running dep8 tests, I also ran the build deb through the wily Juju CI tests to be certain the package is functionally the same as my previous package.

We need to rethink our plans for backports. dh-golang is not in trusty and vivid doesn't have the right dev packages. I am sure we can unify d/rules if we want, but d/control is harder and maybe not worth reconciling.

Curtis Hovey (sinzui) wrote :

I updated all three branches to get the fake-future.sh fix that was added to 1.24.6-0ubuntu3.

Curtis Hovey (sinzui) wrote :

I created a branch for xenial. This is just a forward port of the wily branch. Only the changelog differs.

description: updated
Robie Basak (racb) on 2015-10-29
Changed in juju-core (Ubuntu Trusty):
status: New → Triaged
Changed in juju-core (Ubuntu):
status: Triaged → Fix Committed
Robie Basak (racb) wrote :

Uploaded 1.24.7 to Wily, with only minor changes. See https://git.launchpad.net/~ubuntu-server/ubuntu/+source/juju-core/+git/packaging/log/?h=basak/vivid and please pull them in for any future uploads.

Good to upload to Trusty with only minor changes again but I'm holding until 1.22.8-0ubuntu1~14.04.1 is released to trusty-updates to avoid risking colliding the two SRUs. As soon as that's done I can upload it. In the meantime I have pushed to https://git.launchpad.net/~ubuntu-server/ubuntu/+source/juju-core/+git/packaging/log/?h=basak/trusty (please pull in the minor changes).

Changed in juju-core (Ubuntu Vivid):
status: Triaged → In Progress
Robie Basak (racb) wrote :

Uploaded 1.24.7 to Trusty now that 1.22.8-0ubuntu1~14.04.1 is in trusty-updates. I'm not sure why it is still in trusty-proposed but that doesn't matter as it should be superceded by this new upload once accepted.

I added a changelog note to explain the packaging difference from the previous packaging of 1.22.8-0ubuntu1~14.04.1 in Trusty, since in the general case packaging changes might introduce regressions so I felt that changes should be pointed out for SRU review. In this case I think the changes are fine. I have made a note of this case in our process documentation for next time.

Changed in juju-core (Ubuntu Trusty):
status: Triaged → In Progress

Hello Curtis, or anyone else affected,

Accepted juju-core into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-core/1.24.7-0ubuntu1~15.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in juju-core (Ubuntu Vivid):
status: In Progress → Fix Committed
Curtis Hovey (sinzui) wrote :

I certify that juju 1.24.7 is suitable for local charm development and testing
using both trusty and vivid containers. Users of vivid juju 1.24.7 can create
new environments in private and public clouds. Vivid juju 1.24.7 can maintain
environments back to 1.18.1 (including 1.24.6 which vivid currently has).
Upgrades of clients and environments from juju 1.24.6 to 1.24.7 work without
need of configuration changes. vivid juju 1.24.7 can manually provision
environments and add-machines.

tags: added: verification-dont-vivid verification-needed-trusty
removed: verification-needed
tags: added: verification-done-vivid
removed: verification-dont-vivid
Curtis Hovey (sinzui) on 2015-11-03
description: updated
Chris J Arges (arges) wrote :

Hello Curtis, or anyone else affected,

Accepted juju-core into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/juju-core/1.24.7-0ubuntu1~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in juju-core (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Curtis Hovey (sinzui) wrote :

I certify that juju 1.24.7 is suitable for local charm development and testing.
Users of trusty juju 1.24.7 can create new environments in private and public
clouds. Trusty juju 1.24.7 can maintain environments back to 1.18.1 (including
1.22.8 which trusty currently has). Upgrades of clients and environments from
juju 1.22.8 to 1.24.7 work without need of configuration changes. Trusty juju
1.24.7 can manually provision environments and add-machines.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Curtis Hovey (sinzui) on 2015-11-05
description: updated
description: updated
Mathew Hodson (mhodson) on 2015-11-06
tags: removed: verification-needed
Mathew Hodson (mhodson) on 2015-11-06
Changed in juju-core (Ubuntu):
importance: Undecided → Low
Changed in juju-core (Ubuntu Trusty):
importance: Undecided → Low
Changed in juju-core (Ubuntu Vivid):
importance: Undecided → Low
Changed in juju-core (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.24.7-0ubuntu1~15.04.1

---------------
juju-core (1.24.7-0ubuntu1~15.04.1) vivid; urgency=medium

  * New upstream microrelease. (Lp: #1506652)
  * Update dep8 tests from Xenial.

 -- <email address hidden> (Curtis C. Hovey) Fri, 16 Oct 2015 17:52:18 +0000

Changed in juju-core (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for juju-core has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.24.7-0ubuntu1~14.04.1

---------------
juju-core (1.24.7-0ubuntu1~14.04.1) trusty; urgency=medium

  [ Curtis C. Hovey ]
  * Backport of 1.24.7 from vivid. (Lp: #1506652)

  [ Robie Basak ]
  * This upload results in the following packaging delta from the previous
    1.22.8-0ubuntu1~14.04.1 in trusty-updates:
    - d/copyright: updated.
    - d/control: gccgo-5 [!amd64 !i386 !armhf] now preferred over gccgo-go
      [!amd64 !i386 !armhf], which is a no-op on Trusty since gccgo-5 doesn't
      exist in Trusty. This minimises the backport delta.
    - d/tests: dep8 tests updated from Xenial.

 -- <email address hidden> (Curtis C. Hovey) Fri, 16 Oct 2015 19:20:29 +0000

Changed in juju-core (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.