[needs-packaging] 1.22.5 is not packaged in trusty

Bug #1462001 reported by Curtis Hovey on 2015-06-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core (Ubuntu)
Medium
Unassigned

Bug Description

We're now in a position to have 1.22.5 enter trusty-proposed.

[SRU Information]

juju-core has a stable release exception in https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions, including for major version updates.

[Devel Fix]

[sinzui] Prepare source package, and diffs: DONE
[rbasak] Review package and upload of new upstream release with packaging review. Will remove the block-proposed tag when verification has passed, and then this update should migrate to vivid.

[Stable Fix]

Full backport of new upstream release to trusty.

[Pre-QA tasks]

[<rbasak>] Upload to the current LTS release (trusty-proposed): DONE

[QA Status]

Since there are multiple verifications required, they are listed here as a work item whiteboard status type thing rather than try and track them in a single tag. Please do not mark verification-done or remove block-proposed until all following items have passed. If any of these items fail, this bug should be marked verification-failed immediately.

[sinzui] Upstream QA test against wily: DONE
[sinzui] Upstream QA test against Trusty: TODO
[sinzui] Upstream release process complete: TODO

Manual tests required:

[sinzui] Test juju-quickstart against wily-proposed: DONE
[sinzui] Test juju-deployer against wily-proposed: DONE
[sinzui] Test juju-quickstart against trusty-proposed: TODO
[sinzui] Test juju-deployer against trusty-proposed: TODO

The following stakeholders have expressed an interest in performing their own tests and we will wait for a (timely) acknowledgement from them before removing the -proposed blocks. If you also have an interest in testing new Juju releases before they land in an SRU, then please comment in this bug.

Landscape team QA: TODO

Curtis Hovey (sinzui) on 2015-06-04
tags: added: needs-packaging
Curtis Hovey (sinzui) on 2015-06-04
description: updated
Curtis Hovey (sinzui) on 2015-06-04
description: updated
description: updated
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - 1.22.5 is not packaged in trusty
+ [needs-packaging] 1.22.5 is not packaged in trusty
Changed in juju-core (Ubuntu):
importance: Undecided → Wishlist
Robie Basak (racb) wrote :

Technically we want upgrade-software-version, not needs-packaging.

tags: added: upgrade-software-version
removed: needs-packaging
Changed in juju-core (Ubuntu):
importance: Wishlist → Medium
status: New → Triaged
Robie Basak (racb) wrote :

Your branch looks good, thanks. I found some minor issues for which I'll attach fixes, and three upstream licensing issues. Two just need reporting upstream and don't need to block an upload in Ubuntu. The third is a Canonical upstream with possibly an error in license choice - if upstream can confirm intent, then we can upload:

src/golang.org/x/net/html/charset/testdata/README: allows "W3C 3-clause BSD
license" which requires the license to be reproduced here but it isn't. Not a
blocker for upload in Ubuntu (we can infer) but should be reported upstream.

src/gopkg.in/mgo.v2/internal/sasl/ does not include the Apache license in the
distribution as required by the license. Not a blocker for upload in Ubuntu (we
can infer) but should be reported upstream.

src/github.com/juju/txn: new files say AGPL but refer to LICENSE which says
LGPL. debian/copyright says LGPL for all of txn. If upstream can clarify that
LGPL was intended (eg. in a commit fixing it) then we can infer that the
current debian/copyright is correct and then this won't block an upload.

Robie Basak (racb) wrote :
Curtis Hovey (sinzui) wrote :

The src/github.com/juju/txn issue is fixed in commit 99ec629d0066a4d73c54d8e021a7fc1dc07df614 in upstream master
    https://github.com/juju/txn/commit/99ec629d0066a4d73c54d8e021a7fc1dc07df614

The files are LGPL. Upstream juju is also switching to src/github.com/juju/txn tip.

Curtis Hovey (sinzui) wrote :

I pushed the debian/copyright updates to lp:~sinzui/ubuntu/wily/juju-core/juju-1.22.5. I hope this branch is suitable to make the wily package.

Curtis Hovey (sinzui) wrote :

Hi Robie.

I updated the source package to include distro-info in build-depends.
    lp:~sinzui/ubuntu/wily/juju-core/juju-1.22.5

This ensure juju can learn about every Ubuntu distro that is know to the host system. I think this addresses the case where Ubuntu chooses to rebuild an old package. After verifing it myself, I also sent it to Lp to confirm
    https://launchpadlibrarian.net/209153111/buildlog_ubuntu-wily-amd64.juju-core_1.22.5-0ubuntu2_BUILDING.txt.gz

Curtis Hovey (sinzui) wrote :

Hi Robie.

I prepared a backport of 1.22.5 to trusting using the trusty-updates spb as a base plus debian/* changes from the wily spb.
    lp:~sinzui/ubuntu/trusty/juju-core/trusty-1.22.5

Curtis Hovey (sinzui) on 2015-06-23
description: updated
Curtis Hovey (sinzui) wrote :

I tested 1.22.5 from wily-proposed. It is suitable to create and maintain cloud deployments. It is compatible with both juju-quickstart and juju-deployer. Note, as with Vivid, 1.22.x is not fit for local charm development and testing because it is not systemd aware. We expect to propose juju 1.24 or greater for Wily soon.

description: updated
Curtis Hovey (sinzui) on 2015-06-29
summary: - [needs-packaging] 1.22.5 is not packaged in trusty
+ [needs-packaging] 1.22.6 is not packaged in trusty
summary: - [needs-packaging] 1.22.6 is not packaged in trusty
+ [needs-packaging] 1.22.5 is not packaged in trusty
Robie Basak (racb) on 2015-07-09
description: updated
Robie Basak (racb) wrote :

Tracking superseded by 1.22.6, tracked in bug 1469744.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.22.6-0ubuntu1

---------------
juju-core (1.22.6-0ubuntu1) wily; urgency=medium

  * New upstream bugfix release.
  * d/copyright updated for Juju 1.22.6 (Last verified commit changes).

 -- <email address hidden> (Curtis C. Hovey) Thu, 25 Jun 2015 18:25:00 +0000

Changed in juju-core (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers