juju-core 1.22.0 is not packaged in Ubuntu

Bug #1416051 reported by Robie Basak on 2015-01-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core (Ubuntu)
Undecided
Robie Basak
Trusty
Undecided
Robie Basak

Bug Description

We're now in a position to have 1.22.0 enter trusty-proposed and vivid-proposed, but it should not land in trusty-updates or vivid until upstream passes QA on our proposed binaries, published the tools in their stable simplestream and announces the release for general production use.

[SRU Information]

juju-core has a stable release exception in https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions, including for major version updates.

[Development Fix]

Upload of new upstream release with packaging review. racb will remove the block-proposed tag when verification has passed, and then this update should migrate to vivid.

[Stable Fix]

Full backport of new upstream release.

[Pre-QA tasks]

[strikov] Upload to the development release (vivid-proposed): DONE
[racb] Upload to the current LTS release (trusty-proposed): POSTPONED

[QA Status]

Since there are multiple verifications required, they are listed here as a work item whiteboard status type thing rather than try and track them in a single tag. Please do not mark verification-done or remove block-proposed until all following items have passed. If any of these items fail, this bug should be marked verification-failed immediately.

[sinzui] Upsteam QA test against Vivid: DONE
[sinzui] Upstream QA test against Trusty: POSTPONED
[sinzui] Upstream release process complete: DONE

Manual tests required:

[sinzui] Test juju-quickstart against vivid-proposed: DONE
[sinzui] Test juju-quickstart against trusty-proposed: POSTPONED

The following stakeholders have expressed an interest in performing their own tests and we will wait for a (timely) acknowledgement from them before removing the -proposed blocks. If you also have an interest in testing new Juju releases before they land in an SRU, then please comment in this bug.

Landscape team QA: ?TODO

Robie Basak (racb) on 2015-01-29
Changed in juju-core (Ubuntu Trusty):
assignee: nobody → Robie Basak (racb)
Matthias Klose (doko) on 2015-03-11
tags: removed: block-proposed
Robie Basak (racb) wrote :

Preparing for 1.22.0.

tags: added: block-proposed
summary: - juju-core 1.21.1 is not packaged in Ubuntu
+ juju-core 1.22.0 is not packaged in Ubuntu
description: updated
Robie Basak (racb) on 2015-03-31
description: updated
Changed in juju-core (Ubuntu):
status: New → Fix Committed
Curtis Hovey (sinzui) on 2015-04-06
description: updated
Curtis Hovey (sinzui) wrote :

I tested juju 1.22.0 on vivid with streams and with quickstart (from vivid). All is good. The client is good for working with all providers and state servers on trusty and precise.

description: updated

Tag block-proposed has been removed to be able to update the package in vivid.
We don't plan to update trusty package with 1.22.0 for now.
I'll post an update to this bug when we make decision on package update in trusty.

tags: removed: block-proposed

Juju 1.22.0 can't provision instances which run vivid because it doesn't support systemd. Systemd support has been introduced in Juju 1.23 and we plan to package this release when it becomes stable (now in beta). However, I think that having 1.22 in vivid is much better than having Juju 1.20 (what we currently have) taking into account that 1.20 doesn't support vivid as well. We get new features of Juju 1.22 and can use them against trusty and precise instances.

Due to the fact that Juju 1.22 can't provision instances which run vivid, many dep8 autotests fail. These tests rely on juju local provider (LXC) and expect to have upstart running on both host machine and guest instance. I made decision to avoid modifying tests because this operation is needed only for 1.22 and will be reverted while packaging 1.23. To do functional testing I modified the image adt-run uses and manually installed upstart there. Then, I run adt-run and get all tests passed:
http://paste.ubuntu.com/10760926/
I think that this can be counted as equivalent to the regular autotests run which is carried out automatically against package in -proposed.

Curtis Hovey (sinzui) from Juju Team carried out all the testing procedures required (see #2) and we are ready to move juju-1.22.0 package from -proposed to release. This can't be done automatically (dep8 tests fail) that's why I'm asking for sponsorship to *manually* move the package to release repo.

Curtis Hovey (sinzui) wrote :

juju 1.22.0 is fit for purpose. The client can work with agents and servers in public and private clouds. The Juju charm store only supports LTS services. It is not possible to place a vivid charm in the store. The only vivid users impaired by missing systemd support are charm developers and testers. There are work aroundd for this case though, such as running juju from a docker container with the network mapped to the host machine -- which is actually a safer way to run local-provider than the recommended way.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.22.0-0ubuntu1

---------------
juju-core (1.22.0-0ubuntu1) vivid; urgency=medium

  * New upstream release (LP: #1416051).
  * d/patches/fix-detect-new-release.patch: Added upstream patch to redeem
    the ability to handle future Ubuntu releases (LP: #1427879, #1434092).
  * d/tests/fake-future.sh: New ability to generate fake /etc/os-release.
  * d/copyright: Updated to reflect changes in the codebase.
  * d/control:
    - Change build dependency from gccgo to gccgo-go.
    - Use either cloud-image-utils or cloud-utils as dependency for juju-local
      because cloud-image-utils is not available on precise.
    - Compliance to Debian Policy 3.9.6 was declared.
 -- Oleg Strikov <email address hidden> Thu, 26 Mar 2015 15:54:39 +0300

Changed in juju-core (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.22.6-0ubuntu1~14.04.1

---------------
juju-core (1.22.6-0ubuntu1~14.04.1) trusty; urgency=medium

  * No change backport to 14.04 (LP: #1469744). This results in the
    following packaging delta from the previous 1.20.11-0ubuntu0.14.04.1
    in trusty-updates:
    - distro-info added and libgo5 removed from Build-Depends.
    - Standards-Version bumped.
    - cloud-image-utils | cloud-utils added to juju-local Depends.
    - d/copyright updated.
    - dep8 tests updated.

 -- Robie Basak <email address hidden> Wed, 15 Jul 2015 13:09:07 +0000

Changed in juju-core (Ubuntu Trusty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints