Cannot be run

Bug #874479 reported by Nils Durner on 2011-10-14
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
juffed (Ubuntu)
Undecided
Unassigned

Bug Description

$ sudo apt-get install juffed

...
Unpacking juffed (from .../juffed_0.9.1137-1_amd64.deb) ...
Unpacking juffed-plugins (from .../juffed-plugins_0.9.1137-1_amd64.deb) ...
...

$ juffed

juffed: error while loading shared libraries: libjuff.so.0.9: cannot open shared object file: No such file or directory

Related branches

Nils Durner (ndurner) on 2011-10-14
summary: - Cannot be installed
+ Cannot be run
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in juffed (Ubuntu):
status: New → Confirmed
Brent Bartlett (hyperqube) wrote :

Same problem; I am also using AMD64.

Jonathan Gallagher (jdgallag84) wrote :

Confirmed. x86_64. I ran strace, the program is trying to load libjuff.so.0.9 from
    /lib/x86_64-linux-gnu/tls/x86_64
However, this folder does not exist. Looking at the installed files list reveals that libjuff is installed to
    /usr/lib64
The following worked works for me:
    1) make the directory /lib/x86_64-linux-gnu/tls/x86_64 (if it doesn't exist)
    2) sudo ln -s /usr/lib64/libjuff.so.0.9 /lib/x86_64-linux-gnu/tls/x86_64

That worked! Thanks a lot!

<-----Original Message----->
>From: Jonathan Gallagher [<email address hidden>]
>Sent: 11/11/2011 1:49:18 AM
>To: <email address hidden>
>Subject: Re: [Bug 874479] Re: Cannot be run
>
>Confirmed. x86_64. I ran strace, the program is trying to load
libjuff.so..0.9
>from
> /lib/x86_64-linux-gnu/tls/x86_64
>However, this folder does not exist. Looking at the installed files
list
>reveals that libjuff is installed to
> /usr/lib64
>The following worked works for me:
> 1) make the directory /lib/x86_64-linux-gnu/tls/x86_64 (if it doesn't
exist)
> 2) sudo ln -s /usr/lib64/libjuff.so.0.9
/lib/x86_64-linux-gnu/tls/x86_64

<p><p>Care2 makes it easy for everyone to live a healthy, green lifestyle
and impact the causes you care about most. Over 12 Million members!
<a href="http://www.care2.com" target=_blank>http://www.care2.com</a><br /><br />
Feed a child by searching the web! Learn how <a href="http://www.care2.com/toolbar" target=_blank>http://www.care2.com/toolbar<a>

selivan (selivan5) wrote :

Thank you, Jonathan Gallagher!

It works now. But this is dirty hack, package is still broken since 2011 :(

Iggy (iggy-theiggy) wrote :

To me a a slightly less hackish workaround is putting the following in
/etc/ld.so.conf.d/juffed.conf and then running "sudo ldconfing":

/usr/lib64/juffed/plugins/
/usr/lib64/juffed
/usr/lib64

Thomas Sisson (thomas-sisson-1) wrote :

Would someone please fix this bug? It is now installable, but the library still cannot be found.

Thanks

Histesh Shah (chimak111) wrote :

I had to use sudo ln -s /usr/lib64/libjuff.so.0.9 /usr/lib/x86_64-linux-gnu/libjuff.so.0.9.
The code in comment #3 did not work for me in Lubuntu 14.04 during the LXQt session.

Histesh Shah (chimak111) wrote :

Make that:
sudo ln -s /usr/lib64/libjuff.so.0.9 /usr/lib/x86_64-linux-gnu/libjuff.so.0.9
all on one line!

Post #3 Solved the problem on Elementary 0.2.1 Built on: Ubuntu 12.04 ( "Precise" ).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juffed - 0.9.1137-1ubuntu4

---------------
juffed (0.9.1137-1ubuntu4) vivid; urgency=medium

  * Do not use lib64 on Ubuntu (LP: #874479).
 -- Dmitry Shachnev <email address hidden> Tue, 04 Nov 2014 18:40:29 +0300

Changed in juffed (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers