Juffed crashes after start

Bug #665994 reported by Vadim Kotov on 2010-10-24
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juffed (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

IMPACT:
 Juffed seg faults on start rendering it unusable

PROPOSED FIX:
 Fixed by rebuilding against up-to-date maverick qt libs

PATCHES REQUIRED:
 No change rebuild

TEST CASE:
 $ sudo apt-get install juffed
 $ juffed
 Segmentation fault

FIX TEST:
 https://edge.launchpad.net/~sevenmachines/+archive/release/+packages

 juffed (0.8.1-1build1) maverick; urgency=low

  * No change rebuild to catch newer qscintilla
 -- SevenMachines <email address hidden> Thu, 02 Dec 2010 06:40:54 +0000

 $ wget https://edge.launchpad.net/~sevenmachines/+archive/release/+files/juffed_0.8.1-1build1_i386.deb
 $ sudo dpkg -i juffed_0.8.1-1build1_i386.deb
 $ juffed

REGRESSION POTENTIAL:
 Crashes on start currently, fix affects no other packages so no regression likely

************ ORIGINAL MESSAGE *************

Binary package hint: juffed

I installed juffed package from ubuntu repo. It crashes right after start.
I'm using Ubuntu 10.10

here is info from /var/log/syslog : Oct 24 22:44:09 desktop kernel: [11362.463057] juffed[6842]: segfault at 1 ip 008a066a sp bfa33410 error 4 in libQtGui.so.4.7.0[62f000+aa2000]

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: juffed 0.8.1-1
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sun Oct 24 22:53:55 2010
ProcEnviron:
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: juffed

Vadim Kotov (kotov) wrote :
Changed in juffed (Ubuntu):
status: New → Confirmed

Confirmed on natty
$ apt-show-versions juffed libqtgui4
juffed/natty uptodate 0.8.1-1
libqtgui4/natty uptodate 4:4.7.0-0ubuntu7

While that may "sound good", it isn't feasible for those who are in "repository
only" environments.

On December 1, 2010 at 2:00 PM Vadim Kotov <email address hidden> wrote:

> As a workaround, anyone can use developer's PPA:
> https://launchpad.net/~mezomish/+archive/juffed,
> https://launchpad.net/~mezomish/+archive/juffed-dev
>
> --
> Juffed crashes after start
> https://bugs.launchpad.net/bugs/665994
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (675305).
>
> Status in “juffed” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: juffed
>
> I installed juffed package from ubuntu repo. It crashes right after start.
> I'm using Ubuntu 10.10
>
> here is info from /var/log/syslog : Oct 24 22:44:09 desktop kernel:
> [11362.463057] juffed[6842]: segfault at 1 ip 008a066a sp bfa33410 error 4 in
> libQtGui.so.4.7.0[62f000+aa2000]
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: juffed 0.8.1-1
> ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Sun Oct 24 22:53:55 2010
> ProcEnviron:
>  LANG=ru_RU.utf8
>  SHELL=/bin/bash
> SourcePackage: juffed
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/juffed/+bug/665994/+subscribe
Roland Hughes, President
Logikal Solutions
(630)-205-1593  - cell
http://www.theminimumyouneedtoknow.com
http://www.infiniteexposure.net

description: updated
Martin Pitt (pitti) wrote :

Subscribing ubuntu-sponsors. Please feel free do that yourself if you can't upload the package. Thanks!

It's not clean for 64-bit users. The offered command lines apparently
don't force library installs. I guess most of us will have to wait
until the next major release of KUbuntu and hope they actually update
things.

-----------------------------------------------
roland@roland-Generic-Desktop1:~$ sudo dpkg -i --force-architecture
juffed_0.8.1-1build1_i386.deb
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
Selecting previously deselected package juffed.
(Reading database ... 178405 files and directories currently installed.)
Unpacking juffed (from juffed_0.8.1-1build1_i386.deb) ...
Setting up juffed (0.8.1-1build1) ...
Processing triggers for man-db ...
roland@roland-Generic-Desktop1:~$ juffed
juffed: error while loading shared libraries: libqscintilla2.so.5:
cannot open shared object file: No such file or directory

-----------------------------------------------

On Fri, 2010-12-10 at 18:02 +0000, Martin Pitt wrote:

> Subscribing ubuntu-sponsors. Please feel free do that yourself if you
> can't upload the package. Thanks!
>

Stefano Rivera (stefanor) wrote :

Uploaded a No change rebuild to maverick-proposed, pending SRU team review

Changed in juffed (Ubuntu):
status: Confirmed → Fix Committed
Changed in juffed (Ubuntu Maverick):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juffed - 0.8.1-1build1

---------------
juffed (0.8.1-1build1) natty; urgency=low

  * No change rebuild to catch newer qscintilla. (LP: #665994)
 -- Stefano Rivera <email address hidden> Sat, 11 Dec 2010 13:22:18 +0200

Changed in juffed (Ubuntu):
status: Fix Committed → Fix Released

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Works here on maverick with 0.8.1-1build0.1 from proposed

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juffed - 0.8.1-1build0.1

---------------
juffed (0.8.1-1build0.1) maverick-proposed; urgency=low

  * No change rebuild to catch newer qscintilla. (LP: #665994)
 -- Stefano Rivera <email address hidden> Sat, 11 Dec 2010 13:25:13 +0200

Changed in juffed (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers