juffed crashed with SIGSEGV in Font::Create()

Bug #1426793 reported by Lyn Perrine on 2015-02-28
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juffed (Debian)
Fix Released
Unknown
juffed (Ubuntu)
Medium
Unassigned

Bug Description

To reproduce in pcmanfm mount an external hard drive that is ntfs formatted and then navigate to a text file like called dryer_part_info. Then right click to bring up a context menu and select open with from the menu in pcmanfm. Juffed will start to launch and then apport appears saying juffed had crashed. Or select file new from the menu is an easier way to reproduce.

Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

juffed:
  Installed: 0.9.1137-1ubuntu4
  Candidate: 0.9.1137-1ubuntu4
  Version table:
 *** 0.9.1137-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status
pcmanfm:
  Installed: 1.2.3-1.1
  Candidate: 1.2.3-1.1
  Version table:
 *** 1.2.3-1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status

libfm4:
  Installed: 1.2.3-0ubuntu1
  Candidate: 1.2.3-0ubuntu1
  Version table:
 *** 1.2.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: juffed 0.9.1137-1ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic x86_64
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
CurrentDesktop: LXDE
Date: Sat Feb 28 15:45:42 2015
ExecutablePath: /usr/bin/juffed
InstallationDate: Installed on 2014-09-30 (150 days ago)
InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140930)
ProcCmdline: juffed /media/username/Seagate\ Expansion\ Drive/brendyLaptopssd/dryer_part_info
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fac7db3e635 <_ZN4Font6CreateERK14FontParameters+153>: movzbl (%rax),%eax
 PC (0x7fac7db3e635) ok
 source "(%rax)" (0x006f0000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11To reproduce in pcmanfm mount an external hard drive that is ntfs formatted and then navigate to a text file likTo reproduce in pcmanfm mount an external hard drive that is ntfs formatted and then navigate to a text file like called dryer_part_info. Then right click to bring up a context menu and select open with from the menu in pcmanfm. Juffed will start to launch and then apport appears saying juffed had crashed.

To reproduce in pcmanfm mount an external hard drive that is ntfs formatted and then navigate to a text file like called dryer_part_info. Then right click to bring up a context menu and select open with from the menu in pcmanfm. Juffed will start to launch and then apport appears saying juffed had crashed.

e called dryer_part_info. Then right click to bring up a context menu and select open with from the menu in pcmanfm. Juffed will start to launch and then apport appears saying juffed had crashed.

SourcePackage: juffed
StacktraceTop:
 Font::Create(FontParameters const&) () from /usr/lib/libqscintilla2.so.11
 FontRealised::Realise(Surface&, int, int, FontSpecification const&) () from /usr/lib/libqscintilla2.so.11
 ViewStyle::Refresh(Surface&, int) () from /usr/lib/libqscintilla2.so.11
 Editor::RefreshStyleData() () from /usr/lib/libqscintilla2.so.11
 Editor::SetScrollBars() () from /usr/lib/libqscintilla2.so.11
Title: juffed crashed with SIGSEGV in Font::Create()
UpgradeStatus: Upgraded to vivid on 2014-12-12 (78 days ago)
UserGroups: libvirtd sudoTo reproduce in pcmanfm mount an external hard drive that is ntfs formatted and then navigate to a text file like called dryer_part_info. Then right click to bring up a context menu and select open with from the menu in pcmanfm. Juffed will start to launch and then apport appears saying juffed had crashed.

Possible workaround to get a new file is to open a file manager create a new file and then open it with juffed and I can confirm thiw works with pcmanfm.

Lyn Perrine (walterorlin) wrote :

StacktraceTop:
 Font::Create (this=0x2874330, fp=...) at PlatQt.cpp:125
 FontRealised::Realise (this=0x2874310, surface=..., zoomLevel=0, technology=0, fs=...) at ../src/ViewStyle.cpp:79
 ViewStyle::Refresh (this=0x27f4520, surface=..., tabInChars=8) at ../src/ViewStyle.cpp:318
 Editor::RefreshStyleData (this=0x27f44e0) at ../src/Editor.cpp:349
 Editor::SetScrollBars (this=0x27f44e0) at ../src/Editor.cpp:3985

Changed in juffed (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: wily
information type: Private → Public
description: updated
Changed in juffed (Debian):
status: Unknown → Fix Released
Logan Rosen (logan) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package juffed - 0.10-85-g5ba17f9-9

---------------
juffed (0.10-85-g5ba17f9-9) unstable; urgency=medium

  * Following the Multiarch hinter
    - Marked juffed-plugins Multi-Arch: same
    - Marked libjuff0.10 Multi-Arch: same
    - libjuffed-engine-qsci0.10 Multi-Arch: same

 -- Alf Gaida <email address hidden> Tue, 27 Sep 2016 23:11:37 +0200

juffed (0.10-85-g5ba17f9-8) unstable; urgency=medium

  * Set build language in rules: export LC_ALL=C.UTF-8

 -- Alf Gaida <email address hidden> Mon, 19 Sep 2016 16:35:52 +0200

juffed (0.10-85-g5ba17f9-7) unstable; urgency=medium

  * Fixed typo in changelog

 -- Alf Gaida <email address hidden> Mon, 19 Sep 2016 04:06:51 +0200

juffed (0.10-85-g5ba17f9-6) unstable; urgency=medium

  * Bump compat to 10
  * Bump build dependency debhelper (>=10)
  * set --builddirectory=./build, hopefully make the package reproducible

 -- Alf Gaida <email address hidden> Sun, 18 Sep 2016 17:25:40 +0200

juffed (0.10-85-g5ba17f9-5) unstable; urgency=medium

  * Fixed symbols for armel and armhf, since gcc 6.2 seems to create
    different symbols than its predecessor

 -- Alf Gaida <email address hidden> Fri, 26 Aug 2016 01:06:39 +0200

juffed (0.10-85-g5ba17f9-4) unstable; urgency=medium

  * Cherry-picked changes from experimental
  * Switch to unstable

 -- Alf Gaida <email address hidden> Thu, 25 Aug 2016 19:52:11 +0200

juffed (0.10-85-g5ba17f9-3) experimental; urgency=medium

  * Added missed blank in symbols

 -- Alf Gaida <email address hidden> Tue, 23 Aug 2016 21:37:35 +0200

juffed (0.10-85-g5ba17f9-2) experimental; urgency=medium

  * Fixed symbols - symbol not in powerpc

 -- Alf Gaida <email address hidden> Tue, 23 Aug 2016 19:22:28 +0200

juffed (0.10-85-g5ba17f9-1) experimental; urgency=medium

  * Adding upstream version 0.10-85-g5ba17f9.
    (Closes: #742580, #675293, #688483, #798065, #812133, #591398)
  * Switch to experimental
  * README.debian added
  * Deleted not needed debian/patches
  * Bump compat to 9
  * Renamed install to juffed.install
  * Added debian/.gitignore
  * New maintainer: LXQt Packaging Team (Closes: #829319)
  * Added myself to Uploaders
  * Added ChangZhuo Chen to Uploaders
  * Bump Standards to 3.9.8, no changes needed
  * Added Homepage
  * Added secure VCS-Fields
  * Updated build dependencies for Qt 5
  * Updated package descriptions
  * Added libjuff0.10 and libjuffed-engine-qsci0.10
  * Removed outdated and false manpage
  * Fixed juffed-dev.install
  * Fixed juffed.install
  * Fixed juffed-plugins.install
  * Added libjuff0.10.install and libjuff0.10.symbols
  * Added libjuffed-engine-qsci0.10.install and
    libjuffed-engine-qsci0.10.symbols
  * Fixed debian/rules - build with Qt5, hardening
  * Fixed the copyright format line
  * Fixed upstream-name and source in copyright
  * Fixed watch file
  * Fixed debian/copyrights
  * Added LGPL-2.1-with-Nokia-Qt-LGPL-Exception-version-1.1-or-GPL-3
    to copyrights
  * Fixed package descriptions.
  * Added lintian-override for missed man-page
  * Override missed man-page
  * Set CMAKE_BUILD_TYPE=RelWithDebInfo
  * Added terminal support
  * Applied two upstream patches by Philipp Wiese...

Read more...

Changed in juffed (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.