jpilot-syncmal trashes Avantgo settings after Edgy update

Bug #68452 reported by John McCreesh on 2006-10-26
12
Affects Status Importance Assigned to Milestone
jpilot-syncmal (Ubuntu)
Undecided
Unassigned
Edgy
Undecided
Unassigned

Bug Description

I've used J-Pilot on a daily basis to hotsynch my Palm V and download Avantgo material under Breezy and Dapper. After upgrading to Edgy, J-Pilot 0.99.9 works fine except SyncMAL 0.72.2 no longer loads Avantgo material into the Palm. It appears to skip the step during the hotsync, but when I look on the Palm all the server connection data has been lost.

If I re-enter the 'sync.avantgo.com' etc settings, malsync 2.0.0 works perfectly from the command line time and time again. However, if I hotsync from J-Pilot, the Palm settings are trashed immediately and malsync won't work until I re-type the server settings into the Palm.

I'm using AvantoGo / Avantgo Connect 4.2 under Palm OS v3.3

Dirk Eddelbuettel (edd) wrote :

I can confirm this -- same buggy behavior on my Edgy/6.06 system that has been upgraded continuously via the previous two release.

Advice on how to fix this, or how to workaround it, would be welcome.

Dirk

I have the same problem:

Ubuntu Edgy Eft
jpilot 0.99.9-2
jpilot-syncmal 0.72.2-1

Does anybody now how to fix this?

John McCreesh (jpmcc) wrote :

I've had an email from Jason Day:

"I believe I've got this fixed now. I can't send you a binary, but if you are comfortable building packages from source here is where you can download a preview:

http://jasonday.home.att.net/code/syncmal/jpilot-syncmal-0.73pre.tar.gz

"You will need to have the development packages installed for gtk and pilot-link (and maybe libpisock) to build it. If you get it working, please let me know.

"I'll get this cleaned up and released on my site soon, but I don't know how long it will take to make it into ubuntu's package repository."

Since reporting this bug I've bought a Palm TX which uses a WiFi link to synch with Avantgo, so I can't test whether this fix works. If someone could test it and report back here, I can pass the message on to Jason.

Thanks - John

Thank you very much. It works perfect on Ubuntu Edgy Eft. :-)

On 4 December 2006 at 08:26, John McCreesh wrote:
| I've had an email from Jason Day:
|
| "I believe I've got this fixed now. I can't send you a binary, but if
| you are comfortable building packages from source here is where you can
| download a preview:
|
| http://jasonday.home.att.net/code/syncmal/jpilot-syncmal-0.73pre.tar.gz
|
| "You will need to have the development packages installed for gtk and
| pilot-link (and maybe libpisock) to build it. If you get it working,
| please let me know.
|
| "I'll get this cleaned up and released on my site soon, but I don't know
| how long it will take to make it into ubuntu's package repository."
|
| Since reporting this bug I've bought a Palm TX which uses a WiFi link to
| synch with Avantgo, so I can't test whether this fix works. If someone
| could test it and report back here, I can pass the message on to Jason.
|
| Thanks - John

Thanks for the heads-up, and to Jason for the updated.

I just applied the debian/ directory from the current package to these new
sources, rebuilt it and installed the resulting .deb on my Ubuntu machine.
Works like a charm.

Thanks to all, Dirk

--
Hell, there are no rules here - we're trying to accomplish something.
                                                  -- Thomas A. Edison

John McCreesh (jpmcc) wrote :

Thanks for confirming that Jason has solved the problem. I've emailed Ludovic Rousseau and Daniel Holbach to see if they can get Jason's new code into Ubuntu.

John

d selby (kbmaniac) wrote :

Any news on getting this code into edgy ubuntu ? Its feb 07 now and syncmal is still trashing my avantgo palm settings.

I tried compiling syncmal 0.8 but hit dependency probs - could not find pilot-link header files, adept does not appear to list the dev files for this package ... I could compile it from source as well but its then getting a bit hairy :)

Cheers
Dave S

Changed in jpilot-syncmal:
status: Unconfirmed → Fix Released
Hew (hew) wrote :

Ubuntu Edgy Eft is no longer supported, so a SRU will not be issued for this release. Marking Edgy as Won't Fix.

Changed in jpilot-syncmal:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers