Ubuntu

Touchscreen not working, Lenovo X201t

Reported by j-b-m on 2011-08-27
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
joystick (Debian)
Fix Released
Unknown
joystick (Ubuntu)
Undecided
Unassigned

Bug Description

The touchscreen of my Lenovo X201T does not work in Oneiric, it was working with Natty.

Using Oneiric with latest updates, same for the daily live CD from 27 august 2011.

xserver-xorg-input-wacom is at version: 1:0.11.0-0ubuntu1

The Xorg log shows the following info:

[ 46.557] (II) config/udev: Adding input device Serial Wacom Tablet (/dev/ttyS4)
[ 46.557] (**) Serial Wacom Tablet: Applying InputClass "Wacom serial class"
[ 46.557] (II) LoadModule: "wacom"
[ 46.557] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 46.557] (II) Module wacom: vendor="X.Org Foundation"
[ 46.557] compiled for 1.10.1, module version = 0.11.0
[ 46.557] Module class: X.Org XInput Driver
[ 46.557] ABI class: X.Org XInput driver, version 12.3
[ 46.557] (II) Using input driver 'wacom' for 'Serial Wacom Tablet'
[ 46.557] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 46.557] (**) Serial Wacom Tablet: always reports core events
[ 46.557] (**) Option "Device" "/dev/ttyS4"
[ 46.558] (II) Serial Wacom Tablet: type not specified, assuming 'stylus'.
[ 46.558] (II) Serial Wacom Tablet: other types will be automatically added.
[ 46.558] (EE) Serial Wacom Tablet stylus: wcmWriteWait error : Input/output error
[ 46.558] (WW) Serial Wacom Tablet stylus: Query failed with 38400 baud. Trying 19200.
[ 46.558] (EE) Serial Wacom Tablet stylus: wcmWriteWait error : Input/output error
[ 46.558] (EE) Serial Wacom Tablet stylus: wcmWriteWait error : Input/output error
[ 46.558] (II) Serial Wacom Tablet stylus: serial tablet id 0xE3.
[ 46.558] (EE) PreInit returned 8 for "Serial Wacom Tablet stylus"
[ 46.558] (II) UnloadModule: "wacom"
[ 46.558] (II) Unloading wacom
[ 46.558] (II) config/udev: Adding input device Wacom Serial Touchscreen (/dev/input/event13)
[ 46.558] (**) Wacom Serial Touchscreen: Applying InputClass "evdev tablet catchall"
[ 46.558] (**) Wacom Serial Touchscreen: Applying InputClass "Wacom class"
[ 46.558] (II) Using input driver 'wacom' for 'Wacom Serial Touchscreen'
[ 46.558] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 46.558] (**) Wacom Serial Touchscreen: always reports core events
[ 46.558] (**) Option "Device" "/dev/input/event13"
[ 46.656] (EE) PreInit returned 8 for "Wacom Serial Touchscreen"
[ 46.656] (II) UnloadModule: "wacom"
[ 46.656] (II) Unloading wacom

I tried to compile xf86-input-wacom latest version from git but it does not improve the situation.
Let me know if you need more infos, testing, etc...

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xserver-xorg-input-wacom 1:0.11.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic-pae 3.0.3
Uname: Linux 3.0.0-9-generic-pae i686
Architecture: i386
Date: Sat Aug 27 21:54:40 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xf86-input-wacom
UpgradeStatus: Upgraded to oneiric on 2011-08-20 (7 days ago)

j-b-m (jb-kdenlive) wrote :
j-b-m (jb-kdenlive) wrote :
Download full text (5.1 KiB)

If it can be of any help, here is the xorg log when using Natty (from live CD) on the same machine, with the touchscreen working correctly.

[ 101.106] (II) config/udev: Adding input device Serial Wacom Tablet (/dev/ttyS4)
[ 101.106] (**) Serial Wacom Tablet: Applying InputClass "Wacom serial class"
[ 101.106] (II) LoadModule: "wacom"
[ 101.107] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 101.107] (II) Module wacom: vendor="X.Org Foundation"
[ 101.107] compiled for 1.10.0, module version = 0.10.11
[ 101.107] Module class: X.Org XInput Driver
[ 101.107] ABI class: X.Org XInput driver, version 12.3
[ 101.107] (II) Using input driver 'wacom' for 'Serial Wacom Tablet'
[ 101.107] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 101.108] (**) Serial Wacom Tablet: always reports core events
[ 101.108] (**) Option "Device" "/dev/ttyS4"
[ 101.108] (**) Option "StopBits" "1"
[ 101.108] (**) Option "DataBits" "8"
[ 101.108] (**) Option "Parity" "None"
[ 101.108] (**) Option "Vmin" "1"
[ 101.108] (**) Option "Vtime" "10"
[ 101.108] (**) Option "FlowControl" "Xoff"
[ 101.108] (II) Serial Wacom Tablet: type not specified, assuming 'stylus'.
[ 101.108] (II) Serial Wacom Tablet: other types will be automatically added.
[ 101.624] (II) Serial Wacom Tablet stylus: serial tablet id 0xE3.
[ 101.624] (--) Serial Wacom Tablet stylus: using pressure threshold of 27 for button 1
[ 101.624] (--) Serial Wacom Tablet stylus: Wacom General ISDV4 tablet maxX=26312 maxY=16520 maxZ=127 resX=100000 resY=100000 tilt=disabled
[ 101.624] (II) Serial Wacom Tablet stylus: hotplugging dependent devices.
[ 101.624] (**) Serial Wacom Tablet eraser: Applying InputClass "Wacom serial class"
[ 101.624] (II) Using input driver 'wacom' for 'Serial Wacom Tablet eraser'
[ 101.624] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 101.624] (**) Serial Wacom Tablet eraser: always reports core events
[ 101.624] (**) Option "Device" "/dev/ttyS4"
[ 101.624] (**) Option "BaudRate" "38400"
[ 101.624] (**) Option "StopBits" "1"
[ 101.624] (**) Option "DataBits" "8"
[ 101.624] (**) Option "Parity" "None"
[ 101.624] (**) Option "Vmin" "1"
[ 101.624] (**) Option "Vtime" "10"
[ 101.624] (**) Option "FlowControl" "Xoff"
[ 101.624] (--) Serial Wacom Tablet eraser: Wacom General ISDV4 tablet maxX=26312 maxY=16520 maxZ=127 resX=100000 resY=100000 tilt=disabled
[ 101.624] (**) Option "config_info" "udev:/sys/devices/pnp0/00:0b/tty/ttyS4"
[ 101.624] (II) XINPUT: Adding extended input device "Serial Wacom Tablet eraser" (type: ERASER)
[ 101.625] (--) Serial Wacom Tablet eraser: top X=0 top Y=0 bottom X=26312 bottom Y=16520 resol X=100000 resol Y=100000
[ 101.625] (**) Serial Wacom Tablet eraser: (accel) keeping acceleration scheme 1
[ 101.625] (**) Serial Wacom Tablet eraser: (accel) acceleration profile 0
[ 101.625] (**) Serial Wacom Tablet eraser: (accel) acceleration factor: 2.000
[ 101.625] (**) Serial Wacom Tablet eraser: (accel) acceleration threshold: 4
[ 101.625] (**) Option "BaudRate" "38400"
[ 101.625] (**) Serial Wacom Tablet touch: Applying InputClass "Wacom serial class"
[ ...

Read more...

bugbot (bugbot) on 2011-08-28
tags: added: kubuntu
Changed in xf86-input-wacom (Ubuntu):
status: New → Confirmed
Andrew Tonks (a-p-tonks) wrote :

Seems to be a problem with inputattach on my machine at least (upgrade from a nicely tuned natty install)
If I log in to a rescue window, sudo killall -1 inputattach, then ctrl-D, X restarts with a working touchscreen.
Will try removing the udev rule containing the inputattach line, see if that works.

Then get on with trying to find out the reasons for all the other parts oneiric that are crashing... no way is this a beta release!

j-b-m (jb-kdenlive) wrote :

Oh, thanks a lot! I can confirm that killing inputattach also solves the problem for me and the touchscreen works after an X restart!

Andrew Tonks (a-p-tonks) wrote :

and yes, it looks like for the solution to survive a reboot is just comment out the (only) line of
/lib/udev/rules.d/40-inputattach.rules ...

#SUBSYSTEM=="tty", KERNEL=="ttyS[0-9]*", ATTRS{id}=="FUJ02e5|WACf00c", ACTION=="add|change", RUN+="/lib/udev/inputattach --daemon --baud 19200 --w8001 /dev/%k"

Timo Aaltonen (tjaalton) wrote :

That is weird, since the rule was added there recently to support these devices..

affects: xf86-input-wacom (Ubuntu) → inputattach (Ubuntu)
affects: inputattach (Ubuntu) → joystick (Ubuntu)
Andrew Tonks (a-p-tonks) wrote :

Timo: maybe because we are not talking about a clean install on oneiric but rather an upgrade from a system where we already had things working?

j-b-m (jb-kdenlive) wrote :

I don't think it is caused by some upgrade problem since I could reproduce the issue with an Oneiric live CD

j-b-m (jb-kdenlive) wrote :

Ok, some more infos. If I change the inputattach udev rule baud rate to 38400 (replace
"--baud 19200" with "--baud 38400", I have some more success, and my device is then recognised as a "Wacom Serial Penabled 2FG Touchscreen". It is listed in the xsetwacom command, however, trying to use the touchscreen brings the cursor on the top left corner at first touch, then I have no reaction at all using either stylus or touch.

I attached the xorg log and xsetwacom info in the file called wacom_38400.txt

j-b-m (jb-kdenlive) wrote :

... And here is the info (Xorg log and xsetwacom info) when I comment out the inputattach udev rule, and my touchscreen works fine

Stephen Kitt (steve-sk2) wrote :

Hi,

This has been reported in Debian as http://bugs.debian.org/632961 and the reporter there indicates that removing a configuration section from /usr/share/X11/xorg.conf.d/50-wacom.conf, along with the "--baud" fix, corrects things. Would you mind trying this out too? With the inputattach udev rule enabled of course...

Thanks,

Stephen

j-b-m (jb-kdenlive) wrote :

Thanks Stephen.

Yes, I confirm that splitting the inputattach udev rule like suggested in http://bugs.debian.org/632961 (baud rate of 38400 for wacom devices) AND removing the wacom id from /usr/share/X11/xorg.conf.d/50-wacom.conf (see patch below) allows my touchscreen to be correctly recognised.

There is still a small issue with random lines appearing while drawing with stylus that I have reported as: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/799202 but I think it is unrelated (caused by an Ubuntu patch to xserver-xorg-core as I explained).

Thanks again. Just to make sure, below is my change to the 50-wacom.conf file.

@@ -13,7 +13,7 @@

 Section "InputClass"
         Identifier "Wacom serial class identifiers"
- MatchProduct "FUJ02e5|FUJ02e7|FUJ02e9"
+ MatchProduct "WACf|FUJ02e5|FUJ02e7|FUJ02e9"
         Driver "wacom"
 EndSection

Changed in joystick (Debian):
status: Unknown → New
Stephen Kitt (steve-sk2) wrote :

Great, thanks for the info! That is indeed the change I intended.

Changed in joystick (Debian):
status: New → Fix Committed
Changed in joystick (Debian):
status: Fix Committed → Fix Released
Stephen Kitt (steve-sk2) on 2013-05-07
Changed in joystick (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.