Ubuntu

Jokosher in Intrepid has a broken 'Help' button

Reported by Brett Alton on 2008-10-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Jokosher
Medium
Laszlo Pandy
jokosher (Ubuntu)
Low
David Corrales

Bug Description

Binary package hint: jokosher

Jokosher 0.10 in Intrepid has a button in the menu bar called at "Help > Help" that does not work.

The error returned is:
Unable to load page
The requested URI "ghelp:jokosher" is invalid

I looked for help packages in Synaptic, but could find none.

If there is no help package, should the help button not be removed?

$ apt-cache policy linux-generic nautilus jokosher && lsb_release -a
linux-generic:
  Installed: 2.6.27.7.11
  Candidate: 2.6.27.7.11
  Version table:
 *** 2.6.27.7.11 0
        500 http://archive.ubuntu.com intrepid/restricted Packages
        100 /var/lib/dpkg/status
nautilus:
  Installed: 1:2.24.1-0ubuntu1
  Candidate: 1:2.24.1-0ubuntu1
  Version table:
 *** 1:2.24.1-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
jokosher:
  Installed: 0.10.1-0ubuntu1
  Candidate: 0.10.1-0ubuntu1
  Version table:
 *** 0.10.1-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

Related branches

Nick Ellery (nick.ellery) wrote :

Confirmed in Intrepid.

Changed in jokosher:
importance: Undecided → Low
status: New → Confirmed
status: Confirmed → Triaged
Laszlo Pandy (laszlok) wrote :

The jokosher help files are contained in the Jokosher package, so they are installed already. However they are not being properly registered with the gnome help browser.

Changed in jokosher:
status: Triaged → Confirmed
Laszlo Pandy (laszlok) on 2008-11-08
Changed in jokosher:
assignee: nobody → davidcorrales
assignee: nobody → davidcorrales
importance: Undecided → Medium
milestone: none → 0.11
status: New → Confirmed
Laszlo Pandy (laszlok) on 2009-02-27
Changed in jokosher:
assignee: davidcorrales → laszlok
milestone: 0.11 → 0.11.1
Laszlo Pandy (laszlok) wrote :

Here is the file that is needed to make help work.
This needs to be included in the deb, so that on install it is copied into the following path:
/usr/share/omf/jokosher/jokosher-C.omf

The problem is that OMF links to the GNOME help xml file, and that changes depending on if we install into /usr/ or /usr/local/ or somewhere else entirely.
However for Ubuntu, the GNOME help files are always in /usr/share/gnome/help/... so I have hardcoded the path in the attached .omf file.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jokosher - 0.11.1-0ubuntu1

---------------
jokosher (0.11.1-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #290516):
    - Implement fixed audio/x-raw-float caps to solve negotiation problems.
      (unconfirmed fix for very important bug #247977)
    - Add auto-scrolling when the playhead is dragged past the end of the
      timeline. (LP: #81810)
    - Fix mix view resizing, and add a scroll bar to the mixer strip area.
      (LP: #87790)
    - Use gettext.install() so gettext doesn't need to be imported in every
      module. (LP: #125186)
    - Fix bug where playback would fail because output device selection was
      not loaded correctly.
    - When error occurs, dump a DOT file to give details of GStreamer
      pipeline. (Will greatly help with debugging)
    - Set program name and env var for PulseAudio to display information
      about Jokosher's streamer.
    - Use grab_add() when editing BPM and allow escape key to leave the
      editing mode.
    - Remove encoding parameter from .desktop file as this is deprecated.
  * debian/install, debian/patches/01-hard-code-omf-location.dpatch: install
    fixed version of .omf file for good help pages. (LP: #290516)

 -- Daniel Holbach <email address hidden> Tue, 17 Mar 2009 15:37:15 +0100

Changed in jokosher:
status: Confirmed → Fix Released
Laszlo Pandy (laszlok) on 2009-03-19
Changed in jokosher:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers