john outputs " fopen: john.ini: No such file or directory"

Bug #1071718 reported by Vicente Jiménez Aguilar on 2012-10-26
182
This bug affects 39 people
Affects Status Importance Assigned to Milestone
john (Ubuntu)
Critical
Unassigned

Bug Description

The john program doesn't works any more.
It outputs "fopen: john.ini: No such file or directory".

How to test:
 * install john package
 * execute john
Expected output is help text
instead we get "fopen: john.ini: No such file or directory"

john worked perfectly in versions of Ubuntu before 12.10,

I found this problem in an upgraded system, so I tried to reinstall it.
The john package was also installed for the first time in another machine (the machine that executed ubuntu-bug).
Nothing of the above solves the problem.

If I copy /etc/john/john.conf to the local directory where I try to execute john this stops complaining about the file john.ini but it has problems finding other files.

It seems that the executable john doesn't use /etc/john/john.conf as its configuration file, doesn't find temporal files in ~/.john/ and installed files in /usr/share/john. It only looks for files in the current working directory.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: john 1.7.8-1build1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Date: Fri Oct 26 12:12:49 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
SourcePackage: john
UpgradeStatus: Upgraded to quantal on 2012-10-19 (6 days ago)

Vicente Jiménez Aguilar (vice) wrote :
Vicente Jiménez Aguilar (vice) wrote :

Could it be a possible problem setting the PATH for the process environment?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in john (Ubuntu):
status: New → Confirmed
humboink (humboink) wrote :

same here with a new 12.10 install after apt-get install john

Andros (andros-brz-a) wrote :

same here with the 12.10x64 install after install john

Francesco Muriana (f-muriana) wrote :

The same on Linux Mint 14 (based on Ubuntu 12.10). I tried to solve with these commands:

"cd /usr/share/john
sudo touch john.ini"

and it seems to work

Pali (pali) wrote :

Try: "cd /etc/john"

piebru (piebru) wrote :

None of the above solutions worked for me in 12.10
Ths works, but it is not a solution:
$ cd /etc/john
$ john

Neither workaround worked for me.
The one recommended by Francesco Muriana results in: No "single crack" mode rules found in john.ini
Pali: open: john.log: Permission denied
Pali - with sudo: fopen: password.lst: No such file or directory

I would also add that using 10.04 LTS is not a workaround either, because the John version included in it does not know its passwd hash format.

reagle (joseph.reagle) wrote :

Still present in 13.04 .

Any chance this might get fixed sometime this century? Like nmap, this tool is a required part of any security professional's toolbox.

 I don't use Ubuntu. I maintain the package in Debian.AFAIK the package is
still working in Debian. A couple of months ago I prepared a package for
v1.8.0 just in case someone want to try it and check if this solves the
problem in Ubuntu.
And here is it: http://mentors.debian.net/package/john
Ruben

tags: added: broken bug install-package john
Henry Barker (orionsbelt152) wrote :

What worked for me in 13.04 is, in my home directory:

ln -s /etc/john/john.conf john.ini

Tobiasz Jarczyk (dotnokato-q) wrote :

I got this in saucy.

Dalmer Vieira (dalmer-vieira) wrote :

After doing what Henry Barker (orionsbelt152) suggested, worked for me in Saucy!

In home directory, execute:

ln -s /etc/john/john.conf john.ini

tags: added: saucy
Changed in john (Ubuntu):
importance: Undecided → Critical
Allan M. de Azevedo (4llan) wrote :

Even if I manually create ~/john.ini (ln -s /etc/john/john.conf john.ini) john won't work as usual.

This occurs because var $JOHN is not defined. (echo $JOHN) should be "/usr/share/john/", and it's used in john.conf (cat /etc/john/john.conf | grep \$JOHN)

Phillip Pether (roofox) wrote :

running

$ touch john

worked for me

why Ubuntu version are you using ?

sorry...
WHICH Ubuntu version are yoou using

I tried to reproduce the error and found out that with the new package of john the issue doesn't occur anymore. Because of this I marked this bug as invalid.

Changed in john (Ubuntu):
status: Confirmed → Invalid

Sorry, I meant fix released

Changed in john (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers