Jockey doesn't provide fglrx-updates

Bug #855396 reported by Alberto Milone on 2011-09-21
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
High
Alberto Milone
jockey (Ubuntu)
High
Martin Pitt
nvidia-graphics-drivers-173-updates (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-96-updates (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-updates (Ubuntu)
High
Alberto Milone

Bug Description

Jockey only seems to make fglrx available while ignoring fglrx-updates. The two drivers have the same modaliases therefore there has to be a bug in either the fglrx handler or in some other part of Jockey.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: jockey-common 0.9.4-0ubuntu6 [modified: usr/share/jockey/handlers/fglrx.py]
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.var.log.jockey.log:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Wed Sep 21 11:37:36 2011
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=774ca6f1-bcee-40f5-a9b8-620e9cf299bb ro quiet splash vt.handoff=7
SourcePackage: jockey
UpgradeStatus: Upgraded to oneiric on 2011-09-20 (1 days ago)
dmi.bios.date: 01/19/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0106
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P6T SE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0106:bd01/19/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP6TSE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Alberto Milone (albertomilone) wrote :
Changed in jockey (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-11.10-beta-2
Alberto Milone (albertomilone) wrote :
Alberto Milone (albertomilone) wrote :

The attached patch seems to improve things in the log but fglrx-updates still doesn't show up in Jockey

Alberto Milone (albertomilone) wrote :
Martin Pitt (pitti) wrote :

You just committed that patch yourself, which fixes the jockey part.

Changed in jockey (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
assignee: nobody → Martin Pitt (pitti)
status: Triaged → Fix Committed
assignee: Martin Pitt (pitti) → Alberto Milone (albertomilone)
Martin Pitt (pitti) wrote :

The actual reason is that the fglrx-updates package does not have any "Modalias:" lines right now, so it won't match on any system. Given the package size it's definitively not just an empty stub. So this needs to be fixed there, adding a task for it.

The attachment "temp_fix.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.4-0ubuntu7

---------------
jockey (0.9.4-0ubuntu7) oneiric; urgency=low

  [ Alberto Milone ]
  * data/handlers/fglrx.py: Use the correct name for the module and for the
    package in fglrx.py. (LP: #855396)

  [ Martin Pitt ]
  * jockey/oslib.py, package_header_modaliases(): Only consider packages for
    the system architecture. This avoids creating non-working default handlers
    for e. g. fglrx:i386 on an amd64 system. (LP: #855175)
  * Drop data/handlers/nouveau3d.py, it's installed by default now.
    (LP: #839533)
 -- Martin Pitt <email address hidden> Wed, 21 Sep 2011 12:51:55 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Changed in fglrx-installer-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → In Progress
milestone: none → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:8.881-0ubuntu4

---------------
fglrx-installer-updates (2:8.881-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure to install the correct modaliases file so that
      the driver can be detected by Jockey (LP: #855396).
 -- Alberto Milone <email address hidden> Fri, 23 Sep 2011 13:28:49 +0200

Changed in fglrx-installer-updates (Ubuntu):
status: In Progress → Fix Released
Alberto Milone (albertomilone) wrote :

It looks like the bug isn't fixed yet:

:~$ jockey-text -l
kmod:fglrx - Video driver for the AMD graphics accelerators (Proprietary, Disabled, Not in use)
xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Disabled, Not in use)

This is with jockey - 0.9.4-0ubuntu7 and fglrx-installer-updates has the modaliases now.

See the attached log

Changed in jockey (Ubuntu):
status: Fix Released → Triaged
Martin Pitt (pitti) on 2011-09-26
Changed in jockey (Ubuntu):
assignee: Alberto Milone (albertomilone) → Martin Pitt (pitti)
Martin Pitt (pitti) on 2011-09-27
Changed in jockey (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

The problem is that the -updates packages have a wrong Modalias: line:

Package: fglrx-updates
Modaliases: fglrx(pci:v0000...)

The module name should be "fglrx_updates", or "nvidia_current_updates", etc.

Changed in fglrx-installer-updates (Ubuntu):
status: Fix Released → Triaged
Changed in jockey (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96-updates - 96.43.20-0ubuntu4

---------------
nvidia-graphics-drivers-96-updates (96.43.20-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 11:01:45 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-173-updates - 173.14.30-0ubuntu4

---------------
nvidia-graphics-drivers-173-updates (173.14.30-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 10:12:49 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-updates - 280.13-0ubuntu4

---------------
nvidia-graphics-drivers-updates (280.13-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
    - Make it possible to add card ids to the modaliases by
      adding ids in debian/additional_card_ids.
  * debian/additional_card_ids:
    - Add support for card id 0dfc.
  * debian/nvidia-$flavour.README.Debian.in:
    - Document how to use the additional_card_ids file.
 -- Alberto Milone <email address hidden> Thu, 29 Sep 2011 17:39:14 +0200

Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:8.881-0ubuntu5

---------------
fglrx-installer-updates (2:8.881-0ubuntu5) oneiric; urgency=low

  * debian/rules, debian/modaliases/fglrx_supported:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all AMD cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 15:36:28 +0200

Changed in fglrx-installer-updates (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-updates (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers