jockey-backend crashed with MemoryError in run_dbus_service()

Bug #836599 reported by Łukasz Daniel on 2011-08-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

Error occurred when I double clicked on additional drivers in System settings.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: jockey-common 0.9.4-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
.var.log.jockey.log:

Architecture: amd64
Date: Mon Aug 29 13:20:44 2011
ExecutablePath: /usr/share/jockey/jockey-backend
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
MachineType: innotek GmbH VirtualBox
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/jockey/jockey-backend --debug -l /var/log/jockey.log
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic root=UUID=b9c7fd56-35cd-4e8d-b7a5-5afa98521527 ro quiet splash vt.handoff=7
PythonArgs: ['/usr/share/jockey/jockey-backend', '--debug', '-l', '/var/log/jockey.log']
SourcePackage: jockey
Title: jockey-backend crashed with MemoryError in run_dbus_service()
UpgradeStatus: Upgraded to oneiric on 2011-07-29 (31 days ago)
UserGroups:

dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Łukasz Daniel (lukasz-daniel) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #831754, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.4-0ubuntu3

---------------
jockey (0.9.4-0ubuntu3) oneiric; urgency=low

  * jockey/ui.py, jockey/backend.py: Use MainLoop from GObject, not from GLib.
    Using GLib is broken for pygobject 2.28. This can be reverted once
    pygobject gets upgraded to 2.90. (LP: #836599)
 -- Martin Pitt <email address hidden> Tue, 30 Aug 2011 07:40:39 +0200

Changed in jockey (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers