Does not give useful error messages about package installation failures

Bug #804709 reported by Blümchen Blau on 2011-07-02
874
This bug affects 138 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Medium
Martin Pitt
Oneiric
Medium
Martin Pitt

Bug Description

Sorry too many recent crashes to give details that are surely connected to the report.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: jockey-common 0.9.2-0ubuntu7
ProcVersionSignature: Ubuntu 3.0-2.3-generic-pae 3.0.0-rc4
Uname: Linux 3.0-2-generic-pae i686
Architecture: i386
Date: Sat Jul 2 02:26:19 2011
ExecutablePath: /usr/share/jockey/jockey-backend
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110531.1)
InterpreterPath: /usr/bin/python2.7
MachineType: LENOVO 0221A16
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/jockey/jockey-backend --debug -l /var/log/jockey.log
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0-2-generic-pae root=UUID=84e4eaea-31dd-4101-b810-a878bb24cc7c ro quiet splash vt.handoff=7
PythonArgs: ['/usr/share/jockey/jockey-backend', '--debug', '-l', '/var/log/jockey.log']
SourcePackage: jockey
Title: jockey-backend crashed with SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Traceback: SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 05/05/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 85ET39WW (1.12 )
dmi.board.name: 0221A16
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr85ET39WW(1.12):bd05/05/2011:svnLENOVO:pn0221A16:pvrThinkPadEdge:rvnLENOVO:rn0221A16:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 0221A16
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO

Blümchen Blau (bluemchen-blau) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
visibility: private → public
Brian Murray (brian-murray) wrote :

From the jockey log we see:

011-07-02 02:05:23,182 DEBUG: Could not instantiate Handler subclass __builtin__.NvidiaDriverBase from name NvidiaDriverBase
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/jockey/detection.py", line 947, in get_handlers
    inst = obj(backend)
TypeError: __init__() takes exactly 3 arguments (2 given)
2011-07-02 02:05:23,193 WARNING: modinfo for module nvidia_173 failed: ERROR: modinfo: could not find module nvidia_173

tags: added: bugpattern-written
removed: bugpattern-needed
Changed in jockey (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in jockey (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

It seems installing fglrx fails, but unfortunately the jockey log doesn't have the package error message. Can you please do

  sudo apt-get install fglrx

and copy&paste the entire output there?

@canonical-desktop-team: will be on holiday next week, so please reassign to fglrx/Alberto/Bryce/etc. as appropriate.

Changed in jockey (Ubuntu Oneiric):
status: Triaged → Incomplete

Nao concigo instalar no meu hd.

e Támbem da erro de entrada não suportada e depois de um 35 sedundos aparece o desktop.

francys_ricardo@hotmail

Martin Pitt (pitti) wrote :

No answer to my question in comment 3 for about a month. This bug (and its duplicates) are due to bugs in the fglrx package, but for the jockey tasks I'll see to making the error message more obvious.

Changed in jockey (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
importance: High → Medium
status: Incomplete → In Progress
Martin Pitt (pitti) on 2011-08-18
Changed in jockey (Ubuntu Oneiric):
status: In Progress → Fix Committed

Since, I think, at least daily build 14/8 I have been able to install
fglrx by use of Additional Drivers. However fglrx is not working with
the Ubuntu login due to Bug #819144. Fglrx is working with Gnome and
Unity 2D login.

tor 2011-08-18 klockan 09:50 +0000 skrev Martin Pitt:
> No answer to my question in comment 3 for about a month. This bug (and
> its duplicates) are due to bugs in the fglrx package, but for the jockey
> tasks I'll see to making the error message more obvious.
>
> ** Changed in: jockey (Ubuntu Oneiric)
> Assignee: Canonical Desktop Team (canonical-desktop-team) => Martin Pitt (pitti)
>
> ** Changed in: jockey (Ubuntu Oneiric)
> Importance: High => Medium
>
> ** Changed in: jockey (Ubuntu Oneiric)
> Status: Incomplete => In Progress
>

This bug was fixed in the package jockey - 0.9.4-0ubuntu1

---------------
jockey (0.9.4-0ubuntu1) oneiric; urgency=low

  * New upstream bug fix release:
    - oslib.py: Do not encourage to report package installation failure as
      SystemError, it will appear as a backend crash
    - jockey-gtk: Fix message_type argument to Gtk.MessageBox constructor
    - jockey/ui.py: For invalid combinations of LC_MESSAGES and LC_CTYPE, force
      stdout/stderr encoding to UTF-8 instead of C. (LP: #760883)
    - Fix GLib and GObject imports to be compatible with the future pygobject
      3.0. (LP: #829186)
    - jockey/detection.py, _driverid_to_handler(): In the case that there are
      multiple matching custom handlers for a DriverID, also check that their
      "package" attribute matches.
    - tests/run: Also support specifying individual test method names
  * Add debian/testpkgs/: Scripts and equivs control files for dummy
    driver packages which are convenient for testing.
  * debian/rules: Call debian/testpkgs/clean to ensure that we don't ship
    build stuff there.
  * data/handlers/{fglrx,nvidia}.py: Prevent crash if
    get_alternative_by_name() returns nothing.
  * jockey/oslib.py, {install,remove}_package(): Capture apt's stdout/err into
    the log file, to get proper error messages when packages fail to install.
    (LP: #552300).
  * jockey/oslib.py, install_package(): Avoid raising a SystemError when a
    package fails to install in apt, as this will appear as a crash in Jockey.
    Just point out the error in the log file instead. (LP: #804709)
  * tests/oslib.py: Update test cases for above change.
  * tests/oslib.py: Fix apt initialization to work with current apt versions.
  * data/handlers/{fglrx,nvidia}.py: Also show the -updates variants of the
    drivers, which will be updated to newer upstream versions after the
    Ubuntu release. (UbuntuSpec:desktop-o-xorg-stakeholders-request)
 -- Martin Pitt <email address hidden> Mon, 22 Aug 2011 12:08:02 +0200

Changed in jockey (Ubuntu Oneiric):
status: Fix Committed → Fix Released
tags: added: iso-testing

Bug exists for me, too. Fresh beta1-iso install, fully up to date. Error message is:
SystemError: E:Unable to correct problems, you have held broken packages.

First i wanted to comment on https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/720343?comments=all , but it's marked as a duplicate of this one here.

Stephen Gava (elguavas.) wrote :

This bug still exists.

ubuntu 11.10 oneric, x86-64, beta 1 fully updated as of 2011-09-13. jockey-common version 0.9.4-0ubuntu6. fglrx version 2:8.881-0ubuntu2.

As above, and as pointed out in bug #819365 , which I believe has been incorrectly marked as a duplicate of this one, jockey identifies the fglrx kmod driver as available, but attemting to enable it returns the error:

SystemError: E:Unable to correct problems, you have held broken packages.

so, either this is a different bug (which is what is supect) or the fix released above did not actually fix the problem.

So please either re-open this bark and mark it important, or make bug #819365 _not_ a duplicate of this one and move my report there.

Please let me know if any additional information will help,
cheers,
Stephen.

Martin Pitt (pitti) wrote :

Stephen, this is still not a jockey bug. Your bug 819365 shows that you have broken packages and thus fglrx cannot be installed. The current jockey version provides a proper error message in the jockey log file, but your report does not have that yet.

You can try

  sudo apt-get install fglrx

and see what it is complaining about, that might already give you a clue. If not, please file a new bug against "fglrx-installer" with the output of apt-get.

Thanks!

Stephen Gava (elguavas.) wrote :

Martin, thanks for your response. However, it is not so simple. ;)

Bug #819365 is not my bug, but I found it first because of the error message. If you look at the final entry on bug #81936, which is still incorrectly marked as a duplicate of this one, you will see that the the same error is still occuring, but for the Nvidia drivers, as well as the Fglrx drivers that I am repoting for.

As the problem occurs for the nvidia, as well as the fglrx, drivers, it can't be a problem with fglrx-installer...

Also, sudo apt-get install fglrx works without any problems on my system, but in jockey, the driver is till marked only as "available" and trying to "enable" it there shows the error i originally reported. Also "dpkg --audit" shows no erros for the packages on my system. So, again, jockey is showing an error about holding broken packages where that doesn not seem to be true, and jockey can't be used to "enable" the driver.

With the incorrectly marked as duplicate bug 819365, and the situation I describe above, and scattered over several other bugs that can be searched in the bts here, there is obvioulsy some serious problem in the interaction between jockey and the proprietatry graphic drivers, both nvidia and fglrx, that is still present, at least on the x64 architecture I am reporting for.

So, I can go ahead and file a report on flgrx-installer, but they'll just say it isn't their problem, so this serious bug that has been reported in several ways now will just fall through the cracks in your system and be released in 11.10.

If there is some way I can help you to prevent that from happening, please let me know, but it doubt that going through all this again on fglrx-installer is the solution.

Cheers,
Stephen.

Stephen Gava (elguavas.) wrote :

Martin, sorry, typo in third line above where i say look at "bug #81936" i obviously meant "bug #819365", sorry.

Stephen.

Martin Pitt (pitti) wrote :

It might be incorrectly marked, but it is still not an useful bug report as the jockey version used there was too old for an useful error message. So even if we would undupe 819365 and assign it to fglrx-installer, a developer could not do anything about it. If this happens again, we need a _new_ bug report with the jockey log or the packaging error. So if you can still reproduce the error, can you please do so, and then do "ubuntu-bug jockey-gtk", report it, and let me know the number? That will automatically attach the current log.

Thanks!

summary: - jockey-backend crashed with SystemError: E:Sub-process /usr/bin/dpkg
- returned an error code (1)
+ Does not give useful error messages about package installation failures
Stephen Gava (elguavas.) wrote :

ok, martin, as requested new Bug #855175 reported with updated info for the current state of things.

cheers.

jeff E (thenessus) wrote :

happens to me when trying to install Broadcom STA driver. daily build, 22 of September.

Paul Leger (pleger) wrote :

Hi,
    I have installed the final version of ubuntu 11.10 and cannot install the STA and Nvidia drivers. I have attached the jockey log.

Martin Pitt (pitti) wrote :

Paul, this log shows that it found the nvidia and bcmwl drivers, but it does not show an actual installation attempt. What happens exactly?

On 10/17/2011 03:37 AM, Martin Pitt wrote:
> Paul, this log shows that it found the nvidia and bcmwl drivers, but it
> does not show an actual installation attempt. What happens exactly?
>
When I try installing/activating the drivers, I get:

"Sorry, instalation of this driver failed. Please have a look at the log
file for details: /var/log/jockey.log"

In this web page, I found a solution for nvidia drivers.
http://ubuntuforums.org/showthread.php?t=1859159

Thank you!

Martin Pitt (pitti) wrote :

Paul,

then it seems the /var/log/jockey.log you attached is not from a run where you attempted to install. Can you please open Jockey, try to install a driver, check that it still displays an error, then close it, and attach /var/log/jockey.log again? Thanks!

meanpt (meanpt) wrote :

Crash occurred when tried to install the fglrs post-release's updates driver, after installing the non post-release's fgrlx driver.'

norberto (netcaster) wrote :

same situation as meanpt #22

Robert Avant (robertj-avant) wrote :

Bug became apparent when trying to change from non recommended NVIDIA driver to recommended NVIDIA driver.

André Lopes (zipatei) wrote :

same situation as meanpt #22

Yuri Glushaev (y-glushaev) wrote :

Crash occurs on startup after NVIDIA recommended driver installation.

Paul Leger (pleger) wrote :

On 03/27/2012 11:42 AM, Yuri Glushaev wrote:
> Crash occurs on startup after NVIDIA recommended driver installation.
>
In a fresh installation?

Did you update the system before you tried to install?

Now, I have fresh and updated installation, and I can install the NVIDIA
recommend driver without any issue.

--
Saludos, Paul Leger.

hola estoy metiendo los drivers nvidia para unity3d

Lars Düsing (lars.duesing) wrote :

mauro, would you be please so kind, and write english here?

Paul Leger (pleger) wrote :

On 04/14/2012 05:34 AM, Lars Düsing wrote:
> mauro, would you be please so kind, and write english here?
>
I think Mauro tried replying to me only (I speak Spanish). Anyways, he
wanted to say:
" I am inserting the nvidia drivers in Unity 3d" (very similar to
Spanish :) )

--
Saludos, Paul Leger.

Darryl Baker (g-dpb-t) wrote :

I am getting the same issue installing the ATI/AMD drivers. If that is any help.

Swami Pandit (soami-prakash) wrote :

Hello Martin,

I am new to Ubuntu, reason to switch to linux was related to network security for me. I wonder if you can help me with fixing the bug. Thank you advance.

swami

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers