Unable to install Broadcom drivers from live session

Bug #712554 reported by Scott Kitterman on 2011-02-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Medium
Martin Pitt
Natty
Medium
Martin Pitt

Bug Description

On a Dell Mini 10v (Broadcom wireless) jockey can't install drivers. Only sta is offered and IIRC it's not the right one. Trying to install results in a jockey crash.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: jockey-kde 0.8-0ubuntu6
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Thu Feb 3 10:49:10 2011
LiveMediaBuild: Kubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: Dell Inc. Inspiron 1011
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/khostname.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --
SourcePackage: jockey
dmi.bios.date: 03/20/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: CN0Y53
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A00
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd03/20/2009:svnDellInc.:pnInspiron1011:pvrA00:rvnDellInc.:rnCN0Y53:rvrA00:cvnDellInc.:ct8:cvrA00:
dmi.product.name: Inspiron 1011
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.

Scott Kitterman (kitterman) wrote :
tags: added: iso-testing
Scott Kitterman (kitterman) wrote :

Confirmed that bcmwl-kernel-source is still shipped and should have been detected. Manually installing bcmwl-kernel-source post-install works fine.

tags: added: regression-natty
tags: added: regression-release
removed: regression-natty
Changed in jockey (Ubuntu Natty):
importance: Undecided → High
milestone: none → natty-alpha-3
Brian Murray (brian-murray) wrote :

From .var.log.jockey.log.txt:

2011-02-03 15:05:48,002 DEBUG: Could not instantiate Handler subclass __builtin__.DvbUsbFirmwareHandler from name DvbUsbFirmwareHandler
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/jockey/detection.py", line 977, in get_handlers
    desc = inst.name()
  File "/usr/lib/python2.7/dist-packages/jockey/handlers.py", line 102, in name
    self._package_defaults()
  File "/usr/lib/python2.7/dist-packages/jockey/handlers.py", line 87, in _package_defaults
    (distro_name, distro_desc) = OSLib.inst.package_description(self.package)
  File "/usr/lib/python2.7/dist-packages/jockey/oslib.py", line 189, in package_description
    raise ValueError, 'package %s does not exist' % package
ValueError: package linux-firmware-nonfree does not exist
2011-02-03 15:05:48,012 DEBUG: loading custom handler /usr/share/jockey/handlers/fglrx.py

Michael Vogt (mvo) on 2011-02-25
Changed in jockey (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Do you happen to have some more details how jockey crashes? The attached log looks fine, it goes all the way to

2011-02-03 15:06:55,278 DEBUG: install progress initramfs-tools 0.000000
2011-02-03 15:06:55,330 DEBUG: install progress bcmwl-kernel-source 0.000000
2011-02-03 15:09:32,190 DEBUG: Shutting down

(There are a few exceptions about unavailable packages such as linux-firmware-nonfree; that's okay, they aren't available in the live system as they are in multiverse).

After this, was the bcmwl-kernel-source package actualy installed? What does dpkg -s bcmwl-kernel-source say?

(For the record, I installed alpha-2 on a Dell Mini 10 with broadcom wifi, and Ubiquity installed it just fine)

Changed in jockey (Ubuntu Natty):
assignee: Martin Pitt (pitti) → nobody
status: New → Incomplete
Martin Pitt (pitti) wrote :

Not an alpha-3 release blocker.

Changed in jockey (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
importance: High → Medium
milestone: natty-alpha-3 → none
Martin Pitt (pitti) wrote :

Is there any chance that this was due to bug 711225 (which was fixed this morning)? It'd be great if you could re-test with the current beta-1 candidate images.

Scott Kitterman (kitterman) wrote :

I'll try it again after we have new Kubuntu images.

Scott Kitterman (kitterman) wrote :

Works fine now.

Changed in jockey (Ubuntu Natty):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers