jockey-gtk crashed with BackendCrashError in convert_dbus_exceptions()

Bug #645922 reported by Michael Vogt on 2010-09-23
430
This bug affects 60 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Medium
Martin Pitt

Bug Description

Just got this error during a testinstall of todays maverick daily via usb/usb-creator.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: jockey-gtk 0.5.10-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Thu Sep 23 10:45:19 2010
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100922)
MachineType: LENOVO 3626W15
PackageArchitecture: all
ProcCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- console-setup/layoutcode=de
ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk --check
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/jockey-gtk', '--check']
SourcePackage: jockey
Title: jockey-gtk crashed with BackendCrashError in convert_dbus_exceptions()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 06/07/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET46WW (1.16 )
dmi.board.name: 3626W15
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET46WW(1.16):bd06/07/2010:svnLENOVO:pn3626W15:pvrThinkPadX201:rvnLENOVO:rn3626W15:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3626W15
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO

Michael Vogt (mvo) wrote :
tags: removed: need-duplicate-check
tags: added: iso-testing
Kamus (kamus) wrote :

same here, after forward to second step of installation apport display that jockey-gtk crashed.

tags: added: bugpattern-needed
visibility: private → public
Changed in jockey (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Boy Herre (boy) wrote :

whilst trying to install Ubuntu 10.10 from Live-CD.

while trying to install from live cd, from a cd to usb drive even after alternating the setup of live cd on usb, the same bug appears.
it just hangs at second screen of installation before the choice of partition comes.

Received crash error trying to install 11.04 Natty with live USB

Jean-Baptiste Lallement (jibel) wrote :

confirmed by duplicates and users are still hit by this in Oneiric.

Changed in jockey (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

This was most probably fixed in

jockey (0.9.4-0ubuntu1) oneiric; urgency=low

  * New upstream bug fix release:
    - oslib.py: Do not encourage to report package installation failure as
      SystemError, it will appear as a backend crash
  [...]
  * jockey/oslib.py, {install,remove}_package(): Capture apt's stdout/err into
    the log file, to get proper error messages when packages fail to install.
    (LP: #552300).

The newest duplicate (bug 829729) still has version 0.9.3.

This crash would happen if a package failed to install, which is usually not a problem in jockey itself. However, to see what actually happened, we need the jockey log from a version >= 0.9.4 (due to above fix of actually logging the package installation failure).

So I am closing this, as jockey 0.9.4 now tells the user when a package failed to install, instead of just crashing. The log file will tell what really happened.

Changed in jockey (Ubuntu):
status: Confirmed → Fix Released
John M.K. (jconni) wrote :

Just got this error while choosing "install ubuntu"... I was testing Precice 12.04 from ubuntu-daily-live...

Paolo Sammicheli (xdatap1) wrote :

Same here, testing Precise from Daily Live 20120201

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/645922

To post a comment you must log in.