"Remove" button next to "You need to restart the computer..."

Bug #600804 reported by tadfisher@gmail.com on 2010-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Bilal Akhtar
jockey (Ubuntu)
Low
Bilal Akhtar

Bug Description

jockey-gtk 0.5.8-0ubuntu8.1, Ubuntu 10.04 LTS
jockey-gtk 0.5.9-0ubuntu2, Ubuntu Maverick alpha 3

After activating a restricted driver, the line "You need to restart the computer to activate this driver." appears at the bottom of the window. Immediately to the right, the button "Remove" appears. This is somewhat confusing for fast readers, who assume the button starting with "Re" will do what the notification line says, which is to restart the system. Moreover, after clicking the "Remove" button, the "Cancel" button in the "Removing driver..." progress dialog does not respond, which exacerbates my frustration.

Related branches

Changed in jockey (Ubuntu):
status: New → Confirmed
description: updated
Changed in hundredpapercuts:
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: New → In Progress
Changed in jockey (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
importance: Undecided → Low
status: Confirmed → In Progress
Changed in hundredpapercuts:
importance: Undecided → Low
Vish (vish) wrote :

When the "Restart ..." is present, we should not have the "Remove" button. It should be present only after a reboot.

Changed in hundredpapercuts:
assignee: Bilal Akhtar (bilalakhtar) → nobody
status: In Progress → Triaged
Changed in hundredpapercuts:
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
milestone: none → maverick-round-4-potpourri
milestone: maverick-round-4-potpourri → maverick-round-8-potpourri
Martin Pitt (pitti) wrote :

I find that somewhat debatable, and confusing as well, but since it has the blessing of two design people, so be it :)

Martin Pitt (pitti) wrote :

Merged and also updated ot apply to KDE in trunk r638. Thanks Bilal!

Changed in jockey (Ubuntu):
status: In Progress → Fix Committed
Vish (vish) on 2010-08-24
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.10-0ubuntu1

---------------
jockey (0.5.10-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - ui --list: show auto-install flag
    - Add flag file based auto install mode
    - Add a title to the "search drivers" dialog. Thanks to Bilal Akhtar!
      (LP: #616569)
    - Rename "Hardware Drivers" to "Additional Drivers", to point out that
      Jockey is not responsible for all kinds of drivers. Thanks to Robert
      Roth for the initial patch. (LP: #409338)
    - Hide "Remove" button if a driver needs reboot. Thanks to Bilal Akhtar
      for the initial patch! (LP: #600804)
  * debian/control: Add missing ${misc:Depends}.
  * debian/control: No need to build-depend on python-dev.
  * debian/control: Fix nvidia-common dependency.
  * Add debian/source/format: "1.0", since changes are bzr maintained.
  * debian/control: Bump Standards-Version to 3.9.1.
 -- Martin Pitt <email address hidden> Tue, 24 Aug 2010 20:05:24 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-08-24
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers