[Lucid] Upgrade from Karmic broke nVidia installation on cdrom only upgrade (without network)

Bug #568041 reported by Fido on 2010-04-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

In order to perform the upgrade test of the XOrg Team[1].
I made a clean installation of Karmic, load the proprietary drivers and then upgraded using today's daily build of Lucid Alternate CD. After rebooting the proprietary driver was no longer installed (steps 11 and forward of the test case).

Some notes:
* Nouveau started without any issue, and no error messages where displayed after reboot.
* I encounter bug #562328 after rebooting (with no error message, jockey-gtk just won't start).
* Up until two weeks ago the outcome of the upgrade was just as the test case stated

[1]http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Upgrade%20Testing

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: jockey-gtk 0.5.8-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
CurrentDmesg:
 [ 21.265613] ppdev: user-space parallel port driver
 [ 23.247424] [drm] nouveau 0000:01:00.0: Allocating FIFO number 1
 [ 23.249797] [drm] nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 1
 [ 27.368014] eth0: no IPv6 routers present
Date: Wed Apr 21 16:12:29 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: MICRO-STAR INTERNATIONAL CO., LTD MS-7142
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=5a1e5ced-6c9d-4e0d-a737-8519f7065601 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: jockey
dmi.bios.date: 06/27/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MS-7142
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: 1.00
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd06/27/2006:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7142:pvr1.00:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7142:rvr1.00:cvn:ct3:cvr:
dmi.product.name: MS-7142
dmi.product.version: 1.00
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD

Fido (fedevera) wrote :
Fido (fedevera) wrote :

This might be useful

Fido (fedevera) wrote :

Just one last comment the failed test was xpr-007, no xpr-008 just to avoid the confusion, this is not a duplicate of bug #522328

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Can you please attach the files in /var/log/dist-upgrade/* to this bugreport?

Changed in jockey (Ubuntu):
status: New → Incomplete
Fido (fedevera) wrote :

I was unable to pack 'apt-term.log' (some permissions issue...), hope the other ones help.

Michael Vogt (mvo) wrote :

So it appears that apt remove it because of the conflict against xserver-xorg-video-5:

from apt.log:
Package xserver-xorg-core has broken Conflicts on xserver-xorg-video-5
...
  Considering nvidia-glx-185 0 as a solution to xserver-xorg-core 79
  Added nvidia-glx-185 to the remove list
...

I try to re-create the environment to figure out more about it.

Michael Vogt (mvo) wrote :

From main.log:

2010-04-22 11:32:12,379 DEBUG doUpdate() will not use the network because self.useNetwork==false

This explains why nvidia got removed, the transitional packages are not on the CD (I would bet, haven't verified) and so it does not know how to upgrade the to nvidia-current.

summary: - [Lucid] Upgrade from Karmic broke nVidia installation
+ [Lucid] Upgrade from Karmic broke nVidia installation on cdrom only
+ upgrade (without network)
Michael Vogt (mvo) wrote :

When I tried to reproduce the upgrade with network it worked and upgraded to nvidia-current.

Michael Vogt (mvo) wrote :

The only thing we can do is to warn users in this case, if that is desirable I can add code for this in update-manager.

Changed in jockey (Ubuntu):
status: Incomplete → Won't Fix
Fido (fedevera) wrote :

It might be a good idea to warn the users about this, after all nouveau kicks in and everything works fine, but one might expect the proprietary driver working.

What does seem weired (to me) is that all the other times that I upgraded using the alternate cd, connected to the internet (I need to do this because there are two upgrade tests and I have a slow inet connection[1]), the proprietary driver was perfectly loaded.

[1] just to clarify, this is my upgrade "mantra":
zsync the latest alternate daily built
burn it
install karmic -> upgrade karmic
perform the upgrade test1 (connected to the internet)
install karmic -> upgrade karmic
perform the upgrade test2 (connected to the internet)
use burned cd as a frisbee

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers