Ubuntu

[Lucid] Jockey gives message that it failed to install nvidia hardware driver

Reported by Charlie Kravetz on 2010-03-31
276
This bug affects 49 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Medium
Alberto Milone

Bug Description

Video driver testing; jockey fails to install nvidia driver. Message given is "see jockey log file."
This is a new failure using the lucid-desktop-i386.iso dated 2010-03-31 to install Ubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: jockey-gtk 0.5.8-0ubuntu6
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
Architecture: i386
Date: Wed Mar 31 10:25:48 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100331)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-18-generic root=UUID=5cac8118-7d43-4444-83c8-fbab89f79078 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: jockey
dmi.bios.date: 12/20/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1008.008
dmi.board.name: P4S8X-MX
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1008.008:bd12/20/2005:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP4S8X-MX:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Alberto Milone (albertomilone) wrote :

The installation went well however this warning is incorrectly reported as an error:

2010-03-31 10:20:30,333 ERROR: update-alternatives: warning: skip creation of /usr/lib32/vdpau/libvdpau_nvidia.so.1 because associated file /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so.1 (of link group gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/lib32/libvdpau_nvidia.so because associated file /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so (of link group gl_conf) doesn't exist.

Changed in jockey (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)

Thank you for checking this. You are correct, the installation does appear to have gone okay. I rebooted the system and completed video testing using this installation.

Gunnar Árni Hinriksson (gurki) wrote :

I got the same and after reboot I get an message stating that Ubuntu is running in low-graphics mode.
NVIDIA: Failed to load the NVIDIA kernel module. Please check your system's kernel log for additional error messages. Failed to load module "nvidia"

Gunnar Árni Hinriksson (gurki) wrote :

By blacklisting the nouveau driver I got rid of the problem, and got one ugly loading screen when booting ubuntu.
Seems that you can't remove the nouveau driver using the synaptic package manager and have to blacklist it instead.

superlex (e-lex) wrote :

Only installing nvidia*.run script downloaded from nvidia.it nvidia module is loaded.

I have blacklested uvcvideo, but when I install nvidia driver I obtain

configuration of initramfs-tools (0.92bubuntu71)...
update-initramfs: deferring update (trigger activated)
lzma: Encoder error: -2147467259
dpkg: error processing initramfs-tools (--configure):
sub-process script of post-installation returned an error code (1)
configuration of nvidia-current (195.36.15-0ubuntu1)...
update-initramfs: deferring update (trigger activated)
lzma: Encoder error: -2147467259
dpkg: error processing nvidia-current (--configure):
 sub-process script of post-installation returned an error code (1)
Error processing:
 initramfs-tools
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)

superlex (e-lex) wrote :

Sorry, of course, I should say that I have blacklisted nouveau, not uvcvideo.

Paolo Sammicheli (xdatap1) wrote :

Confirmed on XOrg ISO Tests week8.

Happy Easter, btw :)

Alberto Milone (albertomilone) wrote :

@Gunnar, Paolo
can you attach the output of the following commands, please?
1) update-alternatives --display gl_conf
2) ldconfig -p | grep GL
3) ls -l /etc/alternatives/nvidia_modconf

also, can you see if this command (followed by a reboot) solves the problem, please?
sudo update-initramfs -u

@superlex
Running the script from Nvidia's website is not supported and can break your system. No wonder the nvidia package can't be installed cleanly any more.

Paolo Sammicheli (xdatap1) wrote :

Command's output is in Italian, sorry (fortunatly Alberto will understand :D )

1) x@serverona:~$ update-alternatives --display gl_conf
gl_conf - modalità manuale
 il collegamento attualmente punta a /usr/lib/nvidia-current/ld.so.conf
/usr/lib/mesa/ld.so.conf - priorità 500
 slave xorg_extra_modules: /usr/lib/xorg/x11-extra-modules
/usr/lib/nvidia-current/ld.so.conf - priorità 9700
 slave libvdpau_nvidia.so: /usr/lib/nvidia-current/vdpau/libvdpau_nvidia.so
 slave libvdpau_nvidia.so.1: /usr/lib/nvidia-current/vdpau/libvdpau_nvidia.so.1
 slave libvdpau_nvidia.so.1_lib32: /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so.1
 slave libvdpau_nvidia.so_lib32: /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so
 slave man_nvidiaxconfig.gz: /usr/share/man/man1/alt-nvidia-current-xconfig.1.gz
 slave nvidia-autostart.desktop: /usr/share/nvidia-current/nvidia-autostart.desktop
 slave nvidia-smi.1.gz: /usr/share/man/man1/alt-nvidia-current-smi.1.gz
 slave nvidia_bug_report: /usr/lib/nvidia-current/bin/nvidia-bug-report.sh
 slave nvidia_desktop: /usr/share/nvidia-current/ubuntu-nvidia-settings.desktop
 slave nvidia_drv: /usr/lib/nvidia-current/xorg/nvidia_drv.so
 slave nvidia_modconf: /usr/lib/nvidia-current/modprobe.conf
 slave nvidia_smi: /usr/lib/nvidia-current/bin/nvidia-smi
 slave nvidia_xconfig: /usr/lib/nvidia-current/bin/nvidia-xconfig
 slave xorg_extra_modules: /usr/lib/nvidia-current/xorg
 slave xvmcconfig: /usr/lib/nvidia-current/XvMCConfig
La versione "best" attuale è /usr/lib/nvidia-current/ld.so.conf.

2) x@serverona:~$ ldconfig -p | grep GL
 libGLcore.so.1 (libc6) => /usr/lib/nvidia-current/libGLcore.so.1
 libGLU.so.1 (libc6) => /usr/lib/libGLU.so.1
 libGL.so.1 (libc6) => /usr/lib/nvidia-current/libGL.so.1
 libGL.so (libc6) => /usr/lib/nvidia-current/libGL.so

3) x@serverona:~$ ls -l /etc/alternatives/nvidia_modconf
lrwxrwxrwx 1 root root 37 2010-04-06 15:57 /etc/alternatives/nvidia_modconf -> /usr/lib/nvidia-current/modprobe.conf

summary: - [Lucid] Jockey fails to install nvidia hardware driver
+ [Lucid] Jockey gives message that it failed to install nvidia hardware
+ driver
Matthew Eaton (powder) wrote :

I got this error message as well, however, rebooted and the nvidia driver appears to be loaded and working fine. Is this the right bug?

Jacopo Moronato (jmoronat) wrote :

@ Matthew: yes, see #2

Wolfgang78 (wolfgang-langbein) wrote :
Download full text (34.3 KiB)

I tried several ways to install the current NVIDIA driver via apt (nvidia-current_195.36.15-0ubuntu1_i386.deb) or NVIDIA script (NVIDIA-Linux-x86-195.36.15-pkg1.run). No chance at all. After the failed installation I cannot start the xserver or even a terminal. I need to boot via live CD and fix xorg.conf.

In my case I have got 2 x NVIDIA GeForce 8800 GTS.

Interesting is that the driver nvidia-glx-173 works instead. Or at least almost because the temperature of both graphic cards remained constantly at 85 C when I used nvidia-glx-173.

My jockey.log after failed installation of nvidia-current (nouveau is blacklisted):
2010-04-09 01:24:26,851 DEBUG: updating <jockey.detection.LocalKernelModulesDriverDB instance at 0xa31bd8c>
2010-04-09 01:24:26,860 DEBUG: reading modalias file /lib/modules/2.6.32-19-generic-pae/modules.alias
2010-04-09 01:24:26,988 DEBUG: reading modalias file /usr/share/jockey/modaliases/bcmwl
2010-04-09 01:24:26,989 DEBUG: reading modalias file /usr/share/jockey/modaliases/disable-upstream-nvidia
2010-04-09 01:24:27,028 DEBUG: reading modalias file /usr/share/jockey/modaliases/fglrx-modules.alias.override
2010-04-09 01:24:27,030 DEBUG: reading modalias file /usr/share/jockey/modaliases/nvidia-173
2010-04-09 01:24:27,033 DEBUG: reading modalias file /usr/share/jockey/modaliases/nvidia-96
2010-04-09 01:24:27,035 DEBUG: reading modalias file /usr/share/jockey/modaliases/nvidia-current
2010-04-09 01:24:27,038 WARNING: Could not open DriverDB cache /var/cache/jockey/driverdb-OpenPrintingDriverDB.cache: [Errno 2] No such file or directory: '/var/cache/jockey/driverdb-OpenPrintingDriverDB.cache'
2010-04-09 01:24:27,249 DEBUG: loading custom handler /usr/share/jockey/handlers/nvidia.py
2010-04-09 01:24:27,326 WARNING: modinfo for module nvidia_96 failed: ERROR: modinfo: could not find module nvidia_96

2010-04-09 01:24:27,326 DEBUG: Instantiated Handler subclass __builtin__.NvidiaDriver96 from name NvidiaDriver96
2010-04-09 01:24:27,353 DEBUG: NVIDIA accelerated graphics driver availability undetermined, adding to pool
2010-04-09 01:24:27,357 WARNING: modinfo for module nvidia_current failed: ERROR: modinfo: could not find module nvidia_current

2010-04-09 01:24:27,357 DEBUG: Instantiated Handler subclass __builtin__.NvidiaDriverCurrent from name NvidiaDriverCurrent
2010-04-09 01:24:27,367 DEBUG: NVIDIA accelerated graphics driver availability undetermined, adding to pool
2010-04-09 01:24:27,367 DEBUG: Could not instantiate Handler subclass __builtin__.NvidiaDriverBase from name NvidiaDriverBase
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/jockey/detection.py", line 914, in get_handlers
    inst = obj(backend)
TypeError: __init__() takes exactly 3 arguments (2 given)
2010-04-09 01:24:27,385 WARNING: modinfo for module nvidia_173 failed: ERROR: modinfo: could not find module nvidia_173

2010-04-09 01:24:27,385 DEBUG: Instantiated Handler subclass __builtin__.NvidiaDriver173 from name NvidiaDriver173
2010-04-09 01:24:27,395 DEBUG: NVIDIA accelerated graphics driver availability undetermined, adding to pool
2010-04-09 01:24:27,395 DEBUG: loading custom handler /usr/share/jockey/handlers/b43.py
2010-04-0...

Crunchy the Headcrab (m-greb) wrote :

I can confirm this. April 10 2010. System reported that the installation failed for current nvidia driver through restriced driver installer.

After reboot the driver is indeed installed. Nvidia X Server reports version 195.36.15. However, if I check for restricted drivers via the driver install tool, it says "A different version of this driver is in use."

SilverWave (silverwave) wrote :

Lucid beta 2 64bit (No problems with beta 1)

After reboot the Nvidia X Server reports version 195.36.15.

I was getting no windows boarders and freeze of dialogue boxes on changing Visual Affects but found workaround below.

---
http://ubuntuforums.org/showthread.php?p=9102066#post9102066

sudo gedit /etc/modprobe.d/blacklist.conf

Added to bottom of list:
vga16fb
nouveau
---

Thomas PIERRARD (tom-pierrard) wrote :

@ SilverWave : This is not working for me...

I have same problem again, The "see jockey log file." message...

And scrolling very slow in Firefox ( especially on launchpad.net ), maybe cause by compiz and the "Extra" Visual Effects

Jacopo Moronato (jmoronat) wrote :

@ Silver: dialog freeze is related to bug #554106

Alberto Milone (albertomilone) wrote :

I have a committed a fix to the following branch and will upload the package soon:
lp:~ubuntu-core-dev/jockey/ubuntu

Changed in jockey (Ubuntu):
status: Triaged → Fix Committed
Michael Contreras (egcdigital) wrote :

I have the same problem too... please the fix :(

Alberto Milone (albertomilone) wrote :

@Michael
Even if it says that the installation failed, it's not true and if you reboot, the driver will work. Unless you're experiencing some other bug...

VSN (vsn-inbox) wrote :

Hi,

finaly I have found the right bug report about my problem :) The are too much new bug reports about that issue.

I confirm, that inspite of the error message during the installation the NVIDIA driver was installed and works after a reboot.

BUT after a reboot Hardware Drivers writes "a different version of this driver is in use". After pressing the Activate button I got the same error message: Sorry, the installation of this driver failed. Please have a look at the log file for details.: /var/log/jockey.log.
See screen shot.

I hope the fix you proposed will fix this problem too.

Thx

Johansen (johansense) wrote :

Alberto Milone's command fixed it for me.
nvidia 7900 GTS.

sudo update-initramfs -u

NoOp (glgxg) wrote :

Same issue - nvidia-96 is installed & working. Attaching jockeylog.txt. Note that the log is for both 2.6.32-19-generic & 2.6.32-20-generic kernels.

I also notice that after attempting to 'Activate' jockey-gtk and jockey-backend hang (sleeping) & clicking the 'Close' button on the gui does nothing - the processes have to be killed.

$ ps -e | grep jockey
10294 ? 00:00:01 jockey-gtk
10298 ? 00:00:03 jockey-backend

$ apt-cache policy jockey-gtk
jockey-gtk:
  Installed: 0.5.8-0ubuntu6
  Candidate: 0.5.8-0ubuntu6
  Version table:
 *** 0.5.8-0ubuntu6 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
$ apt-cache policy jockey-common
jockey-common:
  Installed: 0.5.8-0ubuntu6
  Candidate: 0.5.8-0ubuntu6
  Version table:
 *** 0.5.8-0ubuntu6 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
$ uname -a
Linux ... 2.6.32-20-generic #29-Ubuntu SMP Fri Apr 9 20:35:55 UTC 2010 i686 GNU/Linux
$ apt-cache policy nvidia-96
nvidia-96:
  Installed: 96.43.14-0ubuntu13
  Candidate: 96.43.14-0ubuntu13
  Version table:
 *** 96.43.14-0ubuntu13 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/restricted Packages
        100 /var/lib/dpkg/status
$ apt-cache policy nvidia-96-modaliases
nvidia-96-modaliases:
  Installed: 96.43.14-0ubuntu13
  Candidate: 96.43.14-0ubuntu13
  Version table:
 *** 96.43.14-0ubuntu13 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

xserver-xorg-video-nouveau is not installed, libdrm-nouveau1 (2.4.18-1ubuntu2) is.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.8-0ubuntu7

---------------
jockey (0.5.8-0ubuntu7) lucid; urgency=low

  [ Alberto Milone ]
  * Do not check that the module is loaded in enabled() in the nvidia
    handler, as this is what we should do in used(). Just make sure
    that the module and its alias are not blacklisted. This prevents
    Jockey from claiming that the installation of nvidia driver failed
    when when it didn't (LP: #552653).

  [ Jonathan Thomas ]
  * Don't crash when closed with the "x" button (LP: #552723, LP: #398912).
    Thanks ThorbjørnTux!

  [ Martin Pitt ]
  * i18n "Install Drivers" string. (LP: #542552)
 -- Alberto Milone <email address hidden> Mon, 12 Apr 2010 10:13:16 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Canol Gökel (canol) wrote :

Hello, I'm experiencing the same issue. After the message I rebooted but I am not sure the driver is in use. Desktop effects are partly working (there is no transparency on borders for example), the boot screen looks ugly (it was ok before I attempted to install the driver), when I go to hardware drivers it says: "A different version of this driver is in use".

Canol Gökel (canol) wrote :

Okay, now I can see the transparency (I didn't know that it is on unfocused windows, sorry). But the others still apply.

DebianSidUser (raza) wrote :

Well it says that this is the same bug as the one I listed, if so it hasn't been fixed.

https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/556736

Alberto Milone (albertomilone) wrote :

@illbashu
In that bug report you also showed a log from the nvidia-installer which is not supported and doesn't really work well with either Jockey or with the Ubuntu packages.

DebianSidUser (raza) wrote :

@Alberto Milone, I completely removed the nvidia-current since it wasn't working and tried the drivers from the site and it didn't work and when it said that there was a fix out I removed the drivers from the site (sudo nvidia-installer --uninstall) (that are working for -15 kernal) and installed nvidia-current and retested and it didn't work...

DebianSidUser (raza) wrote :

1 more thing I tested it on -20 kernal

Tim Cuthbertson (ratcheer) wrote :

I just did a fresh install using the 12-Apr alternate iso image and still experienced this bug. If the fix has been released, it has not made it to the distribution, yet.

DebianSidUser (raza) wrote :

When will it make it to the distribution?

NoOp (glgxg) wrote :

$ apt-cache policy jockey-common
jockey-common:
  Installed: 0.5.8-0ubuntu7
  Candidate: 0.5.8-0ubuntu7
  Version table:
 *** 0.5.8-0ubuntu7 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Works for me - thanks for the fix.

DebianSidUser (raza) wrote :

ok I got the new package but I have a new prob, its not showing any drivers for my system. (I have a nvidia 8600gt)

DebianSidUser (raza) wrote :

I tried installing it from the command line, same error as before.

bash@bash-desktop:~$ sudo aptitude install nvidia-current
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  nvidia-current
0 packages upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 0B/40.8MB of archives. After unpacking 133MB will be used.
Writing extended state information... Done
Selecting previously deselected package nvidia-current.
(Reading database ... 480705 files and directories currently installed.)
Unpacking nvidia-current (from .../nvidia-current_195.36.15-0ubuntu2_amd64.deb) ...
Processing triggers for man-db ...
Setting up nvidia-current (195.36.15-0ubuntu2) ...
update-alternatives: using /usr/lib/nvidia-current/ld.so.conf to provide /etc/ld.so.conf.d/GL.conf (gl_conf) in auto mode.
update-initramfs: deferring update (trigger activated)
Loading new nvidia-current-195.36.15 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-20-generic
Building for architecture x86_64
Building initial module for 2.6.32-20-generic
Done.

nvidia-current.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/2.6.32-20-generic/updates/dkms/

depmod.....

DKMS: install Completed.

Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_CA.utf8.cache...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-20-generic
Processing triggers for python-support ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

JosephB (joseph-bouchard) wrote :

Troubleshooting specific to you would be better brought to Ubuntu Answers or Ubuntu Forums. The bug seems to be fixed.

DebianSidUser (raza) wrote :

Ubuntu forums and useless and this bug hasn't been fixed.

Alberto Milone (albertomilone) wrote :

@illbashu
I think you removed nvidia-common and, as a result, Jockey is unable to show the nvidia drivers which are compatible with your card. This, however, has a very little to do with the bug described here. Furthermore installing the driver from the command line is not enough.

Please follow these steps:
1) remove nvidia-current
2) install nvidia-common
3) try Jockey again and see how it goes

DebianSidUser (raza) wrote :

Alright I did that and it says its installed and in use but compiz doesn't work.

bash@bash-desktop:~$ compiz --replace
compiz (core) - Fatal: Root visual is not a GL visual
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

VSN (vsn-inbox) wrote :

Hi,

got the updates yesterday, played a little with nvidia drivers (remove, install, activate and so on) and it looks like the bug was fixed.

Great job, Alberto! Thx.

Download full text (3.4 KiB)

i have just read your emails... i had over 30 emails regarding this issue... i had decided to stick with karmic koala untill lucid lynx is fully fixed, basically waiting for the final release to come, which is only 2weeks from now. but, i hope others that had the same issue i had, got their problem fixed. im still continuing enjoying linux, ive tried many others and so far mint/ubuntu are the easiest to work on for me. i wished the wine program worked better because i play counter-strike and wine makes the game buggy. maybe in the future wine will be alot better than it is now... faster, smoother... for gaming. i hope... thanks!

> Date: Tue, 13 Apr 2010 17:07:21 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 552653] Re: [Lucid] Jockey gives message that it failed to install nvidia hardware driver
>
> Hi,
>
> got the updates yesterday, played a little with nvidia drivers (remove,
> install, activate and so on) and it looks like the bug was fixed.
>
> Great job, Alberto! Thx.
>
> --
> [Lucid] Jockey gives message that it failed to install nvidia hardware driver
> https://bugs.launchpad.net/bugs/552653
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “jockey” package in Ubuntu: Fix Released
>
> Bug description:
> Video driver testing; jockey fails to install nvidia driver. Message given is "see jockey log file."
> This is a new failure using the lucid-desktop-i386.iso dated 2010-03-31 to install Ubuntu.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: jockey-gtk 0.5.8-0ubuntu6
> ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-18-generic i686
> Architecture: i386
> Date: Wed Mar 31 10:25:48 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100331)
> Lsusb:
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: System manufacturer System Product Name
> PackageArchitecture: all
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-18-generic root=UUID=5cac8118-7d43-4444-83c8-fbab89f79078 ro quiet splash
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: jockey
> dmi.bios.date: 12/20/2005
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 1008.008
> dmi.board.name: P4S8X-MX
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1008.008:bd12/20/2005:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP4S8X-MX:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: System Product Name
> dmi.product.version: System Version
> dmi.sys.vendor: System manufacturer
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/552653/+subscribe
     ...

Read more...

Arnold Niemann (niemann650) wrote :
Download full text (3.3 KiB)

as i do enjoy helping creators of ubuntu make it better by fixing bugs,
ive decided to stay with karmic 9.10 untill lucid 10.04 is done and
fully functional. which is only 2 weeks away... i hope everything gets
sorted out. so far ubuntu is the best ive worked with... ive heard many
other distros out there that are just as good as ubuntu, but havent
tried them out yet.

> Date: Tue, 13 Apr 2010 10:19:48 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 552653] Re: [Lucid] Jockey gives message that it failed to install nvidia hardware driver
>
> Alright I did that and it says its installed and in use but compiz
> doesn't work.
>
> bash@bash-desktop:~$ compiz --replace
> compiz (core) - Fatal: Root visual is not a GL visual
> compiz (core) - Error: Failed to manage screen: 0
> compiz (core) - Fatal: No manageable screens found on display :0.0
>
> Launching fallback window manager
>
> --
> [Lucid] Jockey gives message that it failed to install nvidia hardware driver
> https://bugs.launchpad.net/bugs/552653
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “jockey” package in Ubuntu: Fix Released
>
> Bug description:
> Video driver testing; jockey fails to install nvidia driver. Message given is "see jockey log file."
> This is a new failure using the lucid-desktop-i386.iso dated 2010-03-31 to install Ubuntu.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: jockey-gtk 0.5.8-0ubuntu6
> ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-18-generic i686
> Architecture: i386
> Date: Wed Mar 31 10:25:48 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100331)
> Lsusb:
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: System manufacturer System Product Name
> PackageArchitecture: all
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-18-generic root=UUID=5cac8118-7d43-4444-83c8-fbab89f79078 ro quiet splash
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: jockey
> dmi.bios.date: 12/20/2005
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 1008.008
> dmi.board.name: P4S8X-MX
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1008.008:bd12/20/2005:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP4S8X-MX:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: System Product Name
> dmi.product.version: System Version
> dmi.sys.vendor: System manufacturer
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/552653/+subscribe

_________________________________________________________________
The New Busy is not the too...

Read more...

De4dSpace (wasteofspace) wrote :

When was this bug fixed? I just fresh installed Beta 2 x64 on April 10th. I work 12 hour days so I don't have time to tweak, sorry.

According to comment #24 above, this was fixed on 2010-04-12.

Emiliano (emiliano-perulli) wrote :

This bug still persists in my just upgraded Ubuntu-Lucid on 2010-04-14

Emiliano (emiliano-perulli) wrote :

Errata corrige: it works now. I just had to remove the default-installed driver, then reinstall it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions