Jockey doesn't show enabled nvidia drivers as such

Bug #547066 reported by Alberto Milone on 2010-03-25
114
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Jockey
Undecided
Unassigned
jockey (Ubuntu)
High
Hisham Sayed Ibrahim
Lucid
High
Alberto Milone

Bug Description

Jockey doesn't show enabled nvidia drivers as such because it fails to check whether the kernel module is loaded because it looks for the actual name of the module (e.g. nvidia_current.ko) but can find only the alias (i.e. nvidia).

An acceptable solution would be to look up the alias and see what it points to.

Related branches

Changed in jockey (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Jacopo Moronato (jmoronat) wrote :

Alberto, is this bug the same as bug #522943 ?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.8-0ubuntu6

---------------
jockey (0.5.8-0ubuntu6) lucid; urgency=low

  * data/handlers/fglrx.py:
    - Re-enable the fglrx handler and make it use the alternatives system
      (LP: #496225).
  * data/handlers/nvidia.py:
    - See if the module alias is loaded and then check what module it
      corresponds to in order to see if it's really enabled (LP: #547066).
      This involved overriding the enabled() and the used() methods.
  * jockey/xorg_driver.py:
    - Simplify the logic in the enabled() method by only relying on
      X-Kit's isDriverEnabled() method. This will avoid getting false
      positives in the case in which the 1st Device section (i.e. the
      only one that we used to check) uses the right driver but the
      same section is irrelevant as it's not mentioned in the
      ServerLayout section.
 -- Alberto Milone <email address hidden> Tue, 30 Mar 2010 15:48:37 +0200

Changed in jockey (Ubuntu Lucid):
status: Triaged → Fix Released
Uphaar Agrawalla (uphaar) wrote :

This was actually reported in bug 539997.

Alberto Milone (albertomilone) wrote :

@Jacopo, Uphaar

Yes, they are the same bug.

Yotam Benshalom (benshalom) wrote :

The problem was not fixed for me. I use jockey-gtk 0.58-0ubuntu8. Nouvou (sp?) is not installed, only nvidia-current, and I get "The driver is activated but is not currently in use" (although 3d and nvidia-setttings work well). My system is dell studio xps-13 with geforce 9500m.
I'll be happy to provide further information. My xorg.conf is attached.

Rkimber (rkimber) wrote :

I also still have this problem. The driver is reported as activated but not in use, and no proprietary drivers are said to be in use.

I have 10.04 with jockey 0.5.8-0ubuntu8.1

xorg.conf is attached
Also, nvidia-settings works fine and a plausible GPU temperature is reported by the, presumably proprietary, driver.

This bug is still present on lucid (when after distribution upgrade) 0.5.8-0ubuntu8.1

A separate clean install of lucid does not have this bug.

Stuart Gillies (gillies) wrote :

I have the same problem (nvidia driver reported as activated but not in use). But when I remove all other drivers that I can find from the system (nouveau and nv) and restart, I find that this message is still reported.

However, when I start up nvidia-settings (195.36.24) I also find that some adjustments there work (digital vibrance, x server colour correction) and some don't (x server xvideo settings). This suggests to me that the nvidia driver is in fact in use, perhaps not fully, despite the message from the jockey gui.

Here too. It is a disturbing message, because practially the driver is working fine,

Bogdan Butnaru (bogdanb) wrote :

I still get this in Natty. (I can’t reopen the bug for some reason, “fix released” is the only option available.

teimcrr (marco-carrarini) wrote :

Confirmed here for Natty clean install.
However, driver seems to work fine, tested with Unigine

Changed in jockey (Ubuntu):
assignee: Alberto Milone (albertomilone) → Hisham Sayed Ibrahim (hisham-olympic)
Andrei Dziahel (develop7) wrote :

I'm experiencing this bug in Natty (upgraded from Maverick)

Linuxexperte (andrea-koeth) wrote :

hi together,

I am experiencing the same message here in LinuxMint 11 RC after a fresh and clean install for upgrading from LinuxMint 10 to LinuxMint 11. LinuxMint 11 is based on natty. In the control-center, it says, that the current-driver is activated but not in use. I had installed the driver from the control-center right after the fresh install. After having installed the nvidia-driver from the control-center, I installed the ppa-repository of the ubuntu-x-swat-team to fix a problem with screenresolution.
But if I check in invida-settings, it says, that the driver version 270.41.06 is activated and in use. x-server-version there is said with version 11.0. Server-vendor-version is said to be 1.10.1 (11001000). Therefore it seems, that the driver is in use, so that the information in the control-center seems obviously to be wrong. This is also confirmed to the termal-settings in the nvidia-settings, which show a plausible temperature of 52 degrees.

Can it be possible, that this is a problem of jockey then?

Here some information about my current system:

System: LinuxMint 11 Katya

Kernel is 2.6.38-8-generic.

My graphic-card is this one: 02:00.0 VGA compatible controller: nVidia Corporation C79 [GeForce 9200M G] (rev b1)

LinuxMint 11 uses Gnome 2.32.1 as default-desktop.

Architecture is x86_64

I would be interested in what the developers say to this.

Greetings
Linuxexperte

Linuxexperte (andrea-koeth) wrote :

For the developers: What I wanted to add: I checked the Synaptic and I found, that the nvida-current-modaliases won't be installed although the depend on nvidia-current. Synaptic shows an error-message there!!! Please check this!!!

Linuxexperte (andrea-koeth) wrote :

hi developers,

I suppose, that this bug is not only affecting Ubuntu but also LinuxMint 11. Could you please add LinuxMint to the list referring the point "also affects distribution". There LinuxMint is not included. Please could you include it??

Linuxexperte (andrea-koeth) wrote :

now I can publicly confirm this. Nvidia has started tracking this issue. There is a bugreport-page existing directly at Nvidia.

Look here: http://forums.nvidia.com/index.php?s=dcae62a5157dea3918cd58cb09c8c057&showtopic=203643&st=20&p=1270537&#entry1270537

Perhaps all these issues from htere should be reported there??

Greetings
Linuxexperte

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers