jockey-kde cannot run: ImportError: No module named ManagerWindowKDE4

Bug #543707 reported by Untitled No. 4 on 2010-03-21
96
This bug affects 21 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
High
Martin Pitt
python-distutils-extra (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: jockey-kde

In Kubuntu 10.04 (Beta 1 + updates) running Hardware Drivers from the menu doesn't open Jockey. Running "sudo jockey-kde" from Konsole results in the following error:
File "/usr/bin/jockey-kde", line 33, in <module>
    import jockey.kdeui.ManagerWindowKDE4
ImportError: No module named ManagerWindowKDE4

This started with after the first updates to beta 1.

ProblemType: Bug
Architecture: amd64
Date: Sun Mar 21 20:51:36 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: LENOVO 2056W5F
Package: jockey-kde 0.5.8-0ubuntu2
PackageArchitecture: all
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=32964b48-66d3-4deb-9f09-58d0eeaa0339 ro quiet splash
ProcEnviron:
 LANGUAGE=
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: jockey
Uname: Linux 2.6.32-16-generic x86_64
dmi.bios.date: 01/09/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6FET56WW (2.02 )
dmi.board.name: 2056W5F
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6FET56WW(2.02):bd01/09/2009:svnLENOVO:pn2056W5F:pvrThinkPadT500:rvnLENOVO:rn2056W5F:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2056W5F
dmi.product.version: ThinkPad T500
dmi.sys.vendor: LENOVO

Untitled No. 4 (untitled-no4) wrote :
Kris OMealy (komealy) wrote :

temporary workaround:
$ jockey-text -l (to list available drivers)
$ jockey-text -e <driver_name> (to enable driver)

This allows you to still enable proprietary drivers, but does nothing to fix this error. I tried installing a few python- packages and a couple kde- ones to no avail. I wasn't able to find any that had to do with ManagerWindowKDE4.

Changed in jockey (Ubuntu):
status: New → Confirmed
Laurent Claessens (moky-math) wrote :

An other workaround (maybe more userfrindly) is to use jockey-gtk

$ apt-get installe jockey-gtk
$ jockey-gtk

The advantage I see is that jockey-text does not mention which of the driver is recommanded. (at least in the Nvidia case)

Changed in jockey (Ubuntu):
assignee: nobody → Jockey-hackers (jockey-hackers)
Jens Jorgensen (jorgensen) wrote :

I've figured out the fix for this. This package uses the very cool DistUtilsExtra.auto module which allows the package to automagically figure out what needs to be done and included in the package. However, the bit of code which looks for kde .ui files searches for files that match *.ui and then checks the first line of the file to see if it starts with:

<ui version="

But unfortunately the first lines of kde/ManagerWindowKDE4.ui are:

<?xml version="1.0" encoding="UTF-8"?>
<ui version="4.0">

and therefore it doesn't get picked up. It looks like the current bzr branch for this project has this problem fixed so the next release should work fine.

Martin Pitt (pitti) wrote :

No, there is no fix for that in python-distutils-extra yet. I'll fix that.

Changed in python-distutils-extra (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: New → In Progress
Martin Pitt (pitti) wrote :

After a pde fix, jockey just needs a rebuild.

Changed in jockey (Ubuntu):
assignee: Jockey-hackers (jockey-hackers) → Martin Pitt (pitti)
importance: Undecided → High
status: Confirmed → In Progress
Martin Pitt (pitti) on 2010-03-26
Changed in python-distutils-extra (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-distutils-extra - 2.18bzr1

---------------
python-distutils-extra (2.18bzr1) lucid; urgency=low

  * auto.py: Also recognize Qt .ui files if they start with an "<?xml..."
    first line. (LP: #543707)
 -- Martin Pitt <email address hidden> Fri, 26 Mar 2010 17:38:18 +0100

Changed in python-distutils-extra (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.8-0ubuntu4

---------------
jockey (0.5.8-0ubuntu4) lucid; urgency=low

  * Merge bug fix from trunk:
    - ui.py: Fix _check_repositories() to not invoke the UI and error dialogs
      in --check mode. (LP: #540750)
  * debian/control: Bump python-distutils-extra build dependency, to ensure we
    build correct -kde packages. (LP: #543707)
 -- Martin Pitt <email address hidden> Fri, 26 Mar 2010 17:41:56 +0100

Changed in jockey (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers