jockey-gtk doesn't detect NVidia Video cards to install proprietary driver

Bug #518067 reported by benste
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Fix Released
High
Unassigned
Nominated for Lucid by Charlie Kravetz

Bug Description

jockey-gtk doesn't detect a geforce7600go to isntall proprietary driver
possibly other hardware too - as reported on IRC (e.g. geforce 6600 GT)

ProblemType: Bug
Architecture: amd64
Date: Sat Feb 6 15:49:15 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
MachineType: Sony Corporation VGN-FE31M
Package: jockey-gtk 0.5.6-0ubuntu1
PackageArchitecture: all
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=dcc56a30-f8f3-4adf-8979-58f695f74007 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
SourcePackage: jockey
Uname: Linux 2.6.32-12-generic x86_64
dmi.bios.date: 08/17/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: R0170J3
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: 7R1M00000000a4f250a8f25490a4
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: C3LN17TL
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR0170J3:bd08/17/2006:svnSonyCorporation:pnVGN-FE31M:pvrC3LN17TL:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrC3LN17TL:
dmi.product.name: VGN-FE31M
dmi.product.version: C3LN17TL
dmi.sys.vendor: Sony Corporation

Revision history for this message
benste (benste) wrote :
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this bug and the supporting attachments. I think there are many NVidia cards not being recognized by jockey in lucd lynx. My own AGP video card, 01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1), has a choice of three nvidia hardware drivers in Ubuntu 9.10, but even when I upgrade to lucid after installing the current driver (-185), it is not recognized in lucid. The driver is left installed, but can not be activated.

I have the logs available if needed from the upgrade.

Changed in jockey (Ubuntu):
status: New → Confirmed
importance: Undecided → High
summary: - jockey-gtk doesn't detect a geforce7600go to isntall proprietary driver
+ jockey-gtk doesn't detect NVidia Video cards to install proprietary
+ driver
Revision history for this message
Reid Miller (sweetreid) wrote :

I have the same problem with a different hardware config. Should I submit a separate bug?

lspci output:
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 140M (rev a1)

Revision history for this message
benste (benste) wrote :

01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce Go 7600] (rev a1)

found a workaround
if you open appeareance config, and choose to activate 3d effects it will search drivers again, strangly it does find them now.
I've aborted the install and now jockey knows my drivers too.

Could you test this on your machines too - guess the first attempt of jockey doesn't know where to search or where to get the hardware info.

Changed in jockey (Ubuntu):
assignee: nobody → Ubuntu Drivers (ubuntu-drivers)
Revision history for this message
Benjamin Geese (ben-8409) wrote :

my ati radeon hd 3600 isnt detected either.
should i mark myself affected or open another bug report because its not an nvidia card?

Revision history for this message
Daniel Holbach (dholbach) wrote :

Please don't use the "ubuntu-drivers" team.

Changed in jockey (Ubuntu):
assignee: Ubuntu Drivers (ubuntu-drivers) → nobody
Revision history for this message
yasaswi (yasaswi-lakkaraju) wrote :

benste <- The work around did not work for me. After trying to change the settings it just gave the error "Desktop effects could not be enabled" I have Nvidia Geforce 8500 GT.

Revision history for this message
Erik B. Andersen (azendale) wrote :

Has anyone tried 'sudo apt-get update' ing, restarting, and then Going to System -> Administration -> Hardware Drivers? I wasn't able to get anything to show up until I did an apt-get update, restarted, and tried again.
HTH,
Erik

Revision history for this message
Charlie Kravetz (charlie-tca) wrote : Re: [Bug 518067] Re: jockey-gtk doesn't detect NVidia Video cards to install proprietary driver

On Fri, 12 Feb 2010 06:49:38 -0000
"Erik B. Andersen" <email address hidden> wrote:

> Has anyone tried 'sudo apt-get update' ing, restarting, and then Going to System -> Administration -> Hardware Drivers? I wasn't able to get anything to show up until I did an apt-get update, restarted, and tried again.
> HTH,
> Erik
>

When the desktop comes up, click on System -> Administration ->
Hardware Drivers. Shows the Nvidia current version driver "activated
but not currently in use." The only option available is 'Remove'.
Clicked 'Remove'; driver is removed. Click 'Activate' again, with out
closing app and with out restarting. Installs the driver and tells me I
need to restart again. Endless loop...

--
Charlie Kravetz
Linux Registered User Number 425914 [http://counter.li.org/]
Never let anyone steal your DREAM. [http://keepingdreams.com]

Revision history for this message
Alberto Milone (albertomilone) wrote :

@Benjamin
There's no fglrx driver in Lucid yet.

Revision history for this message
Gabriel Čenkei (gabox) wrote :

In current daily image this bug is resolved for me. nVidia GF6200LE correctly detected, downloaded and installed. Please check it out.

Revision history for this message
benste (benste) wrote :

For me too - Lucid detected my card withouht a problem
=> I'd suggest closing this bug as solved - OK ?

Revision history for this message
Alberto Milone (albertomilone) wrote :

Thanks for reporting that the problem is solved now. I'm closing this bug report.

Changed in jockey (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers