Jockey doesn't support the alternatives system

Bug #506618 reported by Dave Morley on 2010-01-12
116
This bug affects 19 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
High
Alberto Milone

Bug Description

Nvidia current failed to install from jockey.

ProblemType: Bug
Architecture: amd64
Date: Tue Jan 12 20:50:55 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100112.1)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
NonfreeKernelModules: nvidia
Package: jockey-gtk 0.5.5-0ubuntu4
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-10-generic root=UUID=0ff33399-a030-42cb-9d6d-ed5ed227f083 ro quiet splash
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: jockey
Tags: lucid
Uname: Linux 2.6.32-10-generic x86_64
dmi.bios.date: 11/08/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: NF-M2S
dmi.board.vendor: www.abit.com.tw
dmi.chassis.type: 3
dmi.chassis.version: NF-M2S
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd11/08/2006:svn:pnNF-M2S:pvr:rvnwww.abit.com.tw:rnNF-M2S:rvr:cvn:ct3:cvrNF-M2S:
dmi.product.name: NF-M2S

Dave Morley (davmor2) wrote :
Charlie Kravetz (charlie-tca) wrote :

I can confirm this bug. Installed Xubuntu Lucid from the lucid-desktop-i386.iso dated 2010-01-12.1. Attempts to install nvidia drivers using the icon in the system tray gave this error.

In the jockey.log towards the bottom is
WARNING: modinfo for module nvidia failed: ERROR: modinfo: could not find module nvidia
which would indicate a problem.

This was on a desktop machine: 1.5GHz P4; 1GB RAM; NVidia 6200 w/256MB memory

Changed in jockey (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
Alberto Milone (albertomilone) wrote :

Thanks for reporting the problem.

Jockey doesn't support the new drivers yet, therefore the nvidia packages will have to be installed manually.

This will be explained in the release notes for alpha 2.

On Tue, 2010-01-12 at 21:13 +0000, Alberto Milone wrote:
Cool, I figured it would be something daft like that. :)

--
Seek That Thy Might Know

http://www.davmor2.co.uk

tags: added: iso-testing

And why do I get the same error when trying to install the old 173-version?

Alberto Milone (albertomilone) wrote :

Because it's not a matter of supporting every single driver but rather the fact that Jockey can't deal with the new alternatives system yet.

To be honest, I have added the support for the new system to Jockey but Jockey itself can't be built because of an obsolete dependency (kdebindings).

If you want to install the driver you should follow the instructions available on this page:
https://wiki.ubuntu.com/LucidLynx/TechnicalOverview

(Look for the part about Nvidia in the "Known Issue" paragraph)

Changed in jockey (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: Triaged → Fix Committed
Meir Mazza (mazza-m) on 2010-01-15
Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Philip Muškovac (yofel) wrote :

Marking Fix Committed again as there's no changelog entry in lucid indicating this was fixed.

Changed in jockey (Ubuntu):
status: Fix Released → Fix Committed
Joel Ebel (jbebel) on 2010-01-27
tags: added: glucid
Alberto Milone (albertomilone) wrote :

Jockey supports the alternatives system now. I'm closing this bug report.

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released

I tried doing this today with Lucid Beta 2 and jockey reported that it failed to install NVIDIA current. This bug is not fixed?

Changed in jockey (Ubuntu):
status: Fix Released → Confirmed

Oh, and I should add that after the error message the Jockey UI is frozen. No response to clicking Help, Activate or Close.

las (bandara-ls) wrote :

beta 2 jockey log

las (bandara-ls) wrote :

though it said failed in jockey after running "nvidia-xconfig" as root and rebooting made nvidia driver to work..

Alberto Milone (albertomilone) wrote :

This bug is fixed. What you're experiencing is bug #552653 and I'm working on it.

Changed in jockey (Ubuntu):
status: Confirmed → Fix Released
summary: - Jockey failed to install nvidia current drivers
+ Jockey doesn't support the alternatives system

Ahh, I see. Sorry and thank you.

Jeff Joker (jeffjoker) wrote :

Hello,

I had the same bug this morning on a fresh install of beta 2 via the latest ISO, did all available updates beforehand.
Also, I do not know if this bug was filled but installing the Nvidia driver turns the boot and shutdown splashscreens to be zoomed and therefore blur :((

Ryan Daly (daly-ctcnet) wrote :

This bug is still present on the released Lucid. Jockey doesn't pick up the NVIDIA driver(s).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers