Ubuntu

Crash when trying to set up wifi on Dell Mini 10v (Broadcom) in Kubuntu Netbook

Reported by Scott Kitterman on 2009-10-28
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Nominated for Trunk by Scott Kitterman
jockey (Ubuntu)
High
Unassigned

Bug Description

This is using jockey-kde from the menu after installation with an active wired network.

See the attached log

I did run it more than once with similar results:

$ ps -AF|grep jockey
kitterma 1687 1638 0 744 652 1 00:49 pts/1 00:00:01 tail -f jockey.log
kitterma 2089 1540 0 17912 18200 1 11:30 ? 00:00:01 /usr/lib/kde4/libexec/kdesu -u root -c /usr/bin/jockey-kde
root 2095 2089 0 437 480 1 11:30 ? 00:00:00 sh -c /usr/bin/jockey-kde
root 2096 2095 0 37510 37816 1 11:30 ? 00:00:02 /usr/bin/python /usr/bin/jockey-kde
root 2101 1 0 5845 15656 0 11:30 ? 00:00:03 /usr/bin/python /usr/share/jockey/jockey-backend --debug -l /var/log/jockey.log
kitterma 2204 2176 0 437 524 0 11:32 pts/2 00:00:00 /bin/sh -e /usr/bin/ubuntu-bug jockey-kde
kitterma 2209 2204 0 39560 42184 1 11:32 pts/2 00:00:04 /usr/bin/python /usr/share/apport/apport-kde jockey-kde
kitterma 3229 2547 0 760 872 1 11:44 pts/4 00:00:00 grep --color=auto jockey

I killed all the existing jockey processes, run apt-get update, and it worked fine.

It seems not to handle the lack of a local package cache well.

Scott Kitterman (kitterman) wrote :
Changed in jockey (Ubuntu):
status: New → Triaged
importance: Undecided → High
Scott Kitterman (kitterman) wrote :

I think this one can only be fixed on the ISO, so adding a release note:

The "Hardware Drivers" package in Kubuntu (jockey-kde) requires a local package cache to function properly. Immediately after a new installation, this might not exist. If running jockey-kde after installing Kubuntu, first ensure there is a local package cache by running kpackagekit (in the system section of the menu) and clicking on software updates or in a Konsole shell doing "sudo apt-get update" before running jockey-kde.

Martin Pitt (pitti) wrote :

This is not Kubuntu specific. How about:

The "Hardware Drivers" tool (Jockey) requires up to date package lists before it detects and advertises necessary driver packages. Immediately after a new installation, this will not exist. Before running Jockey the first time after installation, update the package lists in the "Software Updates" (Ubuntu) or "KPackageKit" (Kubuntu) in the System menu, or open a Terminal window and do "sudo apt-get update".

Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/KarmicKoala/ReleaseNotes#Package%20list%20must%20be%20manually%20refreshed%20before%20installing%20drivers>:

The "Hardware Drivers" tool (Jockey) requires up to date package lists before it detects and advertises necessary driver packages. Immediately after a new installation, these package lists will not be present. Before running Jockey for the first time, update the package lists using {{{System->Administration->Software->Update Manager}}} (on Ubuntu) or "KPackageKit" (on Kubuntu). (Bug:462704)

Changed in ubuntu-release-notes:
status: New → Fix Released
Patrick T. (p1703) wrote :

Why is this not fixed? This is no release notes problem, but a simple update problem before running Jockey. Networking doesn't work anymore, too. Karmic is just another low quality release, as the last ones. Will be moving to another Distro, bye.

lixo1 (lixo1) wrote :

Hi, I installed Kubuntu netbook remix 9.10 on Dell Mini 10v. Wifi doesn't work "out of the box".
- At the first boot, after 1min the driver manager automatically shows the "Broadcom STA wireless drive" to install.
- I click to activate it, nothing happened, the drive manager (jockey-kde) freezes.

So, I connect to internet via LAN, and them:
- Tried to activate the Broadcom driver, but nothing, same behavior.

Them I tried to:
- Uninstall bcmwl-kernel-source and bcmwl-modaliases
- Open the drive manager and activate Broadcom. The download started, when the installation finished the driver was installed but the pc crash (black screen). When I reboot I get "Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

So, there something very strange here.

NB. I tried to install Broadcom during the live CD, but the pc crashs after Broadcom driver installation.
I also tried the live CD of Alpha 4 and Alpha 5, and I didn't have any problem, wifi works great.

Please fix it.

lixo1 (lixo1) wrote :

Finally my wifi works, after using only konsole.
I uninstall b43-fwcutter, dkms, bcmwl-kernel-source, bcmwl-modaliases. (apt-get autoremove)
I connect to internet using wire and:
sudo apt-get bcmwl-kernel-source
After a reboot the wireless worked, and jockey showed correctly the active wifi driver.

Jonathan Thomas (echidnaman) wrote :

In Lucid, jockey has the ability to build a local package cache. This is fixed, barring any unforeseen bugs with the feature.

Changed in jockey (Ubuntu):
status: Triaged → Fix Released

Jonathan Thomas [2010-03-18 16:39 -0000]:
> In Lucid, jockey has the ability to build a local package cache.

(It's actually _the_ global package cache, JFYI :) )

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments