Ubuntu

Karmic Restricted Driver Bug

Reported by nachokb on 2009-10-12
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Brian Alexander
Nominated for Lucid by Brian Alexander

Bug Description

When trying to activate a proprietary driver for Broadcom BCM4312 wifi adapter on Ubuntu Karmic (tested Alpha 3, Alpha 5 and Beta), it fails. It tries to open a windows which supposedly downloads and installs the drivers, but it just vanishes immediately. See screencast[1].

Important detail: this didn't happen when running from the LiveCD, only when it is installed. When running from the LiveCD, it successfully install the proprietary Broadcom STA driver.

Running lsmod doesn't show 'wl' module (it is shown when running from the LiveCD).

May be related to:

* 410963 (this seemed to be NetworkManager-specific -- everyone reporting that bug seems to have the driver installed)[2].
* 396203 (though in my case, no error message appeared -- I don't even know if it is Jockey crashing or what else)[3].

DELL Inspiron 1545 Notebook.

[1] Screencast showing the problem: http://www.youtube.com/watch?v=cwiL-bvokDo
[2] https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/410963
[3] https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/396203

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 12 02:13:01 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.6
MachineType: Dell Inc. Inspiron 1545
Package: jockey-gtk 0.5.4-0ubuntu1
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=dab3ee9a-8c3e-4798-8c1f-7a2ad2948288 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: jockey
Uname: Linux 2.6.31-11-generic x86_64
dmi.bios.date: 05/13/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0G848F
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd05/13/2009:svnDellInc.:pnInspiron1545:pvr:rvnDellInc.:rn0G848F:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1545
dmi.sys.vendor: Dell Inc.

nachokb (nachokb) wrote :
nachokb (nachokb) wrote :
nachokb (nachokb) wrote :

Indeed it was solved by installing the bcmwl-kernel-source package...

I fixed it differently. HP Mini 5101 netbook.
The driver enabled OK via jockey-gtk running off usb, but not running post installation.

$ jockey-text -l
kmod:wl - Broadcom STA wireless driver (Proprietary, Disabled, Not in use)
$ sudo jockey-text -e kmod:wl
$ jockey-text -l
kmod:wl - Broadcom STA wireless driver (Proprietary, Disabled, Not in use)

I'd tracked down the module and was following a possible fix I'd find via google. the insmod error lead me to another google result which suggested depmod -a

wireless worked shortly after, and was still working post reboot; so I suspect jockey enabled the driver but tripped over errors loading it. Perhaps any action which runs depmod would fix it at this point.

$ pwd
/lib/modules/2.6.31-14-generic/updates/dkms
$ sudo insmod ./wl.ko
insmod: error inserting './wl.ko': -1 Unknown symbol in module
$ sudo depmod -a
$ modprobe wl
FATAL: Error inserting wl (/lib/modules/2.6.31-14-generic/updates/dkms/wl.ko): Operation not permitted
$ sudo modprobe wl
$ lsmod | grep wl
wl 1272936 0
lib80211 6432 2 lib80211_crypt_tkip,wl

ps. that was on the 9.10 release candidate.

AaronPeterson (alpeterson) wrote :

also occurs with 9.10 netbook remix. Basically there is a problem where it thinks the .deb files are in th e /cdrom folder, but they are not.

Had to install fakeroot dkms, and patch then bcmws-kernel (spelling is probably off) using dpkg from the /media/[tempstring] folder

and reboot, then it comes up.

Note, it also didn't work from the live USB drive, it set the files up for an install, but then it wanted to reboot the computer, but that can't work!! If I rebooted, I'd be without the newly installed drivers!!.

I don't have the ability to plug my computer in to download fixes! I barely have a second computer to surf the web to find the answers!

Much thanks to these guys for helping:
http://swiss.ubuntuforums.org/showthread.php?t=1288865

Runar Ingebrigtsen (ringe) wrote :

I have the same issue with the final 9.10 CD. I ran the Live session from the CD and installed the bcmwl-kernel-source package. The Hardware wizard then said I needed to reboot, which I didn't. Instead I just selected the wireless network I wanted to use in the nm-applet and voilá. So I get wireless while using the LiveCD. Not easy though. I guess not many regular users could do this.

Runar Ingebrigtsen (ringe) wrote :

I also did a fresh install of Karmic. After installation I added the 9.10 CD to my software sources and installed the bcmwl-kernel-source package via Synaptic, which made my wireless network activatable.

I had to make symbolic links manually to fit the requirement of /cdrom as the path to the 9.10 CD.

Changed in jockey (Ubuntu):
status: New → Confirmed
marcbarriere (marcbarriere) wrote :

Same problem with inspiron 1525. I installed Ubuntu 9.04 (the wifi is working with this version) and after I just upgrade to 9.10 with the upgrade program.

Brian Alexander (balexand) wrote :

Simple workaround at http://www.ubuntumini.com/2009/11/broadcom-wireless-driver-fix-in-karmic.html

I did the command line method. Plug in to a wired network connection and run:

sudo apt-get update
sudo apt-get --reinstall install bcmwl-kernel-source

jippolito0003 (jippolito0003) wrote :

Does this fix work on the HP mini 1151 nr Brian?

Andy (andrzejgolka) wrote :

I have the same problem on HP 2133, I've did it (above) and I'm still can't use wifi...

 I've switch off and switch on wifi driver also, and nothig changed. Hp2133 still couldn't see wifi, after this operatin and after restart (after switching off and on procedure).

I've been used 9.04 and everything was perfect, and just after update to 9.10 I've had wifi, but after restarti it disapeard.
Also, I have problem with music - it doesen't work after I open music control panel. But after restart, music work again. I'm new with Ubuntu and I was happy with 9.04 that I drop off f... windows, but now I going to be dissapointed...
So I will be thankfoul for helping me with this.

Hello have a dell mini 10 v and still no wireless. also did an apt get and did not work for me. i am new to linux and have never gotten wireless to work, sure would be nice to get away from *(&%(*&% windows, but without wireless its a useless box...

zandrelli (z3) wrote :

Simple Solution to the Broadcom WiFi issue. First you need to get on the net via Ethernet (wired). Then Go to "Hardware Update" under System. Look for Broadcom drivers. They will appear for installation and then Installed. I had the same situation as everyone her with 9.10 with an Dell Insprion i1545-014B.

yeti (utu) wrote :

I also have a new Dell 1545 with this problem. Just using live cd for now.
Wireless worked ok on ubu 9.04 but not on 9.10 just as others have said.

My Dell calls the wireless 1397;
dmesg | grep -i bcm says bcm4315,
lspci | grep bcm says bcm4312 802.11 b/g rev 01.
No typo, 4312 not 4315, go figure.

Doing the install bcmwl kernel source gets the following modules
into play: lib80211_crypt_tkip, and wl;
in ubu9.04 it was ieee80211_crypt_tkip and wl.
Wireless very good with these installed.

I really believe this ought to get fixed. The hang-up here is rather nasty
when the wrong drivers are loaded.

My Dell Mini 10 ia also confused about what version of wireless is present:

dmesg | grep -i bcm says bcm4315,
lspci | grep bcm says bcm4312 802.11 b/g rev 01.

I have tried 5 different versions of Netbook remix and none of them will get my wireless working on the Dell Mini 10. As poster above noted, excellent OS, but utterly useless on a Netbook without WIFI. There are threads all over Ubuntuforums.org. Can't we get the gurus to figure out a root cause for this and get it fixed already?

sreeharshau (sreeharsha-a) wrote :

Problem solved:

Hi, I had the same problem with broadcom wirless device. initially my wired network didnt work either. Later, I hooked up the cable and started in recovery mode (esc at boot).
In the recovery menu I selected dpkg ( repair brokern packages). it asked for the password etc and looked like it checked/installed some packages. once this is done, i exited from command prompt and rebooted.wireless worked.

HP netbook 1030NR

I had not problem with installing 9.10 on my HP2133 over the Xmas break (although the 9.04 to 9.10 upgrade failed miserably). WIFI worked as did everything else.

On the other hand, I cannot get my Dell Inspiron 1545 to boot the 9.10 LiveCD (neither 32-bit nor 64-bit). More precisely, I think it is booting (I can hear the start up tune) but I have no display - neither the LCD panel nor an external VGA display. I've tried also a Dell 9.10 recovery DVD.

Is there someway to boot the LiveCD into a text only console?

Geoff S (chdkoop) wrote :

I found that a simple wired plug in with the 'sudo apt-get update then running the synaptic update then going into hardware drivers and enableing them since (they were disabled to begin with worked as soon as the broadcom drivers were activated). This worked on the hp mini 110 series. The ve.r was Ubuntu 9.10 netbook remix. IP.s I did try some of the fixes on here and for the minis it worked but the LiveCD way was unsuccesful.

tdn (spam-thomasdamgaard) wrote :

Geoff, this did not solve the issue on my Lenovo S10.

Pomi (max-omelchenko) wrote :

sudo apt-get update
sudo apt-get --reinstall install bcmwl-kernel-source

This worked for my Lenovo S12

Changed in jockey (Ubuntu):
status: Confirmed → Invalid
Michael Watson (mwatson128) wrote :

I had this problem recently with 10.4 net book remix. Basically the install of the proprietary driver fails at the very end.

I followed Ben Prescott's instructions in post #4, THANKS Ben!, and got it working.

dmesg output cut...
[ 0.000000] Linux version 2.6.32-21-generic (buildd@rothera) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 (Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2)
...
[ 56.990615] compal-laptop: Identified laptop model 'Dell Mini 10v'.
...
[ 3919.721963] eth1: Broadcom BCM4315 802.11 Hybrid Wireless Controller 5.60.48.36

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers